Crashes when I try to print this page.

VERIFIED DUPLICATE of bug 176030

Status

()

--
critical
VERIFIED DUPLICATE of bug 176030
16 years ago
16 years ago

People

(Reporter: srt, Assigned: karnaze)

Tracking

({crash})

Trunk
x86
All
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021014 Phoenix/0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021014 Phoenix/0.3

Crashes when I try to print this page.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Actual Results:  
"0x00000901" referenced "0x00000901" which could not be "read"


Page prints fine with Mozilla.
Confirming with latest Phoenix (20021028) and Mozilla (2002102814) builds
running under W2K SP3. Both crash when printing the given URL. See TB13237353G.
I'm raising severity to critical and changing product to Mozilla browser.
Severity: normal → critical
Status: UNCONFIRMED → NEW
Component: General → Printing
Ever confirmed: true
Keywords: crash
Product: Phoenix → Browser
Version: unspecified → other
Reassigning new bug to printing experts.
Assignee: blaker → rods
QA Contact: asa → sujay

Comment 3

16 years ago
Confirmed also on Linux 2002102804

Comment 4

16 years ago
nsBlockFrame::VerifyOverflowSituation(nsIPresContext * 0x03de9518) line 6776 + 3
bytes
nsBlockFrame::DrainOverflowLines(nsIPresContext * 0x03de9518) line 4621
nsBlockFrame::Reflow(nsBlockFrame * const 0x03fbd128, nsIPresContext *
0x03de9518, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...},
unsigned int & 0) line 934
nsContainerFrame::ReflowChild(nsIFrame * 0x03fbd128, nsIPresContext *
0x03de9518, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int
14, int 1582, unsigned int 0, unsigned int & 0) line 926 + 31 bytes
nsTableCellFrame::Reflow(nsTableCellFrame * const 0x03fbd0c8, nsIPresContext *
0x03de9518, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...},
unsigned int & 0) line 951
nsContainerFrame::ReflowChild(nsIFrame * 0x03fbd0c8, nsIPresContext *
0x03de9518, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0,
int 0, unsigned int 0, unsigned int & 0) line 926 + 31 bytes
nsTableRowFrame::ReflowChildren(nsTableRowFrame * const 0x03fbd030,
nsIPresContext * 0x03de9518, nsHTMLReflowMetrics & {...}, const
nsHTMLReflowState & {...}, nsTableFrame & {...}, unsigned int & 0, int 0) line
1054 + 45 bytes
nsTableRowFrame::Reflow(nsTableRowFrame * const 0x03fbd030, nsIPresContext *
0x03de9518, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...},
unsigned int & 0) line 1467 + 37 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x03fbd030, nsIPresContext *
0x03de9518, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0,
int 28084, unsigned int 0, unsigned int & 0) line 926 + 31 bytes
nsTableRowGroupFrame::ReflowChildren(nsTableRowGroupFrame * const 0x03faccf4,
nsIPresContext * 0x03de9518, nsHTMLReflowMetrics & {...}, nsRowGroupReflowState
& {...}, unsigned int & 0, nsTableRowFrame * 0x00000000, int 0, nsTableRowFrame
* * 0x00000000, int * 0x00129ae8) line 444 + 45 bytes
nsTableRowGroupFrame::Reflow(nsTableRowGroupFrame * const 0x03faccf4,
nsIPresContext * 0x03de9518, nsHTMLReflowMetrics & {...}, const
nsHTMLReflowState & {...}, unsigned int & 0) line 1342 + 35 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x03faccf4, nsIPresContext *
0x03de9518, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int
14, int 14, unsigned int 0, unsigned int & 0) line 926 + 31 bytes
nsTableFrame::ReflowChildren(nsTableFrame * const 0x03facc6c, nsIPresContext *
0x03de9518, nsTableReflowState & {...}, int 1, int 0, unsigned int & 0, nsIFrame
* & 0x00000000, int * 0x00000000) line 3304 + 50 bytes
nsTableFrame::ReflowTable(nsIPresContext * 0x03de9518, nsHTMLReflowMetrics &
{...}, const nsHTMLReflowState & {...}, int 1073741824, nsReflowReason
eReflowReason_Resize, nsIFrame * & 0x00000000, int & 0, int & 1, unsigned int &
0) line 2204
nsTableFrame::Reflow(nsTableFrame * const 0x03facc6c, nsIPresContext *
0x03de9518, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...},
unsigned int & 0) line 2070
Assignee: rods → karnaze

Updated

16 years ago
OS: Windows 2000 → All
(Assignee)

Comment 5

16 years ago
Probably a dup of bug 176030, but I can't verify it right now.
Depends on: 176030

Comment 6

16 years ago
the patch in bug 176030 does fix the crash here.

Comment 7

16 years ago
Then it is a dupe of bug 176030

*** This bug has been marked as a duplicate of 176030 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 8

16 years ago
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.