Closed Bug 1772901 Opened 6 months ago Closed 6 months ago

Disable InstallTrigger implementation

Categories

(Toolkit :: Add-ons Manager, task, P2)

task
Points:
1

Tracking

()

RESOLVED FIXED
103 Branch
Tracking Status
firefox103 --- fixed

People

(Reporter: rpl, Assigned: rpl)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [addons-jira])

Attachments

(1 file)

As a follow up of Bug 1754441, this bugzilla issue is tracking fully disabling the InstallTrigger implementation (by setting the about:config pref "extensions.InstallTriggerImpl.enabled" to false) in Nightly and let it ride the train to the other release channels.

The InstallTrigger global will still be enumerable (completely hiding the global is controlled by the separate about:config pref "extensions.InstallTrigger.enabled").

With the InstallTrigger global still enumerable but the InstallTrigger implementation disabled, null will be the value associated to the InstallTrigger global and it will still pass the typeof InstallTrigger !== "undefined" check often used user agent detection to recognize Firefox.

A separate bugzilla issue will track the followup of fully hiding the InstallTrigger global, because there are separate webcompat issues to consider due to the user agent detection use case.

See Also: → 1772905
Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/028200d817a0
Disable InstallTrigger methods. r=webcompat-reviewers,denschub,willdurand

Backed out for for causing failures on browser_dom_nodes_highlight.js

Backout link : https://hg.mozilla.org/integration/autoland/rev/f4824bdc3f8425ae14532c0b527bc54fe020c736

Push with failures: https://treeherder.mozilla.org/jobs?repo=autoland&selectedTaskRun=MpsFrtQbTHubtiEymGjYHw.0&resultStatus=usercancel%2Cretry%2Ctestfailed%2Cbusted%2Cexception%2Crunnable&revision=202d54fa588bc71ff4bf8117e6682d2ca758b729

Link to failure log: https://treeherder.mozilla.org/logviewer?job_id=380934352&repo=autoland&lineNumber=2530

Failure line:
TEST-UNEXPECTED-FAIL | devtools/client/dom/test/browser_dom_nodes_highlight.js | The correct node was highlighted - Got "h2", expected "h1"

Flags: needinfo?(lgreco)

I looked into the unexpected failure triggered in the apparently unrelated devtools DOM panel test, and I confirmed that it is:

  • due to an assumption in a couple of devtools DOM panel test case (which expects a certain number of rows by assuming that InstallTrigger is listed as a window global before the DOM nodes actually covered by the test, see Bug 1772905 comment 8)
  • those failures are triggered by Bug 1772905 and completely unrelated from the patch attached to this bug (which was merely part of the same push to autoland).

I'm going to push the patch attached to this bug on its own, and I've added a proposed tweak to the test case to Bug 1772905 (which I'll defer re-landing until the new patch has been reviewed and it is ready to land).

Flags: needinfo?(lgreco)
Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/cf9ea7c98e76
Disable InstallTrigger methods. r=webcompat-reviewers,denschub,willdurand
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 103 Branch
Regressions: 1773873
See Also: → 1774005
Blocks: 1776426
You need to log in before you can comment on or make changes to this bug.