Open Bug 1773226 Opened 2 years ago Updated 5 months ago

A browser window sometimes blinks (open and immediately close) on browser toolbox startup

Categories

(DevTools :: Framework, defect, P3)

defect

Tracking

(Not tracked)

People

(Reporter: ochameau, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 obsolete file)

This seems to reproduce when opening links from the browser toolbox.
For example opening a profile record, or clicking any links in the browser that will open in firefox UI.
Then, when you are going to restart the browser toolbox, you will always see this browser ui window briefly appearing and disappearing.

In bug 1773037 I tried to disable session restore, but it doesn't seem to be enough.

I do not reproduce on macos, will check on windows.

Severity: -- → S3
Flags: needinfo?(jdescottes)
Priority: -- → P3

I think I reproduced on windows, but the flashing is barely noticeable. The exact STRs for me where:

  • open Firefox
  • open Browser Toolbox
  • open another Browser Toolbox from the first Browser Toolbox
  • in this second Browser Toolbox capture a profile, wait until the profile opens in a window/tab
  • close the second Browser Toolbox window (do not close the window which shows the profile first)
  • reopen the second Browser Toolbox

It seems really important that the additional window gets closed because we close the second BT, and has not been cleanly closed manually before. This would indeed seem to indicate that some flag forces to try and restore a previous session?

Flags: needinfo?(jdescottes)
Attachment #9387450 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: