Closed Bug 1773413 Opened 2 months ago Closed 2 months ago

Stop autofilling matched with protocol part when user’s input has no protocol expression.

Categories

(Firefox :: Address Bar, defect, P1)

defect

Tracking

()

VERIFIED FIXED
103 Branch
Tracking Status
firefox103 --- verified

People

(Reporter: daisuke, Assigned: daisuke)

References

Details

Attachments

(1 file)

Adaptive history autofill candidates are basically fixed url, but if user’s input starts with URI scheme, the autofill target will be full url.

Depends on: 1597791
Severity: -- → S3
Priority: -- → P1
Pushed by dakatsuka.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4ccd82ad4423
Stop autofilling matched with protocol part when user's input has no protocol expression. r=adw
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 103 Branch
Flags: qe-verify+
Flags: in-testsuite+

STR for QA

  1. Set browser.urlbar.autoFill.adaptiveHistory.enabled to true
  2. Open a new tab and visit https://www.nytimes.com/section/health
  3. Open a new tab and close the one from the previous step
  4. Type h in the urlbar and pick the result with the URL from step 2
  5. Open a new tab and close the one from the previous step
  6. Type h in the urlbar
  7. Verify that the URL from step 2 does not autofill

Basically we want to make sure that when you create some adaptive history with a search string like "h", "ht", "htt", etc. but the domain name of the URL does not start with "h", the URL should not be autofilled by adaptive history. In the STR above, adaptive history is created with "h" because "h" matches "health", but the URL domain name "nytimes.com" does not start with "h", and therefore the URL shouldn't be autofilled.

Thank you for providing the steps for testing Drew.
The issue is verified fixed in the latest Fx103.0a1 on Windows 10 and Ubuntu 20.04. There is no autofill for the letter 'h'.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.