form elements not cleared on meta-refresh

VERIFIED DUPLICATE of bug 46845

Status

()

Core
HTML: Form Submission
VERIFIED DUPLICATE of bug 46845
15 years ago
13 years ago

People

(Reporter: azimuth, Assigned: Alexandru Savulov)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016

In the prepared page at http://www.sanctuary.org/~azimuth/mozilla-bug.html,
there are two radio buttons.  This page refreshes every five seconds. Mozilla
ignores the lack of a checked directive, choosing instead to keep the selected
radio button.  This was no doubt considered a feature at one time, but it screws
with some sites, in which the lack of a selection is meaningful within the
application.

Reproducible: Always

Steps to Reproduce:
1. Go to http://www.sanctuary.org/~azimuth/mozilla-bug.html
2. Click on a radio button
3. Wait for refresh

Actual Results:  
The selected radio button continued to stay selected.

Expected Results:  
The state of all input fields (including the demonstration radio buttons) should
have been reset on refresh.

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.