Closed Bug 1773483 Opened 2 months ago Closed 1 day ago

The "View saved logins" footer shows a piece of Code before the "Import your login from Google Chrome" text is displayed

Categories

(Toolkit :: Password Manager, defect, P1)

Desktop
Windows
defect

Tracking

()

RESOLVED FIXED
105 Branch
Tracking Status
firefox101 --- affected
firefox102 --- affected
firefox103 --- affected
firefox104 --- wontfix
firefox105 --- fixed

People

(Reporter: rares.doghi, Assigned: serg)

Details

Attachments

(2 files)

Attached image Chromewhat.png

[Affected platforms]:
Platforms: ALL

103.0a1 (2022-06-05)

[Steps to reproduce]

  1. Reach Gmail.com
  2. Observe the View Saved Logins footer.

[Expected result]
The Json object (code) should not be visible in the View Saved login footer.

[Actual result]
A piece of code is displayed for a split second in the View Saved logins footer right before the "Import your login from Google Chrome" text is displayed.

Please note that this issue is barely noticeable in any version of Firefox, the screenshot was taken from a slow motion recording.
We can barely see the text from the View saved login footer before it changes.

OS: Unspecified → Windows
Assignee: nobody → sgalich
Priority: -- → P1
Has STR: --- → yes
Attachment #9288741 - Attachment description: WIP: Bug 1773483 → Bug 1773483 - skip default subtitle rendering in login autocomplete for import r=dimi!
Pushed by sgalich@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8045967b0150
skip default subtitle rendering in login autocomplete for import r=dimi
Status: NEW → RESOLVED
Closed: 1 day ago
Resolution: --- → FIXED
Target Milestone: --- → 105 Branch

Since nightly and release are affected, beta will likely be affected too.
For more information, please visit auto_nag documentation.

The patch landed in nightly and beta is affected.
:serg, is this bug important enough to require an uplift?

  • If yes, please nominate the patch for beta approval.
  • If no, please set status-firefox104 to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(sgalich)
Flags: needinfo?(sgalich)
You need to log in before you can comment on or make changes to this bug.