Closed Bug 1773794 Opened 2 years ago Closed 2 years ago

Update PDF.js to new version a57a4bc6c2311b13ca490a97e417eee992694168 from 2022-06-10 20:18:35

Categories

(Firefox :: PDF Viewer, enhancement)

enhancement

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox103 --- affected

People

(Reporter: update-bot, Unassigned)

Details

(Whiteboard: [3pl-filed][task_id: d1N7ZV2TR9GQVmpPLKwZuQ])

Attachments

(1 obsolete file)

This update covers 26 commits:


e046b811b7ceb419c8b7d29244dd2bdcd55f86f2 by Jonas Jenwald

https://github.com/mozilla/pdf.js-/commit/e046b811b7ceb419c8b7d29244dd2bdcd55f86f2
Authored: 2022-06-10 09:53:52 +0200
Committed: 2022-06-10 22:12:32 +0200

Expose TextLayerRenderTask in the TypeScript definitions (issue 15016, PR 14013 follow-up)

While TextLayerRenderTask apparently makes sense in TypeScript environments, given that it's being returned by the renderTextLayer-function in the API, we really don't want to extend the public API by simply exporting the class directly in src/pdf.js since it should never be called/initialized manually.
Hence we follow the same pattern as in PR 14013, and add some very basic unit-tests to ensure that renderTextLayer always returns a TextLayerRenderTask-instance as expected.

Files Added:

  • test/unit/text_layer_spec.js
  • test/unit/text_layer_spec.js

Files Added:

  • src/display/text_layer.js
  • src/pdf.js
  • test/unit/clitests.json
  • test/unit/jasmine-boot.js
  • src/display/text_layer.js
  • src/pdf.js
  • test/unit/clitests.json
  • test/unit/jasmine-boot.js

bfe816d0d29e52e89e824fbde9d70248d85b25ac by Calixte Denizet

https://github.com/mozilla/pdf.js-/commit/bfe816d0d29e52e89e824fbde9d70248d85b25ac
Authored: 2022-06-10 16:40:55 +0200
Committed: 2022-06-10 18:45:02 +0200

Add an empty entry in combo list when nothing is selected (bug 1773680)

Files Added:

  • src/display/annotation_layer.js
  • src/display/annotation_layer.js

b716e82d180708d2eabdd08a3b20b4f5a6a6bde0 by jerry1100

https://github.com/mozilla/pdf.js-/commit/b716e82d180708d2eabdd08a3b20b4f5a6a6bde0
Authored: 2022-06-09 14:38:16 -0700
Committed: 2022-06-10 06:50:47 -0700

Extend TextLayerRenderParameters.container type to include HTMLElement.

In PR #14717, the type was changed from a HTMLElement to a DocumentFragment.
This broke TypeScript projects that use a HTMLElement container.

To remedy this, we extend the type of container to also include HTMLElement.

Files Added:

  • src/display/text_layer.js
  • src/display/text_layer.js

c8f6cb9fcf8bb555bcc4bbe761b82bc85e939131 by calixteman

https://github.com/mozilla/pdf.js-/commit/c8f6cb9fcf8bb555bcc4bbe761b82bc85e939131
Authored: 2022-06-10 11:34:28 +0200
Committed: 2022-06-10 11:34:28 +0200

Revert "Change the name of the generated pdf.sandbox.external for mozilla-central"

Files Added:

  • gulpfile.js
  • gulpfile.js

9ac453669329750fefeda7aa757886d69bd291ba by Jonas Jenwald

https://github.com/mozilla/pdf.js-/commit/9ac453669329750fefeda7aa757886d69bd291ba
Authored: 2022-06-09 12:53:39 +0200
Committed: 2022-06-09 21:21:19 +0200

Enable the unicorn/prefer-at ESLint plugin rule (PR 15008 follow-up)

Please find additional information here:

Files Added:

  • .eslintrc
  • external/.eslintrc
  • src/core/catalog.js
  • src/core/crypto.js
  • src/core/document.js
  • src/core/evaluator.js
  • src/core/font_renderer.js
  • src/core/fonts.js
  • src/core/function.js
  • src/core/operator_list.js
  • src/core/pattern.js
  • src/core/type1_parser.js
  • src/core/writer.js
  • src/core/xfa/builder.js
  • src/core/xfa/data.js
  • src/core/xfa/formcalc_parser.js
  • src/core/xfa/html_utils.js
  • src/core/xfa/som.js
  • src/core/xfa/template.js
  • src/core/xfa/text.js
  • src/core/xfa/xhtml.js
  • src/core/xfa_fonts.js
  • src/core/xml_parser.js
  • src/display/editor/fit_curve/fit_curve.js
  • src/display/svg.js
  • src/display/text_layer.js
  • src/display/xfa_layer.js
  • src/shared/compatibility.js
  • test/resources/reftest-analyzer.js
  • test/test.js
  • test/unit/ui_utils_spec.js
  • web/ui_utils.js
  • .eslintrc
  • external/.eslintrc
  • src/core/catalog.js
  • src/core/crypto.js
  • src/core/document.js
  • src/core/evaluator.js
  • src/core/font_renderer.js
  • src/core/fonts.js
  • src/core/function.js
  • src/core/operator_list.js
  • src/core/pattern.js
  • src/core/type1_parser.js
  • src/core/writer.js
  • src/core/xfa/builder.js
  • src/core/xfa/data.js
  • src/core/xfa/formcalc_parser.js
  • src/core/xfa/html_utils.js
  • src/core/xfa/som.js
  • src/core/xfa/template.js
  • src/core/xfa/text.js
  • src/core/xfa/xhtml.js
  • src/core/xfa_fonts.js
  • src/core/xml_parser.js
  • src/display/editor/fit_curve/fit_curve.js
  • src/display/svg.js
  • src/display/text_layer.js
  • src/display/xfa_layer.js
  • src/shared/compatibility.js
  • test/resources/reftest-analyzer.js
  • test/test.js
  • test/unit/ui_utils_spec.js
  • web/ui_utils.js

c161a86ba150d65c270247c6fb5daf80e246770e by Calixte Denizet

https://github.com/mozilla/pdf.js-/commit/c161a86ba150d65c270247c6fb5daf80e246770e
Authored: 2022-06-04 23:28:19 +0200
Committed: 2022-06-09 19:35:59 +0200

[editor] Add an Ink editor

  • Approximate the drawn curve by a set of Bezier curves in using
    js code from https://github.com/soswow/fit-curves.
    The code has been slightly modified in order to make the linter
    happy.

Files Added:

  • src/display/editor/fit_curve/fit_curve.js
  • src/display/editor/ink.js
  • web/images/toolbarButton-editorInk.svg
  • src/display/editor/fit_curve/fit_curve.js
  • src/display/editor/ink.js
  • web/images/toolbarButton-editorInk.svg

Files Added:

  • l10n/en-US/viewer.properties
  • src/display/editor/annotation_editor_layer.js
  • src/display/editor/freetext.js
  • src/shared/util.js
  • web/annotation_editor_layer_builder.css
  • web/app.js
  • web/app_options.js
  • web/toolbar.js
  • web/viewer.css
  • web/viewer.html
  • web/viewer.js
  • l10n/en-US/viewer.properties
  • src/display/editor/annotation_editor_layer.js
  • src/display/editor/freetext.js
  • src/shared/util.js
  • web/annotation_editor_layer_builder.css
  • web/app.js
  • web/app_options.js
  • web/toolbar.js
  • web/viewer.css
  • web/viewer.html
  • web/viewer.js

6371a7605d4b5d0419f5b957cd2e7bd206107830 by Jonas Jenwald

https://github.com/mozilla/pdf.js-/commit/6371a7605d4b5d0419f5b957cd2e7bd206107830
Authored: 2022-06-09 14:46:47 +0200
Committed: 2022-06-09 15:10:58 +0200

Force-install npm packages to try and fix the repeated GitHub Action failures

Files Added:

  • .github/workflows/ci.yml
  • .github/workflows/ci.yml

3d244cb6a8d0eb7f50eb6ee7f1ad4a4b8f4a2abe by Jonas Jenwald

https://github.com/mozilla/pdf.js-/commit/3d244cb6a8d0eb7f50eb6ee7f1ad4a4b8f4a2abe
Authored: 2022-06-09 14:06:51 +0200
Committed: 2022-06-09 15:10:54 +0200

Render PopupAnnotations even if they have missing or empty /Rect-entries (issue 15012, PR 14439 follow-up)

This only applies to corrupt PDF documents, where Annotations are missing the required /Rect-entry. Rendering PopupAnnotations unconditionally shouldn't be a problem, since we're not using a BaseSVGFactory-instance in that case.

Files Added:

  • test/pdfs/issue15012.pdf
  • test/pdfs/issue15012.pdf

Files Added:

  • src/display/annotation_layer.js
  • test/pdfs/.gitignore
  • test/test_manifest.json
  • src/display/annotation_layer.js
  • test/pdfs/.gitignore
  • test/test_manifest.json

66bbc0e7ee03c0584dfa111ba08360b365d1ee66 by Jonas Jenwald

https://github.com/mozilla/pdf.js-/commit/66bbc0e7ee03c0584dfa111ba08360b365d1ee66
Authored: 2022-06-09 10:11:01 +0200
Committed: 2022-06-09 10:11:01 +0200

Call WidgetAnnotation._getTextWidth correctly from the ChoiceWidgetAnnotation-class (PR 14720 follow-up)

In the "no fontSize available" code-path, in the ChoiceWidgetAnnotation._getAppearance method, we don't provide the necessary second argument when calling the _getTextWidth-method which will cause errors to be thrown.

Files Added:

  • src/core/annotation.js
  • src/core/annotation.js

b5cad9be03a11f58731bf946c6fe2d0c6b649963 by Jonas Jenwald

https://github.com/mozilla/pdf.js-/commit/b5cad9be03a11f58731bf946c6fe2d0c6b649963
Authored: 2022-06-09 10:03:36 +0200
Committed: 2022-06-09 10:03:36 +0200

Fix a bug in the ColorConverters.CMYK_HTML method (PR 12631 follow-up)

Because of a small oversight, this method accidentally handled the intermediate array incorrectly.

Files Added:

  • src/shared/scripting_utils.js
  • src/shared/scripting_utils.js

7a89f4a78979c2f3532d483877c0e996884660ff by Jonas Jenwald

https://github.com/mozilla/pdf.js-/commit/7a89f4a78979c2f3532d483877c0e996884660ff
Authored: 2022-06-09 09:52:28 +0200
Committed: 2022-06-09 09:52:28 +0200

Set the MIME type correctly when downloading fonts in debugger.js (PR 5366 follow-up)

Because of a capitalization error, the MIME type wasn't actually being set correctly. However, please note that downloading of font files still worked correctly which is probably why this has gone unnoticed since 2014.

Files Added:

  • web/debugger.js
  • web/debugger.js

36aae436bfea8db6d5384b53e91b76d97e281f6e by Calixte Denizet

https://github.com/mozilla/pdf.js-/commit/36aae436bfea8db6d5384b53e91b76d97e281f6e
Authored: 2022-06-08 20:05:25 +0200
Committed: 2022-06-08 22:16:01 +0200

[editor] Add support for saving newly added Ink

Files Added:

  • src/core/annotation.js
  • src/core/default_appearance.js
  • test/unit/annotation_spec.js
  • src/core/annotation.js
  • src/core/default_appearance.js
  • test/unit/annotation_spec.js

9e24a1660e4a1816c159f806e18ab169a3792852 by Jonas Jenwald

https://github.com/mozilla/pdf.js-/commit/9e24a1660e4a1816c159f806e18ab169a3792852
Authored: 2022-06-08 22:10:59 +0200
Committed: 2022-06-08 22:10:59 +0200

Polyfill Array.prototype.at with core-js (PR 14976 follow-up)

This Array-method is a fairly new addition to the ECMAScript specification, hence we need a polyfill to avoid the library/viewer breaking in older browsers.

Please find additional information at:

Files Added:

  • src/shared/compatibility.js
  • src/shared/compatibility.js

7773b3f5beb3441793208e27101b1ca5626b5ab9 by Calixte Denizet

https://github.com/mozilla/pdf.js-/commit/7773b3f5beb3441793208e27101b1ca5626b5ab9
Authored: 2022-06-01 15:42:46 +0200
Committed: 2022-06-08 14:34:09 +0200

[edition] Add support for saving a newly added FreeText

Files Added:

  • src/core/annotation.js
  • src/core/document.js
  • src/core/worker.js
  • src/core/writer.js
  • src/core/xref.js
  • src/display/editor/annotation_editor_layer.js
  • src/display/editor/editor.js
  • src/display/editor/freetext.js
  • src/shared/util.js
  • test/unit/annotation_spec.js
  • test/unit/test_utils.js
  • web/annotation_editor_layer_builder.css
  • src/core/annotation.js
  • src/core/document.js
  • src/core/worker.js
  • src/core/writer.js
  • src/core/xref.js
  • src/display/editor/annotation_editor_layer.js
  • src/display/editor/editor.js
  • src/display/editor/freetext.js
  • src/shared/util.js
  • test/unit/annotation_spec.js
  • test/unit/test_utils.js
  • web/annotation_editor_layer_builder.css

7b37af7eb4ea6c9f406446f9bffbc2d4560e7ae5 by Calixte Denizet

https://github.com/mozilla/pdf.js-/commit/7b37af7eb4ea6c9f406446f9bffbc2d4560e7ae5
Authored: 2022-06-08 09:26:17 +0200
Committed: 2022-06-08 10:36:38 +0200

Change the name of the generated pdf.sandbox.external for mozilla-central

This patch is blocking https://phabricator.services.mozilla.com/D148600.

Files Added:

  • gulpfile.js
  • gulpfile.js

8c9678158eaf633ee5136654465b4cd512217f68 by Marco Castelluccio

https://github.com/mozilla/pdf.js-/commit/8c9678158eaf633ee5136654465b4cd512217f68
Authored: 2022-06-07 18:56:30 +0200
Committed: 2022-06-07 18:56:30 +0200

Set "presentation" role for page canvases (issue 14437)

Files Added:

  • web/pdf_page_view.js
  • web/pdf_page_view.js

2dd0c861bff6bfa53b1b3096754f7fb534203d25 by Calixte Denizet

https://github.com/mozilla/pdf.js-/commit/2dd0c861bff6bfa53b1b3096754f7fb534203d25
Authored: 2022-06-07 14:44:17 +0200
Committed: 2022-06-07 17:02:11 +0200

Outline fields which are required (bug 1724918)

Files Added:

Files Added:

  • src/core/annotation.js
  • src/core/xfa/template.js
  • src/display/annotation_layer.js
  • test/pdfs/.gitignore
  • test/test_manifest.json
  • web/annotation_layer_builder.css
  • web/xfa_layer_builder.css
  • src/core/annotation.js
  • src/core/xfa/template.js
  • src/display/annotation_layer.js
  • test/pdfs/.gitignore
  • test/test_manifest.json
  • web/annotation_layer_builder.css
  • web/xfa_layer_builder.css

96d0d22d66cfbab6d0f5b213251db9a2653c7745 by Calixte Denizet

https://github.com/mozilla/pdf.js-/commit/96d0d22d66cfbab6d0f5b213251db9a2653c7745
Authored: 2022-06-06 17:24:38 +0200
Committed: 2022-06-07 14:59:02 +0200

Reset all the canvas states after rendering each annotations (#14105)

  • each annotation must be rendered independently of the others. So
    after having rendered each annotation, the canvas states are reset
    in order to have something clean to render the next one.

Files Added:

  • test/pdfs/issue14105.pdf.link
  • test/pdfs/issue14105.pdf.link

Files Added:

  • src/display/canvas.js
  • test/test_manifest.json
  • src/display/canvas.js
  • test/test_manifest.json

e82ad79eb91937e1cf70d2a08b9e663dcb92b12b by Jonas Jenwald

https://github.com/mozilla/pdf.js-/commit/e82ad79eb91937e1cf70d2a08b9e663dcb92b12b
Authored: 2022-06-05 15:35:04 +0200
Committed: 2022-06-05 15:38:28 +0200

Conditionally bundle gulp image_decoders-specific code in src/core/jbig2.js (PR 9729 follow-up)

This method/function was added only for the gulp image_decoders-builds, and is completely unused elsewhere (e.g. in the Firefox PDF Viewer).
While this only reduces the size of the built pdf.worker.js file by a little over 1 kB, it can't hurt to remove completely unused code from the "normal" builds.

Files Added:

  • src/core/jbig2.js
  • src/core/jbig2.js

51c47acb41c4af385acb16fc8db953f96317b15f by Jonas Jenwald

https://github.com/mozilla/pdf.js-/commit/51c47acb41c4af385acb16fc8db953f96317b15f
Authored: 2022-06-05 14:02:16 +0200
Committed: 2022-06-05 14:05:44 +0200

[editor] Update the AnnotationStorage.hash-getter to support editing

While calling JSON.stringify(...) on a class-instance obviously "works" (as in it doesn't throw), since it's really just an Object, it doesn't really make much sense in the context of the AnnotationStorage.hash-getter.

Also, access the inverse Viewport-transform correctly in FreeTextEditor.serialize to prevent errors being thrown when that method is invoked.

Finally, slightly updates the AnnotationStorage.serializable-getter to improve consistency within the class.

Files Added:

  • src/display/annotation_storage.js
  • src/display/editor/freetext.js
  • src/display/annotation_storage.js
  • src/display/editor/freetext.js

59dd4ea2b0d9280996e877bd7eef61a6f72d8e63 by Jonas Jenwald

https://github.com/mozilla/pdf.js-/commit/59dd4ea2b0d9280996e877bd7eef61a6f72d8e63
Authored: 2022-06-05 12:12:05 +0200
Committed: 2022-06-05 12:39:23 +0200

Lookup image-data correctly in paintImageMaskXObjectGroup (issue 14990)

This fixes a regression from PR 14754.

We didn't lookup the image-data correctly, with the result that we tried to render some ImageMasks using a string rather than the intended TypedArray. To make matters worse, this code-path was apparently not properly covered by existing test-cases.

Files Added:

  • test/pdfs/issue14990.pdf.link
  • test/pdfs/issue14990.pdf.link

Files Added:

  • src/display/canvas.js
  • test/test_manifest.json
  • src/display/canvas.js
  • test/test_manifest.json

d34e7fff012086a5423fe5d9197a19e57e849135 by Jonas Jenwald

https://github.com/mozilla/pdf.js-/commit/d34e7fff012086a5423fe5d9197a19e57e849135
Authored: 2022-06-05 10:00:08 +0200
Committed: 2022-06-05 10:00:08 +0200

[editor] Disable the editor-buttons in XFA documents

Given the differences between XFA documents and "normal" PDF documents, we don't support editing of the former ones. Hence, when a XFA-document is opened, we temporarily disable the editor-buttons.

Files Added:

  • web/app.js
  • web/app_options.js
  • web/base_viewer.js
  • web/toolbar.js
  • web/viewer.css
  • web/viewer.js
  • web/app.js
  • web/app_options.js
  • web/base_viewer.js
  • web/toolbar.js
  • web/viewer.css
  • web/viewer.js

dd586715890c3fb1f14eeecde0e8a0d69f608920 by Jonas Jenwald

https://github.com/mozilla/pdf.js-/commit/dd586715890c3fb1f14eeecde0e8a0d69f608920
Authored: 2022-06-04 23:10:58 +0200
Committed: 2022-06-04 23:10:58 +0200

Remove mention of gulp singlefile-command from examples/node/getinfo.js

This comment should've been removed in PR 9385, but better late than never I suppose.

Files Added:

  • examples/node/getinfo.js
  • examples/node/getinfo.js

51bf92806185befd830c07f25e4feed01b3a1620 by Jonas Jenwald

https://github.com/mozilla/pdf.js-/commit/51bf92806185befd830c07f25e4feed01b3a1620
Authored: 2022-06-04 21:32:27 +0200
Committed: 2022-06-04 21:48:11 +0200

[editor] A couple of small FreeText-related fixes (PR 14976 follow-up)

  • Ensure that the modified-warning won't be displayed, when navigating away from the viewer, if the user has added custom Annotations and then removed all of them.
  • Ensure that the initial editor-buttons state, i.e. the toggled-class, is correctly displayed in the toolbar when then viewer loads.
  • Tweak the CSS-classes for the editor-buttons, such that they use the correct focus/hover-rules (similar to the sidebar-buttons).
  • Remove a no longer accurate comment from the BaseViewer.annotationEditorMode-setter.
  • Address a couple of smaller outstanding review comments, including some re-formatting changes, from PR 14976.

Files Added:

  • l10n/en-US/viewer.properties
  • src/display/annotation_storage.js
  • src/shared/util.js
  • web/base_viewer.js
  • web/l10n_utils.js
  • web/toolbar.js
  • web/viewer.html
  • web/viewer.js
  • l10n/en-US/viewer.properties
  • src/display/annotation_storage.js
  • src/shared/util.js
  • web/base_viewer.js
  • web/l10n_utils.js
  • web/toolbar.js
  • web/viewer.html
  • web/viewer.js

be1aa119860d30c610f6f77b38b4df3c50c559e5 by Calixte Denizet

https://github.com/mozilla/pdf.js-/commit/be1aa119860d30c610f6f77b38b4df3c50c559e5
Authored: 2022-06-01 10:38:08 +0200
Committed: 2022-06-04 18:20:11 +0200

[edition] Add a FreeText editor (#14970) - add a basic UI to edit some text in a pdf; - an editor can be moved, suppressed, cut, copied, pasted, selected; - add an undo/redo manager.

Files Added:

  • src/display/editor/annotation_editor_layer.js
  • src/display/editor/editor.js
  • src/display/editor/freetext.js
  • src/display/editor/tools.js
  • test/integration/freetext_editor_spec.js
  • web/annotation_editor_layer_builder.css
  • web/annotation_editor_layer_builder.js
  • web/images/toolbarButton-editorFreeText.svg
  • web/images/toolbarButton-editorNone.svg
  • src/display/editor/annotation_editor_layer.js
  • src/display/editor/editor.js
  • src/display/editor/freetext.js
  • src/display/editor/tools.js
  • test/integration/freetext_editor_spec.js
  • web/annotation_editor_layer_builder.css
  • web/annotation_editor_layer_builder.js
  • web/images/toolbarButton-editorFreeText.svg
  • web/images/toolbarButton-editorNone.svg

Files Added:

  • extensions/chromium/preferences_schema.json
  • l10n/en-US/viewer.properties
  • src/display/annotation_storage.js
  • src/pdf.js
  • src/shared/util.js
  • test/integration-boot.js
  • test/test.js
  • web/app.js
  • web/app_options.js
  • web/base_viewer.js
  • web/default_factory.js
  • web/interfaces.js
  • web/l10n_utils.js
  • web/pdf_page_view.js
  • web/pdf_viewer.css
  • web/toolbar.js
  • web/viewer.css
  • web/viewer.html
  • web/viewer.js
  • extensions/chromium/preferences_schema.json
  • l10n/en-US/viewer.properties
  • src/display/annotation_storage.js
  • src/pdf.js
  • src/shared/util.js
  • test/integration-boot.js
  • test/test.js
  • web/app.js
  • web/app_options.js
  • web/base_viewer.js
  • web/default_factory.js
  • web/interfaces.js
  • web/l10n_utils.js
  • web/pdf_page_view.js
  • web/pdf_viewer.css
  • web/toolbar.js
  • web/viewer.css
  • web/viewer.html
  • web/viewer.js

bb8f5ec20bf6a2fed1f962178b06bc4d99d1e2ef by Jonas Jenwald

https://github.com/mozilla/pdf.js-/commit/bb8f5ec20bf6a2fed1f962178b06bc4d99d1e2ef
Authored: 2022-06-04 17:43:22 +0200
Committed: 2022-06-04 18:11:35 +0200

Bundle the <dialog> polyfill-CSS in the GENERIC legacy/-viewer (PR 14710 follow-up)

In PR 14710 we only included the JavaScript-part of the polyfill, however we probably need to include the CSS as well to reduce the risk of problems in older browsers.

With the recent CSS-related improvements in the preprocess-function we could probably have included this conditionally in the viewer.css file. However, considering that the <dialog> polyfill-code is only invoked when actually needed it seemed most appropriate/correct to lazy-load the polyfill-CSS as well.

Files Added:

  • gulpfile.js
  • web/overlay_manager.js
  • gulpfile.js
  • web/overlay_manager.js

It looks like we experienced one or more build failures when trying to apply this
update. You will need to apply this update manually; you can replicate the patch
locally with ./mach vendor toolkit/components/pdfjs/moz.yaml. I'm going to abandon the Phabricator patch and
let you submit a new one.

If the build failure wasn't caused by a library change, and was instead caused by
something structural in the build system please let my maintainers know in
Slack:#secinf.

I do my best to automatically add new files to the build, but some moz.build files
are complicated and you may need to fix them manually.

Flags: needinfo?(cdenizet)
Attachment #9280780 - Attachment is obsolete: true

We are going to update to a newer commit.

No longer blocks: pdfjs-updates
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(cdenizet)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.