mozilla 1.1/1.2b without debugging does not start

RESOLVED DUPLICATE of bug 124958

Status

SeaMonkey
Build Config
RESOLVED DUPLICATE of bug 124958
15 years ago
12 years ago

People

(Reporter: hans adams, Assigned: Daniel (Leaf) Nunes)

Tracking

Trunk
x86
OpenBSD

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
running on:

OpenBSD gateway.emil-kammerer.de 3.1 GENERIC#59 i386

./configure --prefix=/opt/mozilla-1.1 --disable-shared --enable-static
--disable-debug

MAKE="gmake"
export MAKE
gmake
gmake install

prevents mozilla from crashing, but, except transforming profiles (once), it
does not work at all. After initialization Mozilla does not consume any cpu
time.

 1972 p5  I+      0:00.01 /bin/sh /opt/mozilla-1.1/lib/mozilla-1.1/run-mozilla.
23664 p5  I+      0:00.56 /opt/mozilla-1.1/lib/mozilla-1.1/mozilla-bin
(Reporter)

Updated

15 years ago
Depends on: 177558
(Reporter)

Comment 1

15 years ago
Created attachment 104677 [details]
tail of trace produced by ktrace -di /opt/mozilla-1.1/bin/mozilla
what if you don't --enable-static and --disable-shared?
Then the openbsd build won't run w/o --enable-static --disable-shared. See bug
124958.

The output of ktrace doesn't appear to be useful. Do you have a gdb stack?  And
can you test using the mozilla1.2b release?  1.1 was released some time ago and
the code has changed substantially since then.

(Reporter)

Comment 4

15 years ago
Created attachment 104689 [details]
gdb stacktrace for mozilla-1.1, --disable-shared --enable-static
Hrmph.  That's still not helpful.  It makes it to main() so it's not hitting the
static constructor issue from bug 124958.  Try building with:
./configure --disable-shared --enable-static --disable-debug
--enable-optimize='-g' (or -ggdb) and try stepping through the build starting at
main1 and see where it dies.
(Reporter)

Comment 6

15 years ago
referring to additional comment #5:

Acording to your proposal compilation did not finish. Seems to be aproblem in ld
or collect2 of gcc 2.95.3, build 20010125.

Excerpt of log file from  final linking stage...

gmake[1]: Entering directory `/home/mozilla-1.1'
tier_0: config build include 
gmake[2]: Entering directory `/home/mozilla-1.1/config'
.
.
.
c++ -o mozilla-bin -I/usr/X11R6/include -fno-rtti -fno-exceptions -Wall
-Wconversion -Wpointer-arith -Wbad-function-cast -Wcast-align
-Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -pedantic -Wno-long-long
-pthread -pipe  -DNDEBUG -DTRIMMED -ggdb -O0
-DWIDGET_DLL=\"libwidget_gtk.so.1.0\" -DGFXWIN_DLL=\"libgfx_gtk.so.1.0\"
-I/usr/local/include/gtk-1.2 -I/usr/local/include/glib-1.2 -I/usr/X11R6/include 
nsAppRunner.o nsWindowCreator.o showOSAlert.o nsSigHandlers.o
nsStaticComponents.o nsNativeAppSupportGtk.o nsNativeAppSupportBase.o   
-L../../dist/bin -L../../dist/lib -L../../dist/lib/components -lxpconnect
-ljsloader -lxpctest -lunicharutil -luconv -lucvja -lucvcn -lucvlatin -lucvtw
-lucvtw2 -lucvko -lucvibm -lucvmath -lnslocale -lstrres -llwbrk -lchardet
-lnkcache -lnecko -lnecko2 -luriloader -lpref -loji -lcaps -lchrome -lrdf
-lhtmlpars -lgfxps -lgfx_gtk -lgfxxprint -lgfx2 -limglib2 -limgppm -limgpng
-limggif -limgjpeg -limgbmp -limgmng -limgxbm -lgkplugin -ljsurl -ljsdom
-lgkview -lwidget_gtk -lxremote_client -lgkcontent -lgklayout -lmork -ldocshell
-lembedcomponents -lwebbrwsr -leditor -lcomposer -ltxmgr -ltxtsvc -lprofile
-lnsprefm -laccessibility -lmozldap -lnsappshell -lfileview -lmozfind
-lregviewer -lshistory -lxremoteservice -lappcomps -lmozbrwsr -lcookie -lwallet
-lwalletviewers -lxmlextras -lautoconfig -ltransformiix -luniversalchardet
-lmailnews -lmsgdb -lmsgnews -llocalmail -lmimeemitter -lvcard -lsmimestb -lmime
-lmsgcompose -lmsgimap -laddrbook -limport -limpText -limpComm4xMail -labsyncsvc
-lmsgmdn -lunicharutil_s -ljsj -lgtksuperwin -lgtkxtbin -lxlibrgb -lgkgfx
-lmsgbaseutil -lmimecthglue_s  -L../../dist/lib/components -L../../dist/lib
-lmozpng -L../../dist/lib -lmozmng -L../../dist/lib -lmozjpeg -L../../dist/lib
-lmozz   -L/usr/X11R6/lib -lXp -lXext -lX11  -L../../dist/bin -L../../dist/lib
-lldap50 -llber50 -lprldap50  -L/usr/X11R6/lib -lXt -L../../dist/bin -lmozjs
-L../../dist/bin -lxpcom -L/home/mozilla-1.1/dist/lib -lplds4 -lplc4 -lnspr4  
-L/usr/local/lib -L/usr/X11R6/lib -lgtk -lgdk -lgmodule -lglib -lintl -lXext
-lX11 -lm -lm     
collect2: ld terminated with signal 11 [Segmentation fault]
gmake[2]: *** [mozilla-bin] Error 1
gmake[2]: Leaving directory `/home/mozilla-1.1/xpfe/bootstrap'
gmake[1]: *** [tier_99] Error 2
gmake[1]: Leaving directory `/home/mozilla-1.1'
gmake: *** [default] Error 2
.
.
.
..going to compile gcc-3.2 |-<<<

best Hans Adams
Because it's a debug build, it's eating up a lot of memory at link time.  IIRC,
on some *BSDs, you need to change one of per-process resource limits to get some
of the libraries to link. Try bumping the openfiles/descriptors to 512,
stacksize to 2M & the memoryuse vars to unlimited.
(Reporter)

Comment 8

15 years ago
... Sure I did ;->  

Initially starting with 8MB stack, but I increased up to following:
bash-2.05a# ulimit -a
core file size        (blocks, -c) unlimited
data seg size         (kbytes, -d) 1048576
file size             (blocks, -f) unlimited
max locked memory     (kbytes, -l) 78216
max memory size       (kbytes, -m) 234648
open files                    (-n) 128
pipe size          (512 bytes, -p) 1
stack size            (kbytes, -s) 16384
cpu time             (seconds, -t) unlimited
max user processes            (-u) 532
virtual memory        (kbytes, -v) 1064960

...and gave 1.2b a try:

To proof, that everything else is healthy, I compiled without debugging...
bash-2.05a# pwd
/home/mozilla-1.2b

bash-2.05a# ./configure --prefix=/opt/mozilla-1.2b \
> --disable-shared --enable-static \
> --disable-debug --enable-optimize="-O0"
gmake ...
.
.
.
everything went fine, and resulted in:

c++ -o mozilla-bin -I/usr/X11R6/include -fno-rtti -fno-exceptions -Wall
-Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth
-Wno-ctor-dtor-privacy -pedantic -Wno-long-long -pthread -pipe  -DNDEBUG
-DTRIMMED -O0 -DWIDGET_DLL=\"libwidget_gtk.so.1.0\"
-DGFXWIN_DLL=\"libgfx_gtk.so.1.0\" -I/usr/local/include/gtk-1.2
-I/usr/local/include/glib-1.2 -I/usr/X11R6/include  nsAppRunner.o
nsWindowCreator.o showOSAlert.o nsSigHandlers.o nsStaticComponents.o
nsNativeAppSupportGtk.o nsNativeAppSupportBase.o    -L../../dist/bin
-L../../dist/lib -L../../dist/lib/components -lxpconnect -lxpctest -luconv
-lucvmath -li18n -lnecko -lnecko2 -luriloader -lpref -loji -lcaps -lchrome -lrdf
-lhtmlpars -lgfxps -lgfx_gtk -lgfxxprint -limgmng -limglib2 -lgkplugin -ljsurl
-ljsdom -lgkview -lwidget_gtk -lxremote_client -lgkcontent -lgklayout -lmork
-ldocshell -lembedcomponents -lwebbrwsr -leditor -ltxmgr -lcomposer -lprofile
-lnsprefm -laccessibility -lmozldap -lnsappshell -lfileview -lmozfind
-lregviewer -lshistory -lxremoteservice -lappcomps -lcookie -lwallet
-lwalletviewers -lxmlextras -lautoconfig -ltransformiix -luniversalchardet
-ltypeaheadfind -lmailnews -lmsgdb -lmsgnews -llocalmail -lmimeemitter -lvcard
-lsmimestb -lmime -lmsgcompose -lmsgimap -laddrbook -limport -limpText
-limpComm4xMail -labsyncsvc -lmsgmdn -ljsloader_s -lunicharutil_s -lucharucomp_s
-lucvutil_s -lplatlocale_s -lstrres_s -llwbrk_s -lchardet_s -ljsj -lgtksuperwin
-lgtkxtbin -lnkcache_s -lgfxshared_s -lxlibrgb -lgkgfx -limglib2_s -limgppm_s
-limgpng_s -limggif_s -limgjpeg_s -limgbmp_s -limgxbm_s -ltxtsvc_s -lmozbrwsr_s
-lmsgbaseutil -lmimecthglue_s  -L../../dist/lib/components -L../../dist/lib
-lmozpng -L../../dist/lib -lmozmng -L../../dist/lib -lmozjpeg -L../../dist/lib
-lmozz   -L/usr/X11R6/lib -lXp -lXext -lX11  -L../../dist/bin -L../../dist/lib
-lldap50 -llber50 -lprldap50  -L/usr/X11R6/lib -lXt -L../../dist/bin -lmozjs
-L../../dist/bin -lxpcom -L/home/mozilla-1.2b/dist/lib -lplds4 -lplc4 -lnspr4  
-L/usr/local/lib -L/usr/X11R6/lib -lgtk -lgdk -lgmodule -lglib -lintl -lXext
-lX11 -lm -lm     

as it lacks -static, mozilla-bin is indeed not statically linked!

bash-2.05a# find . -name "mozilla-bin" -print
./xpfe/bootstrap/mozilla-bin
./dist/bin/mozilla-bin
bash-2.05a# file ./xpfe/bootstrap/mozilla-bin
./xpfe/bootstrap/mozilla-bin: OpenBSD/i386 demand paged dynamically linked
executable not stripped
bash-2.05a#file ./dist/bin/mozilla-bin
./dist/bin/mozilla-bin: symbolic link to ../../xpfe/bootstrap/mozilla-bin

installing and testing gave same results as mentioned in comment #1 for
mozilla-1.1 (as compiled wihtout -g, no line numbers)
gateway# /opt/mozilla-1.2b/bin/mozilla --debug
/opt/mozilla-1.2b/bin/mozilla-bin: Command not found.
gateway# /opt/mozilla-1.2b/bin/mozilla --debug
/opt/mozilla-1.2b/lib/mozilla-1.2b/run-mozilla.sh -g
/opt/mozilla-1.2b/lib/mozilla-1.2b/mozilla-bin
MOZILLA_FIVE_HOME=/opt/mozilla-1.2b/lib/mozilla-1.2b
 
LD_LIBRARY_PATH=/opt/mozilla-1.2b/lib/mozilla-1.2b:/opt/mozilla-1.2b/lib/mozilla-1.2b/plugins:/opt/mozilla-1.2b/lib/mre/mre-1.2b
DISPLAY=:0.0
FONTCONFIG_PATH=/etc/fonts:/opt/mozilla-1.2b/lib/mozilla-1.2b/res/Xft
DYLD_LIBRARY_PATH=/opt/mozilla-1.2b/lib/mozilla-1.2b:/opt/mozilla-1.2b/lib/mre/mre-1.2b
    
LIBRARY_PATH=/opt/mozilla-1.2b/lib/mozilla-1.2b:/opt/mozilla-1.2b/lib/mozilla-1.2b/components:/opt/mozilla-1.2b/lib/mre/mre-1.2b
      
SHLIB_PATH=/opt/mozilla-1.2b/lib/mozilla-1.2b:/opt/mozilla-1.2b/lib/mre/mre-1.2b
         
LIBPATH=/opt/mozilla-1.2b/lib/mozilla-1.2b:/opt/mozilla-1.2b/lib/mre/mre-1.2b
       ADDON_PATH=/opt/mozilla-1.2b/lib/mozilla-1.2b
      MOZ_PROGRAM=/opt/mozilla-1.2b/lib/mozilla-1.2b/mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=1
     moz_debugger=
/usr/bin/gdb /opt/mozilla-1.2b/lib/mozilla-1.2b/mozilla-bin -x /tmp/mozargs6769
GNU gdb 4.16.1
Copyright 1996 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-unknown-openbsd3.1"...
(gdb) br main1
Breakpoint 1 at 0x734c
(gdb) run
Starting program: /opt/mozilla-1.2b/lib/mozilla-1.2b/mozilla-bin 

Breakpoint 1, 0x734c in main1 ()
(gdb) cont
Continuing.

Program received signal SIGINT, Interrupt.
0x423c4d41 in syscall ()
(gdb) bt
#0  0x423c4d41 in syscall ()
#1  0x421c3869 in _MD_PauseCPU ()
#2  0x421bc916 in _PR_CPU_Idle ()
#3  0x421bf242 in _PR_UserRunThread ()
#4  0x421c0818 in _PR_CreateThread ()
#5  0x10d90e4 in nsAppShellService virtual table ()
#6  0x10d900c in nsAppShellService::nsIObserver virtual table ()
(gdb) quit
The program is running.  Quit anyway (and kill it)? (y or n) yes
gateway# 

Might be indeed one of the well known tugs along initalization of static
members, if dynamically linked.

Trying to enforce statically linking gives:

bash-2.05a# cd bootstrap

bash-2.05a# mv mozilla-bin mozilla-bin.dyn
#manually inserted -static -v
bash-2.05a# c++ -static -v -o mozilla-bin -I/usr/X11R6/include -fno-rtti
-fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align
-Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -pedantic -Wno-long-long
-pthread -pipe  -DNDEBUG -DTRIMMED -O0 -DWIDGET_DLL=\"libwidget_gtk.so.1.0\"
-DGFXWIN_DLL=\"libgfx_gtk.so.1.0\" -I/usr/local/include/gtk-1.2
-I/usr/local/include/glib-1.2 -I/usr/X11R6/include  nsAppRunner.o
nsWindowCreator.o showOSAlert.o nsSigHandlers.o nsStaticComponents.o
nsNativeAppSupportGtk.o nsNativeAppSupportBase.o    -L../../dist/bin
-L../../dist/lib -L../../dist/lib/components -lxpconnect -lxpctest -luconv
-lucvmath -li18n -lnecko -lnecko2 -luriloader -lpref -loji -lcaps -lchrome -lrdf
-lhtmlpars -lgfxps -lgfx_gtk -lgfxxprint -limgmng -limglib2 -lgkplugin -ljsurl
-ljsdom -lgkview -lwidget_gtk -lxremote_client -lgkcontent -lgklayout -lmork
-ldocshell -lembedcomponents -lwebbrwsr -leditor -ltxmgr -lcomposer -lprofile
-lnsprefm -laccessibility -lmozldap -lnsappshell -lfileview -lmozfind
-lregviewer -lshistory -lxremoteservice -lappcomps -lcookie -lwallet
-lwalletviewers -lxmlextras -lautoconfig -ltransformiix -luniversalchardet
-ltypeaheadfind -lmailnews -lmsgdb -lmsgnews -llocalmail -lmimeemitter -lvcard
-lsmimestb -lmime -lmsgcompose -lmsgimap -laddrbook -limport -limpText
-limpComm4xMail -labsyncsvc -lmsgmdn -ljsloader_s -lunicharutil_s -lucharucomp_s
-lucvutil_s -lplatlocale_s -lstrres_s -llwbrk_s -lchardet_s -ljsj -lgtksuperwin
-lgtkxtbin -lnkcache_s -lgfxshared_s -lxlibrgb -lgkgfx -limglib2_s -limgppm_s
-limgpng_s -limggif_s -limgjpeg_s -limgbmp_s -limgxbm_s -ltxtsvc_s -lmozbrwsr_s
-lmsgbaseutil -lmimecthglue_s  -L../../dist/lib/components -L../../dist/lib
-lmozpng -L../../dist/lib -lmozmng -L../../dist/lib -lmozjpeg -L../../dist/lib
-lmozz   -L/usr/X11R6/lib -lXp -lXext -lX11  -L../../dist/bin -L../../dist/lib
-lldap50 -llber50 -lprldap50  -L/usr/X11R6/lib -lXt -L../../dist/bin -lmozjs
-L../../dist/bin -lxpcom -L/home/mozilla-1.2b/dist/lib -lplds4 -lplc4 -lnspr4  
-L/usr/local/lib -L/usr/X11R6/lib -lgtk -lgdk -lgmodule -lglib -lintl -lXext
-lX11 -lm -lm     
Reading specs from /usr/lib/gcc-lib/i386-unknown-openbsd3.1/2.95.3/specs
gcc version 2.95.3 20010125 (prerelease)
 /usr/lib/gcc-lib/i386-unknown-openbsd3.1/2.95.3/collect2 -e start -dc -dp
-Bstatic -o mozilla-bin /usr/lib/crt0.o -L../../dist/bin -L../../dist/lib
-L../../dist/lib/components -L../../dist/lib/components -L../../dist/lib
-L../../dist/lib -L../../dist/lib -L../../dist/lib -L/usr/X11R6/lib
-L../../dist/bin -L../../dist/lib -L/usr/X11R6/lib -L../../dist/bin
-L../../dist/bin -L/home/mozilla-1.2b/dist/lib -L/usr/local/lib -L/usr/X11R6/lib
-L/usr/lib/gcc-lib/i386-unknown-openbsd3.1/2.95.3 nsAppRunner.o
nsWindowCreator.o showOSAlert.o nsSigHandlers.o nsStaticComponents.o
nsNativeAppSupportGtk.o nsNativeAppSupportBase.o -lxpconnect -lxpctest -luconv
-lucvmath -li18n -lnecko -lnecko2 -luriloader -lpref -loji -lcaps -lchrome -lrdf
-lhtmlpars -lgfxps -lgfx_gtk -lgfxxprint -limgmng -limglib2 -lgkplugin -ljsurl
-ljsdom -lgkview -lwidget_gtk -lxremote_client -lgkcontent -lgklayout -lmork
-ldocshell -lembedcomponents -lwebbrwsr -leditor -ltxmgr -lcomposer -lprofile
-lnsprefm -laccessibility -lmozldap -lnsappshell -lfileview -lmozfind
-lregviewer -lshistory -lxremoteservice -lappcomps -lcookie -lwallet
-lwalletviewers -lxmlextras -lautoconfig -ltransformiix -luniversalchardet
-ltypeaheadfind -lmailnews -lmsgdb -lmsgnews -llocalmail -lmimeemitter -lvcard
-lsmimestb -lmime -lmsgcompose -lmsgimap -laddrbook -limport -limpText
-limpComm4xMail -labsyncsvc -lmsgmdn -ljsloader_s -lunicharutil_s -lucharucomp_s
-lucvutil_s -lplatlocale_s -lstrres_s -llwbrk_s -lchardet_s -ljsj -lgtksuperwin
-lgtkxtbin -lnkcache_s -lgfxshared_s -lxlibrgb -lgkgfx -limglib2_s -limgppm_s
-limgpng_s -limggif_s -limgjpeg_s -limgbmp_s -limgxbm_s -ltxtsvc_s -lmozbrwsr_s
-lmsgbaseutil -lmimecthglue_s -lmozpng -lmozmng -lmozjpeg -lmozz -lXp -lXext
-lX11 -lldap50 -llber50 -lprldap50 -lXt -lmozjs -lxpcom -lplds4 -lplc4 -lnspr4
-lgtk -lgdk -lgmodule -lglib -lintl -lXext -lX11 -lm -lstdc++ -lm -lgcc -lc_r
-lgcc
ld: -lprldap50: no match
collect2: ld returned 1 exit status
ash-2.05a# ulimit -a
core file size        (blocks, -c) unlimited
data seg size         (kbytes, -d) 1048576
file size             (blocks, -f) unlimited
max locked memory     (kbytes, -l) 78216
max memory size       (kbytes, -m) 234648
open files                    (-n) 128
pipe size          (512 bytes, -p) 1
stack size            (kbytes, -s) 16384
cpu time             (seconds, -t) unlimited
max user processes            (-u) 532
virtual memory        (kbytes, -v) 1064960

It seems to be impossible to build such large programs under OpenBSD 3.1
perhaps it is a system problem, which should be fixed by system programmers...

best, Hans Adams
(Reporter)

Comment 9

15 years ago
Compiling mozilla-1.2b for using native threads under Openbsd:

bash-2.05a# ./configure --prefix=/opt/mozilla-1.2b \
> --disable-shared --enable-static \
> --disable-debug --enable-optimize="-O0" \
> --with-pthreads

gmake ... everything went fine

gmake install, o.k

I were able to start it once, it came up, I could set preferences etc.

Starting a second time, it wait for ever ... (you know, like in comment #1)

-------------------------------------------------------------------------------

bash-2.05a# /opt/mozilla-1.2b/bin/mozilla --debug
/opt/mozilla-1.2b/lib/mozilla-1.2b/run-mozilla.sh -g
/opt/mozilla-1.2b/lib/mozilla-1.2b/mozilla-bin
MOZILLA_FIVE_HOME=/opt/mozilla-1.2b/lib/mozilla-1.2b
 
LD_LIBRARY_PATH=/opt/mozilla-1.2b/lib/mozilla-1.2b:/opt/mozilla-1.2b/lib/mozilla-1.2b/plugins:/opt/mozilla-1.2b/lib/mre/mre-1.2b
DISPLAY=:0.0
FONTCONFIG_PATH=/etc/fonts:/opt/mozilla-1.2b/lib/mozilla-1.2b/res/Xft
DYLD_LIBRARY_PATH=/opt/mozilla-1.2b/lib/mozilla-1.2b:/opt/mozilla-1.2b/lib/mre/mre-1.2b
    
LIBRARY_PATH=/opt/mozilla-1.2b/lib/mozilla-1.2b:/opt/mozilla-1.2b/lib/mozilla-1.2b/components:/opt/mozilla-1.2b/lib/mre/mre-1.2b
      
SHLIB_PATH=/opt/mozilla-1.2b/lib/mozilla-1.2b:/opt/mozilla-1.2b/lib/mre/mre-1.2b
         
LIBPATH=/opt/mozilla-1.2b/lib/mozilla-1.2b:/opt/mozilla-1.2b/lib/mre/mre-1.2b
       ADDON_PATH=/opt/mozilla-1.2b/lib/mozilla-1.2b
      MOZ_PROGRAM=/opt/mozilla-1.2b/lib/mozilla-1.2b/mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=1
     moz_debugger=
/usr/bin/gdb /opt/mozilla-1.2b/lib/mozilla-1.2b/mozilla-bin -x /tmp/mozargs25667
GNU gdb 4.16.1
Copyright 1996 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-unknown-openbsd3.1"...
(gdb) br main
Breakpoint 1 at 0x9699
(gdb) br main1
Breakpoint 2 at 0x734c
(gdb) run
Starting program: /opt/mozilla-1.2b/lib/mozilla-1.2b/mozilla-bin 

Breakpoint 1, 0x9699 in main ()
(gdb) cont
Continuing.

Breakpoint 2, 0x734c in main1 ()
(gdb) cont
Continuing.

Program received signal SIGINT, Interrupt.
0x423fc3b7 in _thread_sys_poll ()
(gdb) bt
#0  0x423fc3b7 in _thread_sys_poll ()
#1  0x423e43dc in _thread_kern_sched_state_unlock ()
#2  0x423e3d76 in _thread_kern_sched ()
#3  0x423e402a in _thread_kern_sched_state_unlock ()
#4  0x423e30ad in pthread_cond_timedwait ()
#5  0x421b654f in pt_TimedWait ()
#6  0x421b6861 in PR_WaitCondVar ()
#7  0x420aec35 in TimerThread::Run ()
#8  0x420a8ef9 in nsThread::Main ()
#9  0x421bd27b in _pt_root ()
#10 0x423c4bcd in _thread_start ()
#11 0x23 in ?? ()
Error accessing memory address 0xffffffff: Invalid argument.
(gdb) quit
The program is running.  Quit anyway (and kill it)? (y or n) y

------------------------------------------------------------------------------

sending SIGINFO to the process to retrieve state of threads results in:

bash-2.05a# /opt/mozilla-1.2b/bin/mozilla --debug
/opt/mozilla-1.2b/lib/mozilla-1.2b/run-mozilla.sh -g
/opt/mozilla-1.2b/lib/mozilla-1.2b/mozilla-bin
MOZILLA_FIVE_HOME=/opt/mozilla-1.2b/lib/mozilla-1.2b
 
LD_LIBRARY_PATH=/opt/mozilla-1.2b/lib/mozilla-1.2b:/opt/mozilla-1.2b/lib/mozilla-1.2b/plugins:/opt/mozilla-1.2b/lib/mre/mre-1.2b
DISPLAY=:0.0
FONTCONFIG_PATH=/etc/fonts:/opt/mozilla-1.2b/lib/mozilla-1.2b/res/Xft
DYLD_LIBRARY_PATH=/opt/mozilla-1.2b/lib/mozilla-1.2b:/opt/mozilla-1.2b/lib/mre/mre-1.2b
    
LIBRARY_PATH=/opt/mozilla-1.2b/lib/mozilla-1.2b:/opt/mozilla-1.2b/lib/mozilla-1.2b/components:/opt/mozilla-1.2b/lib/mre/mre-1.2b
      
SHLIB_PATH=/opt/mozilla-1.2b/lib/mozilla-1.2b:/opt/mozilla-1.2b/lib/mre/mre-1.2b
         
LIBPATH=/opt/mozilla-1.2b/lib/mozilla-1.2b:/opt/mozilla-1.2b/lib/mre/mre-1.2b
       ADDON_PATH=/opt/mozilla-1.2b/lib/mozilla-1.2b
      MOZ_PROGRAM=/opt/mozilla-1.2b/lib/mozilla-1.2b/mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=1
     moz_debugger=
/usr/bin/gdb /opt/mozilla-1.2b/lib/mozilla-1.2b/mozilla-bin -x /tmp/mozargs16933
GNU gdb 4.16.1
Copyright 1996 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-unknown-openbsd3.1"...
(gdb) br main
Breakpoint 1 at 0x9699
(gdb) br main1
Breakpoint 2 at 0x734c
(gdb) run
Starting program: /opt/mozilla-1.2b/lib/mozilla-1.2b/mozilla-bin 

Breakpoint 1, 0x9699 in main ()
(gdb) cont
Continuing.

Breakpoint 2, 0x734c in main1 ()
(gdb) cont
Continuing.

Program received signal ?, Unknown signal.
0x423fc3b7 in _thread_sys_poll ()
(gdb) quit
The program is running.  Quit anyway (and kill it)? (y or n) y

------------------------------------------------------------------------------

sending signal SIGVTALRM results in:
(At least, scheduling of threads should have started ...)

/opt/mozilla-1.2b/lib/mozilla-1.2b/run-mozilla.sh -g
/opt/mozilla-1.2b/lib/mozilla-1.2b/mozilla-bin
MOZILLA_FIVE_HOME=/opt/mozilla-1.2b/lib/mozilla-1.2b
 
LD_LIBRARY_PATH=/opt/mozilla-1.2b/lib/mozilla-1.2b:/opt/mozilla-1.2b/lib/mozilla-1.2b/plugins:/opt/mozilla-1.2b/lib/mre/mre-1.2b
DISPLAY=:0.0
FONTCONFIG_PATH=/etc/fonts:/opt/mozilla-1.2b/lib/mozilla-1.2b/res/Xft
DYLD_LIBRARY_PATH=/opt/mozilla-1.2b/lib/mozilla-1.2b:/opt/mozilla-1.2b/lib/mre/mre-1.2b
    
LIBRARY_PATH=/opt/mozilla-1.2b/lib/mozilla-1.2b:/opt/mozilla-1.2b/lib/mozilla-1.2b/components:/opt/mozilla-1.2b/lib/mre/mre-1.2b
      
SHLIB_PATH=/opt/mozilla-1.2b/lib/mozilla-1.2b:/opt/mozilla-1.2b/lib/mre/mre-1.2b
         
LIBPATH=/opt/mozilla-1.2b/lib/mozilla-1.2b:/opt/mozilla-1.2b/lib/mre/mre-1.2b
       ADDON_PATH=/opt/mozilla-1.2b/lib/mozilla-1.2b
      MOZ_PROGRAM=/opt/mozilla-1.2b/lib/mozilla-1.2b/mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=1
     moz_debugger=
/usr/bin/gdb /opt/mozilla-1.2b/lib/mozilla-1.2b/mozilla-bin -x /tmp/mozargs23961
GNU gdb 4.16.1
Copyright 1996 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-unknown-openbsd3.1"...
(gdb) run
Starting program: /opt/mozilla-1.2b/lib/mozilla-1.2b/mozilla-bin 

Program terminated with signal SIGVTALRM, Virtual timer expired.
The program no longer exists.
(gdb) quit
--------------------------------------------------------------------------------
Summary: mozilla 1.1 without debugging stops working → mozilla 1.2b without debugging does not start
(Reporter)

Comment 10

15 years ago
Observations:

Under both condiditions, configured with or without --with-pthreads, -pthread is
set.(refer to comment #5 and comment #9). Hereby I conclude, that pthreads are
_always_ used.

BUT: As verified in comment #9, SIGINFO is not handled at all, though it should
trigger displaying of internal state of threads.
SIGVTARLM finishes program, instead of scheduling threads.

In various places of program, setitimer seems to be set. This will have
unpredictable results together with pthreads :->.

best, Hans Adams
Summary: mozilla 1.2b without debugging does not start → mozilla 1.1/1.2b without debugging does not start
Ugh. Don't force the use of -static.  The misnamed static build option doesn't
link the binaries static, it links (most of) the components static.  There are
certain libraries that need to remain shared (see bug 46775).

Pthreads are always used unless you're on an old platform which doesn't support
pthreads.  Afaict, OpenBSD uses nspr user threads by default.

Wrt comment #8:

ld: -lprldap50: no match
collect2: ld returned 1 exit status

I don't think you can force the use of -static when linking against ldap as ldap
only builds the shared libraries.  You'll have to build using --disable-ldap to
get around that problem.

Hrm.  If it worked once, try removing components/*.dat and restarting.  Maybe
it's getting hung up when it doesn't register the components.  Also, try making
sure that the NSPR tests still work, since this is a minor OS update since the
previous version that anyone tested afaik. 

cd nsprpub/pr/tests
make && make runtests



(Reporter)

Comment 12

15 years ago
>rm.  If it worked once, try removing components/*.dat and restarting.  Maybe
>it's getting hung up when it doesn't register the components.

IT works _once_ after new "gmake install"....


>cd nsprpub/pr/tests
>make && make runtests
-------------------------------------------------------------------------
----------- mozilla-1.1 without pthreads -----------------------------------
NSPR Test Results - .

BEGIN                   Sat Nov  2 20:54:18 CET 2002
NSPR_TEST_LOGFILE       /dev/null

Test                    Result

accept                  FAILED
acceptread                      FAILED
acceptreademu                   FAILED
addrstr                 FAILED
affinity                        FAILED
alarm                   FAILED
anonfm                  FAILED
append                  FAILED
atomic                  FAILED
attach                  FAILED
bigfile                 FAILED
bigfile2                        FAILED
bigfile3                        FAILED
cleanup                 FAILED
cltsrv                  FAILED
concur                  FAILED
cvar                    FAILED
cvar2                   FAILED
dceemu                  FAILED
dlltest                 FAILED
dtoa                    FAILED
env                     FAILED
errcodes                        FAILED
errset                  FAILED
exit                    FAILED
fdcach                  FAILED
fileio                  FAILED
foreign                 FAILED
forktest                        FAILED
fsync                   FAILED
gethost                 FAILED
getproto                        FAILED
i2l                     FAILED
initclk                 FAILED
inrval                  FAILED
instrumt                        FAILED
intrio                  FAILED
intrupt                 FAILED
io_timeout                      FAILED
ioconthr                        FAILED
ipv6                    FAILED
join                    FAILED
joinkk                  FAILED
joinku                  FAILED
joinuk                  FAILED
joinuu                  FAILED
layer                   FAILED
lazyinit                        FAILED
lltest                  FAILED
lock                    FAILED
lockfile                        FAILED
logger                  FAILED
makedir                 FAILED
mbcs                    FAILED
multiacc                        FAILED
multiwait                       FAILED
many_cv                 FAILED
nameshm1                        FAILED
nbconn                  FAILED
nblayer                 FAILED
nonblock                        FAILED
ntioto                  FAILED
ntoh                    FAILED
obsints                 FAILED
op_2long                        FAILED
op_excl                 FAILED
op_filnf                        FAILED
op_filok                        FAILED
op_noacc                        FAILED
op_nofil                        FAILED
openfile                        FAILED
parent                  FAILED
peek                    FAILED
perf                    FAILED
pipeping                        FAILED
pipeping2                       FAILED
pipepong                        FAILED
pipepong2                       FAILED
pipeself                        FAILED
poll_er                 FAILED
poll_nm                 FAILED
poll_to                 FAILED
pollable                        FAILED
prftest                 FAILED
prftest1                        FAILED
prftest2                        FAILED
primblok                        FAILED
priotest                        FAILED
provider                        FAILED
prpoll                  FAILED
prpollml                        FAILED
ranfile                 FAILED
randseed                        FAILED
rmdir                   FAILED
rwlocktest                      FAILED
sel_spd                 FAILED
selct_er                        FAILED
selct_nm                        FAILED
selct_to                        FAILED
select2                 FAILED
selintr                 FAILED
sem                     FAILED
sema                    FAILED
semaerr                 FAILED
semaerr1                        FAILED
semaping                        FAILED
semapong                        FAILED
sendzlf                 FAILED
server_test                     FAILED
servr_kk                        FAILED
servr_ku                        FAILED
servr_uk                        FAILED
servr_uu                        FAILED
short_thread                    FAILED
sigpipe                 FAILED
socket                  FAILED
sockopt                 FAILED
sockping                        FAILED
sockpong                        FAILED
sprintf                 FAILED
sproc_ch                        FAILED
sproc_p                 FAILED
stack                   FAILED
stdio                   FAILED
str2addr                        FAILED
strod                   FAILED
suspend                 FAILED
switch                  FAILED
system                  FAILED
testbit                 FAILED
testfile                        FAILED
thrpool_server                  FAILED
thrpool_client                  FAILED
threads                 FAILED
thruput                 FAILED
timemac                 FAILED
timetest                        FAILED
tmoacc                  FAILED
tmocon                  FAILED
tpd                     FAILED
vercheck                        FAILED
version                 FAILED
udpsrv                  FAILED
writev                  FAILED
xnotify                 FAILED
y2k                     FAILED
y2ktmo                  FAILED
zerolen                 FAILED

END             Sat Nov  2 20:54:19 CET 2002


-------------------------------------------------------------------------------

------ mozilla 1.2 wiht pthreads ----------------------------------------------


NSPR Test Results - .

BEGIN                   Sat Nov  2 17:38:36 CET 2002
NSPR_TEST_LOGFILE       /dev/null

Test                    Result

accept                  FAILED
acceptread                      FAILED
acceptreademu                   FAILED
addrstr                 FAILED
affinity                        FAILED
alarm                   FAILED
anonfm                  FAILED
append                  FAILED
atomic                  FAILED
attach                  FAILED
bigfile                 FAILED
bigfile2                        FAILED
bigfile3                        FAILED
cleanup                 FAILED
cltsrv                  FAILED
concur                  FAILED
cvar                    FAILED
cvar2                   FAILED
dceemu                  FAILED
dlltest                 FAILED
dtoa                    FAILED
env                     FAILED
errcodes                        FAILED
errset                  FAILED
exit                    FAILED
fdcach                  FAILED
fileio                  FAILED
foreign                 FAILED
forktest                        FAILED
fsync                   FAILED
gethost                 FAILED
getproto                        FAILED
i2l                     FAILED
initclk                 FAILED
inrval                  FAILED
instrumt                        FAILED
intrio                  FAILED
intrupt                 FAILED
io_timeout                      FAILED
ioconthr                        FAILED
ipv6                    FAILED
join                    FAILED
joinkk                  FAILED
joinku                  FAILED
joinuk                  FAILED
joinuu                  FAILED
layer                   FAILED
lazyinit                        FAILED
lltest                  FAILED
lock                    FAILED
lockfile                        FAILED
logger                  FAILED
makedir                 FAILED
mbcs                    FAILED
multiacc                        FAILED
multiwait                       FAILED
many_cv                 FAILED
nameshm1                        FAILED
nbconn                  FAILED
nblayer                 FAILED
nonblock                        FAILED
ntioto                  FAILED
ntoh                    FAILED
obsints                 FAILED
op_2long                        FAILED
op_excl                 FAILED
op_filnf                        FAILED
op_filok                        FAILED
op_noacc                        FAILED
op_nofil                        FAILED
openfile                        FAILED
parent                  FAILED
peek                    FAILED
perf                    FAILED
pipeping                        FAILED
pipeping2                       FAILED
pipepong                        FAILED
pipepong2                       FAILED
pipeself                        FAILED
poll_er                 FAILED
poll_nm                 FAILED
poll_to                 FAILED
pollable                        FAILED
prftest                 FAILED
prftest1                        FAILED
prftest2                        FAILED
primblok                        FAILED
priotest                        FAILED
provider                        FAILED
prpoll                  FAILED
prpollml                        FAILED
ranfile                 FAILED
randseed                        FAILED
rmdir                   FAILED
rwlocktest                      FAILED
sel_spd                 FAILED
selct_er                        FAILED
selct_nm                        FAILED
selct_to                        FAILED
select2                 FAILED
selintr                 FAILED
sem                     FAILED
sema                    FAILED
semaerr                 FAILED
semaerr1                        FAILED
semaping                        FAILED
semapong                        FAILED
sendzlf                 FAILED
server_test                     FAILED
servr_kk                        FAILED
servr_ku                        FAILED
servr_uk                        FAILED
servr_uu                        FAILED
short_thread                    FAILED
sigpipe                 FAILED
socket                  FAILED
sockopt                 FAILED
sockping                        FAILED
sockpong                        FAILED
sprintf                 FAILED
sproc_ch                        FAILED
sproc_p                 FAILED
stack                   FAILED
stdio                   FAILED
str2addr                        FAILED
strod                   FAILED
suspend                 FAILED
switch                  FAILED
system                  FAILED
testbit                 FAILED
testfile                        FAILED
thrpool_server                  FAILED
thrpool_client                  FAILED
threads                 FAILED
thruput                 FAILED
timemac                 FAILED
timetest                        FAILED
tmoacc                  FAILED
tmocon                  FAILED
tpd                     FAILED
vercheck                        FAILED
version                 FAILED
udpsrv                  FAILED
writev                  FAILED
xnotify                 FAILED
y2k                     FAILED
y2ktmo                  FAILED
zerolen                 FAILED

END             Sat Nov  2 17:38:38 CET 2002


--------------------------------------------------------------------------------

best, Hans Adams
>>rm.  If it worked once, try removing components/*.dat and restarting.  Maybe
>>it's getting hung up when it doesn't register the components.
> 
> 
> IT works _once_ after new "gmake install"....

Yeah, I got that part.  Did you try removing those files and see if it ran
again?  I'm trying to narrow down what allows the first run to work and
subsequent ones to fail.

Every test failed.  Try adding the location of dist/bin to LD_LIBRARY_PATH
before doing the |make runtests|.
(Reporter)

Comment 14

15 years ago
Answer to comment #13. (BTW: I will be on vaccations for the next two weeks)
best, Hans Adams

-----------------------------------------------------------------------------
Trying to start mozilla-1.1
1) freshly installed: works, asks for profiles etc...
2) second try to start: does not work, does not even receive cpu time.
   state: I+
3) a) rm lib/mozilla-1.1/components/*.dat
   b) comes up with start screen without asking for profiles etc.
      --- most often, freezes sometimes like 2) ----
   c) second try to start: see 2)
4) a) rm lib/mozilla-1.1/components/*.dat and lib/mozilla-1.1/components.reg
   b) comes up always, without asking for profiles etc.


--------------------------------------------------------------------------------
Trying to start mozilla-1.2b (was compiled with -pthreads)
1) fresly installed: works, asks for profiles etc.
2) second try to start: does not work, doen not even recieve cpu time.
   state: I+
3) a) rm lib/mozilla-1.2b/components/*.dat
   b) comes upt with start screen without asking for profiles etc..
   c) second try to start, see 2)

------------------------------------------------------------------------------
gateway# bash
bash-2.05a# export
LD_LIBRARY_PATH=/home/mozilla-1.1/dist/bin:/home/mozilla-1.1/dist/bin
bash-2.05a# echo $LD_LIBRARY_PATH
/home/mozilla-1.1/dist/bin:/home/mozilla-1.1/dist/bin
bash-2.05a# gmake runtests

NSPR Test Results - .

BEGIN                   Sun Nov  3 21:05:25 CET 2002
NSPR_TEST_LOGFILE       /dev/null

Test                    Result

accept                  Passed
acceptread                      Passed
acceptreademu                   Passed
addrstr                 Passed
affinity                        Passed
alarm                   Passed
anonfm                  Passed
append                  Passed
atomic                  Passed
attach                  FAILED
bigfile                 Passed
bigfile2                        FAILED
bigfile3                        FAILED
cleanup                 Passed
cltsrv                  Passed
concur                  Passed
cvar                    Passed
cvar2                   Passed
dceemu                  Passed
dlltest                 Passed
dtoa                    Passed
env                     Passed
errcodes                        Passed
errset                  Passed
exit                    Passed
fdcach                  Passed
fileio                  Passed
foreign                 Passed
forktest                        Passed
fsync                   Passed
gethost                 FAILED
getproto                        Passed
i2l                     Passed
initclk                 Passed
inrval                  Passed
instrumt                        Passed
intrio                  Passed
intrupt                 Passed
io_timeout                      Passed
ioconthr                        Passed
ipv6                    Passed
join                    Passed
joinkk                  Passed
joinku                  Passed
joinuk                  Passed
joinuu                  Passed
layer                   Passed
lazyinit                        Passed
lltest                  Passed
lock                    Passed
lockfile                        Passed
logger                  Passed
makedir                 Passed
mbcs                    FAILED
multiacc                        Passed
multiwait                       Passed
many_cv                 Passed
nameshm1                        Passed
nbconn                  FAILED
nblayer                 Passed
nonblock                        Passed
ntioto                  Passed
ntoh                    Passed
obsints                 Passed
op_2long                        Passed
op_excl                 Passed
op_filnf                        Passed
op_filok                        Passed
op_noacc                        FAILED
op_nofil                        Passed
openfile                        Passed
parent                  Passed
peek                    Passed
perf                    Passed
pipeping                        Passed
 pipeping2                      Passed
pipepong                        FAILED
pipepong2                       FAILED
pipeself                        Passed
poll_er                 Passed
poll_nm                 Passed
poll_to                 Passed
pollable                        Passed
prftest                 Passed
prftest1                        Passed
prftest2                        Passed
primblok                        Passed
priotest
                        FAILED
provider                        FAILED
prpoll                  Passed
prpollml                        FAILED
ranfile                 FAILED
randseed                        Passed
rmdir                   Passed
rwlocktest                      Passed
sel_spd                 Passed
selct_er                        Passed
selct_nm                        Passed
selct_to                        Passed
select2                 Passed
selintr                 Passed
sem                     Passed
sema                    FAILED
semaerr                 FAILED
semaerr1                        FAILED
semaping                        FAILED
semapong                        FAILED
sendzlf                 Passed
server_test                     Passed
servr_kk                        Passed
servr_ku                        Passed
servr_uk                        Passed
servr_uu                        Passed
short_thread                    Passed
sigpipe                 Passed
socket                  Passed
sockopt                 Passed
sockping                        Passed
sockpong                        FAILED
sprintf                 Passed
sproc_ch                        Passed
sproc_p                 Passed
stack                   Passed
stdio                   Passed
str2addr                        Passed
strod                   Passed
suspend                 Passed
switch                  Passed
system                  Passed
testbit                 Passed
testfile                        Passed
thrpool_server                  Passed
thrpool_client                  FAILED
threads                 Passed
thruput                 FAILED
timemac                 Passed
timetest                        Passed
tmoacc                  FAILED
tmocon                  FAILED
tpd                     Passed
vercheck                        Passed
version                 Passed
udpsrv                  Passed
writev                  Passed
xnotify                 Passed
y2k                     FAILED
y2ktmo                  Passed
zerolen                 Passed

END             Thu Nov  7 19:07:57 CET 2002

You have new mail in /var/mail/root
bash-2.05a# bash-2.05a# 

--------------------------------------------------------------------------------
As tests lasted about 4 days, some processes had to be killed manually.
Process was killed, if it got huge amount of cpu time, without finishing, or if
it waited long without recieving cpu time.

gateway# bash
bash-2.05a# ps -axg | grep priotest
27108 p5  I+      0:00.00 ./pipepong 
13726 pa  I+      0:00.00 grep pipepong 
bash-2.05a# kill 27108
bash-2.05a# ps -axg | grep priotest
20656 p5  R+     14:02.25 ./priotest 
 6705 pa  R+      0:00.00 grep priotest (bash)
bash-2.05a# ps -axg | grep priotest
20656 p5  R+     14:22.64 ./priotest 
 4756 pa  R+      0:00.00 grep priotest (bash)
bash-2.05a# ps -axg | grep priotest
20656 p5  R+     14:25.29 ./priotest 
 9738 pa  R+      0:00.00 grep priotest (bash)
bash-2.05a# ps -axg | grep priotest
20656 p5  R+     14:36.94 ./priotest 
12608 pa  R+      0:00.00 grep priotest (bash)
bash-2.05a# ps -axg | grep priotest
20656 p5  R+     15:45.42 ./priotest 
32314 pa  R+      0:00.00 grep priotest (bash)
bash-2.05a# ps -axg | grep priotest
20656 p5  R+    5496:56.66 ./priotest 
26510 pa  I+      0:00.00 grep priotest 
You have new mail in /var/mail/root
bash-2.05a# kill 20656
bash-2.05a# ps -axg | grep provider
32010 pa  R+      0:00.00 grep priotest (bash)
bash-2.05a# ps -axg | grep provider
26855 p5  I+      0:00.02 ./provider 
14880 pa  R+      0:00.00 grep provider (bash)
bash-2.05a# ps -axg | grep ranfile
26855 p5  I+      0:00.02 ./provider 
24646 pa  R+      0:00.00 grep provider (bash)
bash-2.05a# kill 26855
bash-2.05a# ps -axg | grep ranfile
10548 p5  D+      0:02.45 ./ranfile 
 2502 pa  I+      0:00.00 grep ranfile 
bash-2.05a# ps -axg | grep ranfile
10548 p5  D+      0:04.54 ./ranfile 
23492 pa  R+      0:00.00 grep ranfile (bash)
bash-2.05a# ps -axg | grep ranfile
10548 p5  D+      0:06.91 ./ranfile 
27540 pa  I+      0:00.00 grep ranfile 
bash-2.05a# ps -axg | grep ranfile
10548 p5  D+      0:07.93 ./ranfile 
  668 pa  R+      0:00.00 grep ranfile (bash)
bash-2.05a# ps -axg | grep ranfile
10548 p5  D+      0:10.63 ./ranfile 
13105 pa  I+      0:00.00 grep ranfile 
bash-2.05a# kill 10548
bash-2.05a# 
--------------------------------------------------------------------------------

bash-2.05a# pwd
/home/mozilla-1.2b/nsprpub/pr/tests
bash-2.05a# echo $LD_LIBRARY_PATH

bash-2.05a# export
LD_LIBRARY_PATH=/home/mozilla-1.2b/dist/lib:/home/mozilla-1.2b/dist/bin
bash-2.05a# echo $LD_LIBRARY_PATH
/home/mozilla-1.2b/dist/lib:/home/mozilla-1.2b/dist/bin
bash-2.05a# gmake tests
gmake: *** No rule to make target `tests'.  Stop.
bash-2.05a# gmake runtests

NSPR Test Results - .

BEGIN                   Thu Nov  7 18:28:26 CET 2002
NSPR_TEST_LOGFILE       /dev/null

Test                    Result

accept                  Passed
acceptread                      Passed
acceptreademu                   Passed
addrstr                 Passed
affinity                        Passed
alarm                   Passed
anonfm                  Passed
append                  Passed
atomic                  Passed
attach                  Passed
bigfile                 Passed
bigfile2                        FAILED
bigfile3                        FAILED
cleanup                 Passed
cltsrv                  Passed
concur                  Passed
cvar                    Passed
cvar2                   Passed
dceemu                  Passed
dlltest                 Passed
dtoa                    Passed
env                     Passed
errcodes                        Passed
errset                  Passed
exit                    Passed
fdcach                  Passed
fileio                  Passed
foreign                 Passed
forktest                        Passed
fsync                   Passed
gethost                 FAILED
getproto                        Passed
i2l                     Passed
initclk                 Passed
inrval                  Passed
instrumt                        Passed
intrio                  Passed
intrupt                 Passed
io_timeout                      Passed
ioconthr                        Passed
ipv6                    Passed
join                    Passed
joinkk                  Passed
joinku                  Passed
joinuk                  Passed
joinuu                  Passed
layer                   Passed
lazyinit                        Passed
lltest                  Passed
lock                    Passed
lockfile                        Passed
logger                  Passed
makedir                 FAILED
mbcs                    FAILED
multiacc                        Passed
multiwait                       Passed
many_cv                 Passed
nameshm1                        FAILED
nbconn                  FAILED
nblayer                 Passed
nonblock                        Passed
ntioto                  Passed
ntoh                    Passed
obsints                 Passed
op_2long                        Passed
op_excl                 Passed
op_filnf                        Passed
op_filok                        Passed
op_noacc                        Passed
op_nofil                        Passed
openfile                        Passed
parent                  Passed
peek                    Passed
perf                    Passed
pipeping                        Passed
pipeping2                       Passed
pipepong                        FAILED
pipepong2                       FAILED
pipeself                        Passed
poll_er                 Passed
poll_nm                 Passed
poll_to                 Passed
pollable                        Passed
prftest                 Passed
prftest1                        Passed
prftest2                        Passed
primblok                        Passed
priotest                        Passed
provider                        Passed
prpoll                  Passed
prpollml                        FAILED
ranfile                 Passed
randseed                        Passed
rmdir                   Passed
rwlocktest                      Passed
sel_spd                 Passed
selct_er                        Passed
selct_nm                        Passed
selct_to                        Passed
select2                 FAILED
selintr                 Passed
sem                     Passed
sema                    FAILED
semaerr                 FAILED
semaerr1                        FAILED
semaping                        FAILED
semapong                        FAILED
sendzlf                 Passed
server_test                     Passed
servr_kk                        Passed
servr_ku                        Passed
servr_uk                        Passed
servr_uu                        Passed
short_thread                    Passed
sigpipe                 Passed
socket                  Passed
sockopt                 Passed
sockping                        Passed
sockpong                        FAILED
sprintf                 Passed
sproc_ch                        Passed
sproc_p                 Passed
stack                   Passed
stdio                   Passed
str2addr                        Passed
strod                   Passed
suspend                 FAILED
switch                  Passed
system                  Passed
testbit                 Passed
testfile                        Passed
thrpool_server                  Passed
thrpool_client                  FAILED
threads                 Passed
thruput                 FAILED
timemac                 Passed
timetest                        Passed
tmoacc                  FAILED
tmocon                  Passed
tpd                     Passed
vercheck                        Passed
version                 Passed
udpsrv                  Passed
writev                  Passed
xnotify                 Passed
y2k                     FAILED
y2ktmo                  Passed
zerolen                 Passed

END             Thu Nov  7 19:26:52 CET 2002

bash-2.05a# exit
gateway# 
--------------------------------------------------------------------------------
Process was killed, if it got huge amount of cpu time, without finishing, or if
it waited long without recieving cpu time. To be honest, tests ran much faster
than those from mozilla-1.1. Whole suite took about one hour.


gateway# bash
bash-2.05a# ps axg | grep sema
 6359 pe  I+      0:00.01 ./select2 
26220 q0  R+      0:00.00 grep select2 (bash)
bash-2.05a# kill 6359
bash-2.05a# ps axg | grep sema
14918 pe  I+      0:00.00 ./sema 
27659 q0  R+      0:00.00 grep sema (bash)
bash-2.05a# kill 14918
bash-2.05a# ps axg | grep sema
31973 pe  I+      0:00.00 ./semaerr 
 6635 pe  I+      0:00.01 semaerr1 
 2897 q0  R+      0:00.00 grep sema (bash)
bash-2.05a# ps axg | grep sema
31973 pe  I+      0:00.01 ./semaerr 
 6635 pe  I+      0:00.01 semaerr1 
30585 q0  R+      0:00.00 grep sema (bash)
bash-2.05a# ps axg | grep sema
31973 pe  I+      0:00.01 ./semaerr 
 6635 pe  I+      0:00.01 semaerr1 
 2148 q0  R+      0:00.00 grep sema (bash)
bash-2.05a# ps axg | grep sema
31973 pe  I+      0:00.01 ./semaerr 
 6635 pe  I+      0:00.01 semaerr1 
14432 q0  R+      0:00.00 grep sema (bash)
bash-2.05a# kill 31973
bash: kill: (31973) - No such process
bash-2.05a# ps axg | grep sema
 1126 pe  I+      0:00.01 ./semaerr1 
 5029 q0  R+      0:00.00 grep sema (bash)
bash-2.05a# ps axg | grep sema
 1126 pe  I+      0:00.01 ./semaerr1 
  934 q0  R+      0:00.00 grep sema (bash)
bash-2.05a# ps axg | grep sema
 1126 pe  I+      0:00.01 ./semaerr1 
31130 q0  R+      0:00.00 grep sema (bash)
bash-2.05a# kill 1126
bash-2.05a# ps axg | grep sema
19549 pe  I+      0:00.00 ./semaping 
23751 pe  I+      0:00.00 semapong 
 2165 q0  R+      0:00.00 grep sema (bash)
bash-2.05a# ps axg | grep sema
19549 pe  I+      0:00.00 ./semaping 
23751 pe  I+      0:00.01 semapong 
23325 q0  R+      0:00.00 grep sema (bash)
bash-2.05a# ps axg | grep sema
19549 pe  I+      0:00.00 ./semaping 
23751 pe  I+      0:00.01 semapong 
 4889 q0  R+      0:00.00 grep sema (bash)
bash-2.05a# ps axg | grep sema
25280 pe  I+      0:00.01 ./semapong 
31500 q0  R+      0:00.00 grep sema (bash)
bash-2.05a# ps axg | grep suspend
 9927 q0  R+      0:00.00 grep sema (bash)
bash-2.05a# ps axg | grep suspend
27398 pe  R+      2:57.07 ./suspend 
10340 q0  R+      0:00.00 grep suspend (bash)
bash-2.05a# ps axg | grep suspend
27398 pe  R+      6:49.63 ./suspend 
16622 q0  R+      0:00.00 grep suspend (bash)
bash-2.05a# ps axg | grep client
27398 pe  R+      6:58.51 ./suspend 
17590 q0  I+      0:00.00 grep suspend 
bash-2.05a# kill 27398
bash-2.05a# ps axg | grep thru
16016 pe  I+      0:00.01 ./thrpool_client 
26517 q0  R+      0:00.00 grep client (bash)
bash-2.05a# kill 16016
bash-2.05a# ps axg | grep tmoacc
 1927 pe  I+      0:00.01 ./thruput 
 4268 q0  R+      0:00.00 grep thru (bash)
bash-2.05a# kill 1927
bash-2.05a# ps axg | grep tmoacc
14380 pe  I+      0:00.01 ./tmoacc 
32669 q0  R+      0:00.00 grep tmoacc (bash)
bash-2.05a# kill 14380
bash-2.05a#

Target Milestone: --- → Future
Priority: -- → P4
Mass reassign to new default build assignee
Assignee: seawood → mozbugs-build
Priority: P4 → --
This is a duplicate of bug 124958 AFAICT.
No longer depends on: 177558
Depends on: 124958
Mass reassign of Build/Config bugs to Leaf.
Assignee: mozbugs-build → leaf
Target Milestone: Future → ---

Comment 18

14 years ago

*** This bug has been marked as a duplicate of 124958 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.