Closed Bug 1776218 Opened 8 months ago Closed 2 months ago

caldav Calendar freezes thunderbird 102 on startup for some time

Categories

(Calendar :: Provider: CalDAV, defect)

Thunderbird 102
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1789999

People

(Reporter: freddy, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: perf, regression)

Steps to reproduce:

Installed TB 102 (Beta 8) and started using my existing profile. The UI freezes for quite some time. Removed prefs.js, no freezes. After trying to delete from stuff from prefs.js found out that as soon as I add any of my caldav calendars from work the UI freezes on startup. Using google calendars (via caldav) is not a problem.
I have used these calendars for years, it's working fine in TB 91.10

Actual results:

UI freezes on startup

Expected results:

UI responds upon starting

Forgot to mention: Using Fedora 36, fully updated.

Tried 103 (daily) as well. Kind of the same problem but 103 simply takes a very log time to startup with the caldav calendar enabled. Removing the entries from prefs.js, the 103 starts normal.

Blocks: tb102found

Just to add that I'm encountering the same issue on Windows 11 21H2 with Thunderbird 102.0 64-bit (final). It took me quit some time to figure out the freeze on TB 102.0 was caused by the calendars as everything was working properly on TB 91.x before the upgrade, and with 9 connected caldav I didn't have the patience to wait for TB to respond again, I always killed the process after a few minutes. Then I started randomly removing options from the prefs.js file, and eventually found out that removing the caldav calendars solved the freeze issue.

Actually, simply adding a caldav calendar (from Zimbra 8.8.15) to a brand new profile makes Thunderbird freeze for about 3 minutes. So the more connected caldav you have, the longer the freeze at startup (TB takes about 30 minutes to unfreeze with my main profile). Once TB eventually responds, it works without an issue until the next restart, and even forcing a "synchronize calendars" doesn't cause a freeze.

I am on Windows 10 21H2 with Thunderbird 102.0
I see the same freeze for some minutes before Thunderbird becomes usable.
I have also several CaldDAV calendar to sync at startup.
If I do as L-Bro, so I remove lines about my CalDAV calendar in prefs.js, then Thunderbird starts quickly and is directly usable.

I would like to ad that I didn't find this issue with my computer on KDE Neon 5.25 with Kernel 5.13.0
Thunderbird 102.0 (64bits) starts normally, even with several CaldDAV calendar activated.

We have seen 2 point releases already but this issue remains. In fact, it may even have gotten worse (though that could just be a gut feeling, haven't measured it). Simply disabling the caldav calendars does not seem to make any diffrence, they need to be really removed for a speady/regular startup. I give up, will revert back to version 91.

(In reply to Freddy from comment #5)

We have seen 2 point releases already but this issue remains. In fact, it may even have gotten worse

I think it is not expected that version 102 is worse than 91. But as far as I know we are not working on any version 102 specific performance issues, so it is not surprising that it has not improved.

Lasana can you offer guidance?

Component: Untriaged → General
Flags: needinfo?(lasana)
Keywords: perf
Product: Thunderbird → Calendar

For what it is worth, tried the third point release (102.0.3) as well, same issue. And just to be clear, version 91 works flawlessly, no delays at startup due to caldav issues.

I can support what Freddy mentioned.
On Windows 10, all version of Thunderbird 102 (now I am with 102.0.3) freeze several minutes at start-up (3-5 min with a Intel(R) Core(TM) i7-8665U CPU) before being capable to work. When removing the CaldDAV calendar, no freeze is observed at start up. And with the same config, I have not seen any freeze with Thunderbird 91.

Surprisingly, on KDE Neon (based on Ubuntu 20.04), with Thunderbird 102 (installed through package downloaded from https://www.thunderbird.net/en-US/thunderbird/all/ and run from a folder at /opt/ ) I have not observed any freeze at start-up even if I have several CalDAV calendars synced (and a much older computer).

If I can help you to find a solution, I'll be delighted. This is currently a major issue for me.

Are these calendars cached or un-cached (right click > properties > Offline Support). Are you able to give a rough estimate of how many items are on the calendar? Is it publicly accessible are you able to share the link?

Component: General → Provider: CalDAV
Flags: needinfo?(lasana) → needinfo?(freddy)

On Windows 10 :

  • Calendars are cached.
  • They are not public, these are my professional calendars as well as shared calendars of some colleagues and of some teams.
  • Some have "many" items, but I have no idea how to get the number of item of a calendar.
  • Calendar are synced with a professional Zimbra server.

On Kde Neon (no freeze on start up):

  • Calendar are cached.
  • These are not public but private personal calendar, except calendar of day off and public holidays (Mozilla public calendar)
  • Some have "many" items, but I have no idea how to get the number of item of a calendar.
  • Calendar are sync with a self-hosted Nextcloud calendar.
  • Calendars are cached. cached/uncached makes no difference.
  • Not public since these are my corporate calendars.
  • They have many, many items (not sue how much but a couple of hundreds I reckon, going back to 2006)
  • Calendar are synced with a Zimbra server (fully patched 8.8.15).

Noticing a pattern here regarding Zimbra? Or merely a coincidence?

If i set calendar.threading.disabled to true the startup time becomes unbearably bad.

Did some more testing. When disabling the caldav calendars, startup time is normal (that was not the case in the original 1.0.2 release if i recall correctly). Enabling the 'tasks' calendar (cleared everything, just 1 item) workes just fine. However, as soon as I enable my corporate calendar the UI freezes for at least a minute.

Flags: needinfo?(freddy)

Maybe the performance profiler would help here? Is it working on 102?

(In reply to Andrei Hajdukewycz [:sancus] from comment #12)

Maybe the performance profiler would help here? Is it working on 102?

I do not seem to be able to open the developer tools (not with ctrl-shift-I nor clicking in the menu). I tried the error console, I see a lot of warning's there along the line of "Calendar: Parsing failed for parts of the item (while this is considered to be a minor issue, we continue processing the item)" and then per item usually something like "X-LIC-ERROR;X-LIC-ERRORTYPE=VALUE-PARSE-ERROR:No value for LOCATION property. Removing entire property".

Tried to look at the logs in Zimbra as well. Disabled the caldav calendar en then enabled it. It takes Zimbra about 10 seconds to send out all the request, which do appear visually in TB promptly. However, the UI then freezes for a minute or two.

(In reply to Andrei Hajdukewycz [:sancus] from comment #12)

Maybe the performance profiler would help here? Is it working on 102?

No, not yet. Bug 1771304 - Performance profiler completely broken on Thunderbird.

Freddy, how is the daily build?

Flags: needinfo?(freddy)

(In reply to Wayne Mery (:wsmwk) from comment #14)

(In reply to Andrei Hajdukewycz [:sancus] from comment #12)

Maybe the performance profiler would help here? Is it working on 102?

No, not yet. Bug 1771304 - Performance profiler completely broken on Thunderbird.

Freddy, how is the daily build?

Tried the daily build 104.0a1 (2022-07-23), same issue. What I have been noticing in the most recent 102.0.3 and in the daily build as well is that the first few seconds after startup the UI does seem to be responsive. But after that is freezes for more that a minute, triggering the gnome application unresponsive popup which has a timeout setting of 1 minute. The popup is only triggered once, so the freeze is anywhere between 1 and 2 minutes.

FYI, I will be AFK for a fortnight.

Flags: needinfo?(freddy)

I have the similar issue on Archlinux and KDE with Thunderbird 102.0.3. UI freezes completely while calendars' update is taking place. I have two calendars enabled: one over caldav and the other over iCal. The one that is connected by iCal has a lot of events. The problem could be easily triggered by clicking "Synchronize" button inside the Calendar tab. The 91 version of Thunderbird has no such issue with the same setup.

You can try setting the calendar.icaljs pref to false.

Thanks for the advice! It seems that setting calendar.icaljs pref to false have helped: I see no GUI freezes anymore.

Status: UNCONFIRMED → RESOLVED
Closed: 7 months ago
Resolution: --- → DUPLICATE

Hello,
I confirm on my side too that setting calendar.icaljs pref to false have helped: I see no freezes at start-up anymore.
Thanks for finding this solution!

Since I am using caldav and not ical , much to my surprise setting the calendar.icaljs to false indeed helps to avoid the GUI freezes.

Have not seen any unwanted side effects yet, sure hope it stays that way.

Found an unwanted side effect unfortunately. The 'today pane' no longer shows any items.
Setting calendar.icaljs to true and hiding the 'today pane' still freezes the UI.
Tested on version 102.1.2.

Can someone tell me where to find the calendar.icaljs? I've looked in the prefs.js and other places and can't find it. I have six calendars set up (not Zimbra) and my Thunderbird is basically useless now. Been sitting, locked up, for 45 minutes now. Windows 11 21h2.

(In reply to Paul C. from comment #23)

Can someone tell me where to find the calendar.icaljs? I've looked in the prefs.js and other places and can't find it. I have six calendars set up (not Zimbra) and my Thunderbird is basically useless now. Been sitting, locked up, for 45 minutes now. Windows 11 21h2.

EDIT: found it:
thunderbird-->settings-->scroll all the way down the general, click on config editor, then enter calendar.icaljs in the search box. Toggle to false. But for me to have gotten this, Thunderbird woudl have had to work and allow me into the config editor. I was able to get mine fixed by disabling my windows networking, then disabling all the calendars in thunderbird. Guess I won't use calendars anymore.

We are on version 102.2.1 in the meantime. Yet, no solution for this very annoying calendar issue. And by now the update from 91 to 102 is forced, on fedora (36) at least. When the today pane is not in use disabling calendar.icaljs is an option but i myself are a heavy user of the today pane so for me it is not an option.
Furthermore, this issue is not mentioned in the "KNOWN ISSUES" section of the release notes. I do believe this issue is sincerely impacting user experience so it might be warranted to the mentioned.

I just noticed this bug was set to 'RESOLVED DUPLICATE of bug 1659582'. This one does seem to be in no way related to that bug imo. Up to version 91 everything worked flawlessly with all my calendars enabled, trouble only started with version 102. So this one is not even close to being resolved and the last update on bug 1659582 was over 2 years ago. I sincerely hope this bug gets more attention since I am very close to ditching Thunderbird for Evolution.

(In reply to Freddy from comment #26)

I just noticed this bug was set to 'RESOLVED DUPLICATE of bug 1659582'. This one does seem to be in no way related to that bug imo. Up to version 91 everything worked flawlessly with all my calendars enabled, trouble only started with version 102. So this one is not even close to being resolved and the last update on bug 1659582 was over 2 years ago.

Bug 1659582 is perhaps a generic choice. But In the absence of a performance profile it is reasonable choice given that ical.js became the default calendar engine in version 102. (ical.js' origins go back two years.)

Significant progress is being made in beta, for example https://mzl.la/3ANUSGx. So if you are keen to get early improvements and contribute to that progress, you might consider using beta. https://www.thunderbird.net/en-US/download/beta/

(In reply to Wayne Mery (:wsmwk) from comment #27)

(In reply to Freddy from comment #26)

I just noticed this bug was set to 'RESOLVED DUPLICATE of bug 1659582'. This one does seem to be in no way related to that bug imo. Up to version 91 everything worked flawlessly with all my calendars enabled, trouble only started with version 102. So this one is not even close to being resolved and the last update on bug 1659582 was over 2 years ago.

Bug 1659582 is perhaps a generic choice. But In the absence of a performance profile it is reasonable choice given that ical.js became the default calendar engine in version 102. (ical.js' origins go back two years.)

Significant progress is being made in beta, for example https://mzl.la/3ANUSGx. So if you are keen to get early improvements and contribute to that progress, you might consider using beta. https://www.thunderbird.net/en-US/download/beta/

I tried Thunderbird Beta (105b2 to be exact) but it does not seem to be any better. When starting up, there is still a lot of CPU usage for a minute or so in which the UI freezes completely. Which is to expected I guess since (some of) the 'fixes' you mentioned are targeted towards the 106 branch.

Tried 106a1 and sure enough, it starts a bit faster. However, the UI freeze still occurs, albeit a handful of seconds later. So the first 20 odd seconds the UI is repsonsive, then it freezes with high CPU usage. However, when looking at it more closely it appears to only use 1 CPU core (to its max). Which suggests to me that Thunderbird is not (entirely) multi-threaded?

Hello,

I totally disagree with the mark as duplicate of bug 1659582.

On my side, Thunderbird 102 is now totally unusable : after 2 hours, UI is still frozen, I can't read/receive any mail.

Bug 1659582 is only S2 ; that involve no dataloss.
However, when I try to reinstall Thunderbird 91 ; I can't open my profile anymore.
Moreover, I can't disable calendar since UI froze too early after statup, giving no access to any menu.

So for now, I have lost access to my local calendar (hope data are still here somewhere) because of this bug, and all setup linked to my profile (filters, address book) since I have to create a new profile to launch Thunderbird 91.
Since no workaround is provided, I think this bug should remain open with S1 severity.

Moreover, I have performed update as prompted, can't see any proposal to create a new profile, nor warning on issues.
I still don't see this (major) issue listed in release notes. So more and more users may be impacted.

PS: My config is :

  • Thunderbird 102.3
  • Windows 10 22H2
  • 9 calendars hosted on SoGo + 1 local calendar, no cache

Given that there is no activity in bug 1659582 and we have active people here, let's undupe.

The profiler and its instructions have improved. Please post a profiler URL using the preciese instructions at https://support.mozilla.org/en-US/kb/profiling-thunderbird-performance.

draco, please collect yours with Windows started in safe mode. https://support.microsoft.com/en-us/help/12376/windows-10-start-your-pc-in-safe-mode

Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---

Let's call this S2 until proved otherwise.

Severity: -- → S2

FWIW, I have been using 'Daily' for the last couple of weeks. And for a bit of good news and hope for better days, version 107a1 starts up fast, loads all calendars without issues and the today pane is usable as well. So I really hope this version will be released soon, or the necessary patches are applied to the current 102 release.

I think the only key calendar fixes in past couple weeks are

  • on nightly 9/20 Bug 1789999 - Thunderbird pauses for 10-15 seconds at a time, even for minutes. Stuck in icaltimezone_compare_change_fn of icaltime_compare of ical.js - fixed only 3 days ago, now on beta 106, not yet on version 102 (but it will be)
  • on nightly 9/10 Bug 1788549 - Avoid loading the task list and the Today Pane to-do list unless they are visible

So if your improvement happened on 9/20 nightly or later then then it was fixed by bug 1789999. Otherwise, likely didn't come from a calendar fix

Flags: needinfo?(freddy)

(In reply to Wayne Mery (:wsmwk) from comment #34)

I think the only key calendar fixes in past couple weeks are

  • on nightly 9/20 Bug 1789999 - Thunderbird pauses for 10-15 seconds at a time, even for minutes. Stuck in icaltimezone_compare_change_fn of icaltime_compare of ical.js - fixed only 3 days ago, now on beta 106, not yet on version 102 (but it will be)
  • on nightly 9/10 Bug 1788549 - Avoid loading the task list and the Today Pane to-do list unless they are visible

So if your improvement happened on 9/20 nightly or later then then it was fixed by bug 1789999. Otherwise, likely didn't come from a calendar fix

The improvement did indeed happen on 9/20 nightly. So bug 1789999 might actually be the solution. So I sincerely hope this fix gets applied to version 102 real soon.

Flags: needinfo?(freddy)

I can confirm this bug on Windows 11 21H2, Thunderbird 102.3.1.
Please fix.

Same bug here on Windows 10 21H2 with TB 102.3.1 64 bits

(In reply to Freddy from comment #35)

(In reply to Wayne Mery (:wsmwk) from comment #34)

I think the only key calendar fixes in past couple weeks are

  • on nightly 9/20 Bug 1789999 - Thunderbird pauses for 10-15 seconds at a time, even for minutes. Stuck in icaltimezone_compare_change_fn of icaltime_compare of ical.js - fixed only 3 days ago, now on beta 106, not yet on version 102 (but it will be)
  • on nightly 9/10 Bug 1788549 - Avoid loading the task list and the Today Pane to-do list unless they are visible

So if your improvement happened on 9/20 nightly or later then then it was fixed by bug 1789999. Otherwise, likely didn't come from a calendar fix

The improvement did indeed happen on 9/20 nightly. So bug 1789999 might actually be the solution. So I sincerely hope this fix gets applied to version 102 real soon.

Yes, in 102.3.2 which just released. Is it better for you?

Flags: needinfo?(freddy)

(In reply to Wayne Mery (:wsmwk) from comment #38)

(In reply to Freddy from comment #35)

(In reply to Wayne Mery (:wsmwk) from comment #34)

I think the only key calendar fixes in past couple weeks are

  • on nightly 9/20 Bug 1789999 - Thunderbird pauses for 10-15 seconds at a time, even for minutes. Stuck in icaltimezone_compare_change_fn of icaltime_compare of ical.js - fixed only 3 days ago, now on beta 106, not yet on version 102 (but it will be)
  • on nightly 9/10 Bug 1788549 - Avoid loading the task list and the Today Pane to-do list unless they are visible

So if your improvement happened on 9/20 nightly or later then then it was fixed by bug 1789999. Otherwise, likely didn't come from a calendar fix

The improvement did indeed happen on 9/20 nightly. So bug 1789999 might actually be the solution. So I sincerely hope this fix gets applied to version 102 real soon.

Yes, in 102.3.2 which just released. Is it better for you?

Yes, 102.3.2 is much better. Still quite a spike in CPU usage but no more UI freezes. Happy to go back to the stable release now, thanks!

Flags: needinfo?(freddy)

Working for me as well now. Thank you!

Yes, much better for me too !

102.3.2 seems to have fixed my calendar.

Status: REOPENED → RESOLVED
Closed: 7 months ago2 months ago
Duplicate of bug: 1789999
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.