Closed Bug 1777768 Opened 2 months ago Closed 1 month ago

Update PDF.js to new version 13c01b6d4ababf039fe59ef800ebae38b1de37f5 from 2022-06-30 08:31:22

Categories

(Firefox :: PDF Viewer, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
104 Branch
Tracking Status
firefox104 --- fixed

People

(Reporter: update-bot, Assigned: update-bot)

References

(Blocks 1 open bug)

Details

(Whiteboard: [3pl-filed][task_id: QiQL1m3iSnuOyhRA8PERag])

Attachments

(1 file)

This update covers 17 commits:


9723c5d3775ac11479a96cf7104df3b527df99a6 by Calixte Denizet

https://github.com/mozilla/pdf.jscommit/9723c5d3775ac11479a96cf7104df3b527df99a6
Authored: 2022-06-29 15:39:02 +0200
Committed: 2022-06-30 09:56:34 +0200

[Editor] Handle correctly colors when saving a document in HCM

  • for example in Dusk theme (Windows 11), black appears to be white, so
    the user will draw something in white. But if they want to print or
    save the used color must be black.
  • fix a bug with the color input which only accepts hex string colors;
  • adjust outline color of the selected/hovered editors in HCM.

Files Modified:

  • src/display/display_utils.js
  • src/display/editor/editor.js
  • src/display/editor/freetext.js
  • src/display/editor/ink.js
  • src/display/editor/tools.js
  • web/annotation_editor_layer_builder.css

a694e360a462ee25fe0a3ef1af9c8f03399494bd by Calixte Denizet

https://github.com/mozilla/pdf.jscommit/a694e360a462ee25fe0a3ef1af9c8f03399494bd
Authored: 2022-06-29 18:09:32 +0200
Committed: 2022-06-29 19:35:40 +0200

[Editor] Allow to select a freetext editor when in ink mode

  • and when in ink mode, change the toolbar active button when
    a freetext edited.

Files Modified:

  • src/display/editor/annotation_editor_layer.js
  • src/display/editor/freetext.js
  • src/display/editor/tools.js
  • web/annotation_editor_layer_builder.css

63f2d0bb640db96cf42e996fe79c557cc4d07998 by Jonas Jenwald

https://github.com/mozilla/pdf.jscommit/63f2d0bb640db96cf42e996fe79c557cc4d07998
Authored: 2022-06-29 15:58:57 +0200
Committed: 2022-06-29 16:16:48 +0200

Fix the annotationEditorMode-compatibility for older browsers (PR 15113 follow-up)

Files Modified:

  • web/app_options.js
  • web/base_viewer.js

bc5b6cd08c8974122428f87312d0c1c2393e6fdd by Calixte Denizet

https://github.com/mozilla/pdf.jscommit/bc5b6cd08c8974122428f87312d0c1c2393e6fdd
Authored: 2022-06-29 16:11:11 +0200
Committed: 2022-06-29 16:11:11 +0200

[Editor] Set the freetext editor dimensions when the changing the font size

Files Modified:

  • src/display/editor/freetext.js

3e751679bacbaa3edabbdfb0af62b6b161141723 by Calixte Denizet

https://github.com/mozilla/pdf.jscommit/3e751679bacbaa3edabbdfb0af62b6b161141723
Authored: 2022-06-28 21:29:35 +0200
Committed: 2022-06-29 11:52:19 +0200

Add a visible page border in HCM (bug 1776914)

Files Modified:

  • web/pdf_viewer.css

44a75c2a0fac3db498f32746e0d9e602f4ac17fd by Jonas Jenwald

https://github.com/mozilla/pdf.jscommit/44a75c2a0fac3db498f32746e0d9e602f4ac17fd
Authored: 2022-06-29 11:20:31 +0200
Committed: 2022-06-29 11:40:54 +0200

[editor] Slightly shorten the en-US freetext_default_content placeholder text

Now that it's possible to change the font-size, this placeholder string feels a little bit long (especially for larger font-sizes).

Given that Editing is not enabled/released yet, I hope that it should be fine to update this without changing the l10n-id.

Files Modified:

  • l10n/en-US/viewer.properties
  • web/l10n_utils.js

f3ba02bc0029e88b4cbf8d948d740aba2799a52e by Jonas Jenwald

https://github.com/mozilla/pdf.jscommit/f3ba02bc0029e88b4cbf8d948d740aba2799a52e
Authored: 2022-06-29 11:13:23 +0200
Committed: 2022-06-29 11:40:54 +0200

[editor] Remove the unused name-property from the editorParamsToolbars DOM elements

As far as I can tell, this is completely unused and can thus be removed.

Files Modified:

  • web/viewer.html

4a4c6b98515ed233b3f078422ad805beee1cd760 by Jonas Jenwald

https://github.com/mozilla/pdf.jscommit/4a4c6b98515ed233b3f078422ad805beee1cd760
Authored: 2022-06-29 11:13:03 +0200
Committed: 2022-06-29 11:35:58 +0200

[editor] Introduce a proper annotationEditorMode option/preference (PR 15075 follow-up)

This replaces the boolean annotationEditorEnabled option/preference with a "proper" annotationEditorMode one. This way it's not only possible for the user to control if Editing is enabled/disabled, but also which specific Editing-mode should become enabled upon PDF document load.

Given that Editing is not enabled/released yet, I cannot imagine that changing the name and type of the option/preference should be an issue.

Files Modified:

  • extensions/chromium/preferences_schema.json
  • src/shared/util.js
  • web/app.js
  • web/app_options.js
  • web/base_viewer.js

1a3ef2a0aa62acd570ff0303841200243be6ca6a by Calixte Denizet

https://github.com/mozilla/pdf.jscommit/1a3ef2a0aa62acd570ff0303841200243be6ca6a
Authored: 2022-06-13 18:23:10 +0200
Committed: 2022-06-28 12:05:04 +0200

[editor] Add some UI elements in order to set font size & color, and ink thickness & color

Files Added:

  • web/annotation_editor_params.js

Files Modified:

  • l10n/en-US/viewer.properties
  • src/core/annotation.js
  • src/display/canvas.js
  • src/display/display_utils.js
  • src/display/editor/annotation_editor_layer.js
  • src/display/editor/editor.js
  • src/display/editor/freetext.js
  • src/display/editor/ink.js
  • src/display/editor/tools.js
  • src/pdf.js
  • src/shared/util.js
  • test/integration/freetext_editor_spec.js
  • test/unit/annotation_spec.js
  • web/app.js
  • web/base_viewer.js
  • web/toolbar.js
  • web/viewer.css
  • web/viewer.html
  • web/viewer.js

3789dab307eae0a586c8da2f8c5a34b761a196a8 by Calixte Denizet

https://github.com/mozilla/pdf.jscommit/3789dab307eae0a586c8da2f8c5a34b761a196a8
Authored: 2022-06-25 16:40:46 +0200
Committed: 2022-06-25 17:19:57 +0200

Always flush the current item with MarkedContent stuff when getting text (#15094)

Files Modified:

  • src/core/evaluator.js
  • test/unit/api_spec.js

38daef065a7bce9a5e26dbacf01326d90d747ed6 by Tim van der Meij

https://github.com/mozilla/pdf.jscommit/38daef065a7bce9a5e26dbacf01326d90d747ed6
Authored: 2022-06-25 16:27:24 +0200
Committed: 2022-06-25 16:28:44 +0200

Update dependencies to the most recent versions

Note that even though Puppeteer got a major version bump the changelog
doesn't include compatibility changes that are relevant to us; please
see https://github.com/puppeteer/puppeteer/releases.

Files Modified:

  • package-lock.json
  • package.json

f7d69aab1525bb8cc876519c5f80a95eccce726d by Tim van der Meij

https://github.com/mozilla/pdf.jscommit/f7d69aab1525bb8cc876519c5f80a95eccce726d
Authored: 2022-06-25 15:45:55 +0200
Committed: 2022-06-25 15:45:55 +0200

Update translations to the most recent versions

Files Modified:

  • l10n/be/viewer.properties
  • l10n/bn/viewer.properties
  • l10n/cy/viewer.properties
  • l10n/dsb/viewer.properties
  • l10n/el/viewer.properties
  • l10n/en-GB/viewer.properties
  • l10n/es-AR/viewer.properties
  • l10n/es-CL/viewer.properties
  • l10n/es-MX/viewer.properties
  • l10n/et/viewer.properties
  • l10n/fr/viewer.properties
  • l10n/gn/viewer.properties
  • l10n/he/viewer.properties
  • l10n/hsb/viewer.properties
  • l10n/hu/viewer.properties
  • l10n/ia/viewer.properties
  • l10n/id/viewer.properties
  • l10n/is/viewer.properties
  • l10n/it/viewer.properties
  • l10n/ka/viewer.properties
  • l10n/ko/viewer.properties
  • l10n/nl/viewer.properties
  • l10n/nn-NO/viewer.properties
  • l10n/oc/viewer.properties
  • l10n/pt-BR/viewer.properties
  • l10n/pt-PT/viewer.properties
  • l10n/rm/viewer.properties
  • l10n/ru/viewer.properties
  • l10n/sv-SE/viewer.properties
  • l10n/tg/viewer.properties
  • l10n/tr/viewer.properties
  • l10n/uk/viewer.properties
  • l10n/vi/viewer.properties
  • l10n/zh-CN/viewer.properties
  • l10n/zh-TW/viewer.properties

83ecc3f46c4d70a6c4bfd55c5b3b9a01cb034cb5 by neilnaveen

https://github.com/mozilla/pdf.jscommit/83ecc3f46c4d70a6c4bfd55c5b3b9a01cb034cb5
Authored: 2022-06-09 01:08:19 +0000
Committed: 2022-06-25 15:32:33 +0200

chore: Set permissions for GitHub actions

Restrict the GitHub token permissions only to the required ones; this way, even if the attackers will succeed in compromising your workflow, they won’t be able to do much.

https://docs.github.com/en/actions/using-workflows/workflow-syntax-for-github-actions#permissions

https://docs.github.com/en/actions/using-jobs/assigning-permissions-to-jobs

Keeping your GitHub Actions and workflows secure Part 1: Preventing pwn requests

Signed-off-by: neilnaveen <42328488+neilnaveen@users.noreply.github.com>

Files Modified:

  • .github/workflows/ci.yml
  • .github/workflows/codeql.yml

c0f65657a2993a08cf5254330e1335ca934532bb by Jonas Jenwald

https://github.com/mozilla/pdf.jscommit/c0f65657a2993a08cf5254330e1335ca934532bb
Authored: 2022-06-25 09:52:32 +0200
Committed: 2022-06-25 09:54:05 +0200

Use the built components/pdf_viewer.css file in the reference tests

Currently we're loading the web/annotation_layer_builder.css and web/xfa_layer_builder.css files directly during the reference tests.
This becomes a problem is we want to reduce duplication in the CSS-files, e.g. by placing common rules in the web/pdf_viewer.css file.

Given that gulp components is already being utilized when running tests, we can thus use that to instead depend on the entire viewer-components CSS-file in the reference tests.

Files Modified:

  • test/driver.js

12c76d35a510980ff9f7ce59bd5f95f7e478759a by naveen

https://github.com/mozilla/pdf.jscommit/12c76d35a510980ff9f7ce59bd5f95f7e478759a
Authored: 2022-06-25 01:30:04 +0000
Committed: 2022-06-25 01:30:04 +0000

chore: Included githubactions in the dependabot config

This should help with keeping the GitHub actions updated on new releases. This will also help with keeping it secure.

Dependabot helps in keeping the supply chain secure https://docs.github.com/en/code-security/dependabot

GitHub actions up to date https://docs.github.com/en/code-security/dependabot/working-with-dependabot/keeping-your-actions-up-to-date-with-dependabot

https://github.com/ossf/scorecard/blob/main/docs/checks.md#dependency-update-tool
Signed-off-by: naveen <172697+naveensrinivasan@users.noreply.github.com>

Files Added:

  • .github/dependabot.yml

9748d3eb85c16d67a3173f289c366c6ba74f98fc by Jonas Jenwald

https://github.com/mozilla/pdf.jscommit/9748d3eb85c16d67a3173f289c366c6ba74f98fc
Authored: 2022-06-24 20:12:50 +0200
Committed: 2022-06-24 20:15:46 +0200

Remove element ids from the layersView in the sidebar

Similar to other recent patches, see e.g. PR 15057, we don't want to add these kind of ids to DOM-elements since they shouldn't become "linkable" through the URL hash.

Please note: This patch can be tested, in the viewer, with e.g. bug1737260.pdf from the test-suite.

Files Modified:

  • web/pdf_layer_viewer.js
  • web/viewer.css

0c420f5135dc39e37244e74c2dc4584da5eb0f83 by Calixte Denizet

https://github.com/mozilla/pdf.jscommit/0c420f5135dc39e37244e74c2dc4584da5eb0f83
Authored: 2022-06-23 15:47:45 +0200
Committed: 2022-06-24 20:02:32 +0200

Support rotating editor layer

  • As in the annotation layer, use percent instead of pixels as unit;
  • handle the rotation of the editor layer in allowing editing when rotation
    angle is not zero;
  • the different editors are rotated counterclockwise in order to be usable
    when the main page is itself rotated;
  • add support for saving/printing rotated editors.

Files Modified:

  • src/core/annotation.js
  • src/display/annotation_layer.js
  • src/display/editor/annotation_editor_layer.js
  • src/display/editor/editor.js
  • src/display/editor/freetext.js
  • src/display/editor/ink.js
  • test/integration/scripting_spec.js
  • test/test_manifest.json
  • test/unit/annotation_spec.js
  • web/annotation_editor_layer_builder.css
  • web/annotation_editor_layer_builder.js
  • web/annotation_layer_builder.css
  • web/pdf_viewer.css

Duplicate of this bug: 1776538
Assignee: nobody → update-bot
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 104 Branch
Depends on: 1777929
Whiteboard: [3pl-filed][task_id: QiQL1m3iSnuOyhRA8PERag] → [3pl-filed][task_id: QiQL1m3iSnuOyhRA8PERag][no-nag]
Whiteboard: [3pl-filed][task_id: QiQL1m3iSnuOyhRA8PERag][no-nag] → [3pl-filed][task_id: QiQL1m3iSnuOyhRA8PERag]
You need to log in before you can comment on or make changes to this bug.