Closed Bug 1778318 Opened 5 months ago Closed 5 months ago

Remove JS getters from internal module objects

Categories

(Core :: JavaScript Engine, task, P3)

task

Tracking

()

RESOLVED FIXED
104 Branch
Tracking Status
firefox104 --- fixed

People

(Reporter: jonco, Assigned: jonco)

References

Details

Attachments

(3 files)

Following bug 1774454, the JS getters on internal module objects are only used by test code, via the shell module object wrapper system. None of these objects are exposed to JS.

If change the shell module object wrappers to use the C++ accessors we can remove these getters entirely.

Test code interacts with these module objects by means of the shell object
wrappers. If we add a few more C++ accessors where necessary we can use these
instead of calling the JS property getters.

Since these getters are now unused we can remove them.

Depends on D151133

Since these no longer have any methods or getters we can give them null prototypes.

Depends on D151134

Pushed by jcoppeard@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/071ec66b1874
Part 1: Use C++ accessors of internal module objects in shell object wrappers r=arai
https://hg.mozilla.org/integration/autoland/rev/f2acb176f0ff
Part 2: Remove getters from internal module objects r=arai
https://hg.mozilla.org/integration/autoland/rev/4381d9d2dce1
Part 3: Remove prototypes for internal module objects r=arai
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 104 Branch
Regressions: 1778439
You need to log in before you can comment on or make changes to this bug.