Closed Bug 1778335 Opened 1 month ago Closed 1 month ago

Typing https://mozilla.org/ into address bar suggests "httphttps://mozilla.org/ — Visit" (additional http prefix)

Categories

(Firefox :: Address Bar, defect, P1)

Firefox 103
defect
Points:
3

Tracking

()

VERIFIED FIXED
104 Branch
Tracking Status
firefox-esr91 --- unaffected
firefox-esr102 --- unaffected
firefox102 --- unaffected
firefox103 --- verified
firefox104 --- verified

People

(Reporter: ke5trel, Assigned: daisuke)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

STR:

  1. Type https://mozilla.org/ into the address bar, including the trailing slash (site needs to autofill and have a www subdomain).

Expected:
First suggested item is https://mozilla.org/ — Visit or https://www.mozilla.org/ — Visit.

Actual:
After typing the trailing slash, the first suggestion becomes httphttps://mozilla.org/ — Visit, having an additional http prefix. Pressing Enter does a web search or tries to open the httphttps: protocol.

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=7769fe500298f839594d1c1a3782ad23b5d5926e&tochange=58d8e3010b7739779b9651e8c213c5865601b49a

Regressed by Bug 1770095.

:daisuke, since you are the author of the regressor, bug 1770095, could you take a look?
For more information, please visit auto_nag documentation.

Flags: needinfo?(daisuke)

Hi Kestrel! Thank you very much for the report.

Yes, I also could reproduce this issue.
I will fix it.
Thanks again.

Assignee: nobody → daisuke
Status: NEW → ASSIGNED
Flags: needinfo?(daisuke)
Pushed by dakatsuka.birchill@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b35262d256b9
Handle a URL that has www name in history correctly. r=adw
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 104 Branch

Comment on attachment 9284426 [details]
Bug 1778335: Handle a URL that has www name in history correctly.

Beta/Release Uplift Approval Request

  • User impact if declined: There is a case where displaying autofill is wrong.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The change is only a few rows and affects only autofill feature.
  • String changes made/needed: None
  • Is Android affected?: Unknown
Attachment #9284426 - Flags: approval-mozilla-beta?

Comment on attachment 9284426 [details]
Bug 1778335: Handle a URL that has www name in history correctly.

Approved for 103.0b7, thanks.

Attachment #9284426 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Severity: -- → S3
Points: --- → 3
Priority: -- → P1
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Reproduced the issue on Win10 using build 103.0a1(20220607214725).
Verified as fixed on Beta 103.0b7(20220710185935) and Nightly 104.0a1(20220711094852).

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.