Closed Bug 1778492 Opened 3 months ago Closed 2 months ago

Add an origin trial for COEP: Credentialless

Categories

(Core :: DOM: Core & HTML, task)

task

Tracking

()

RESOLVED FIXED
105 Branch
Tracking Status
firefox104 --- fixed
firefox105 --- fixed

People

(Reporter: hsinyi, Assigned: sefeng)

Details

Attachments

(2 files)

No description provided.
Assignee: nobody → sefeng
Status: NEW → ASSIGNED

This avoids adding the .eslintrc.js file to bypass
no-undef rule.

Pushed by sefeng@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/34227495753a
Add an origin trial for coep: credentialless r=emilio,necko-reviewers,kershaw
https://hg.mozilla.org/integration/autoland/rev/6c3ac3569d31
Move origin-trial mochitests to its own directory r=Standard8

Backed out 2 changesets (Bug 1778492) for causing eslint failures.
Backout link
Push with failures
Failure Log

Flags: needinfo?(sefeng)
Regressions: 1781286
Regressions: 1781288
Regressions: 1781289
Regressions: 1781290

Bug 1781286 indicates that browser_origin_trial_coep_credentialless_fetch.js takes too long to run (succeeded), I'll split the test case into multiple ones.

The rest are crashes on Android on tier 2 though. Looking..

Flags: needinfo?(sefeng)
Pushed by sefeng@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/96c019e10f7b
Add an origin trial for coep: credentialless r=emilio,necko-reviewers,kershaw
https://hg.mozilla.org/integration/autoland/rev/1133dcd67782
Move origin-trial mochitests to its own directory r=Standard8
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 105 Branch
No longer regressions: 1781290
No longer regressions: 1781286
No longer regressions: 1781288

Hi Sean, as we discussed, could you please help prepare uplift request so that the experiments of using the Credentialless feature can start on beta under origin trial? Thank you.

Flags: needinfo?(sefeng)

Comment on attachment 9284720 [details]
Bug 1778492 - Add an origin trial for coep: credentialless r=emilio

Beta/Release Uplift Approval Request

  • User impact if declined: No direct user impact, however the users who we'd like to experience COEP: credentialless with will need to wait for another release to experience the feature.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is not risky because only exclusively included users can use this feature.
  • String changes made/needed:
  • Is Android affected?: No
Flags: needinfo?(sefeng)
Attachment #9284720 - Flags: approval-mozilla-beta?
Attachment #9286715 - Flags: approval-mozilla-beta?

Comment on attachment 9284720 [details]
Bug 1778492 - Add an origin trial for coep: credentialless r=emilio

Approved for 104.0b6

Attachment #9284720 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9286715 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.