Closed Bug 1779144 Opened 7 months ago Closed 7 months ago

Handle tap gesture blocks in APZCTreeManager::ConvertToGecko()

Categories

(Core :: Panning and Zooming, task, P3)

task

Tracking

()

RESOLVED FIXED
104 Branch
Tracking Status
firefox104 --- fixed

People

(Reporter: botond, Assigned: botond)

References

Details

Attachments

(2 files, 1 obsolete file)

APZCTreeManager::ConvertToGecko(), used during the APZ handling of tap gesture events, assumes the tap gesture events were gesture-detected from touch events and therefore we're in the middle of a touch gesture, and accordingly looks at mTouchBlockHitResult.

However, since we implemented touchpad double-tap-to-zoom, tap gesture events can also be sent directly by the widget code. To handle them properly in ConvertToGecko(), we should maintain a "tap gesture hit result" and use it instead of mTouchBlockHitResult when applicable.

Assignee: nobody → botond
Attachment #9285690 - Attachment is obsolete: true
Pushed by bballo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fe20f47f85d9
Handle touchpad double-taps correctly in APZCTreeManager::ConvertToGecko(). r=dlrobertson
https://hg.mozilla.org/integration/autoland/rev/52ba9b55ca7c
Factor out a helper shared by the touch event and tap event handling codepaths. r=dlrobertson
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 104 Branch
Regressions: 1792708
You need to log in before you can comment on or make changes to this bug.