Reply sig processing should not eliminate really, really long signatures.

RESOLVED DUPLICATE of bug 54570

Status

--
enhancement
RESOLVED DUPLICATE of bug 54570
16 years ago
14 years ago

People

(Reporter: alex_mozilla, Assigned: sspitzer)

Tracking

(Depends on: 1 bug)

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1) Gecko/20020826

With the settings set to quote the original email, Reply to a long email. Make
it an email that is, for instance, a mail list digest. Make sure that the digest
includes some email in the middle that has a "properly" notated signature. That
is, a sig that starts with a line of text containing two dash/minus characters
("--").

The quoted reply will have the full digest email truncated at the first "--" sig.

A sig over some number of lines of text should probably not be considered a
valid "sig". If you really want to get sophisticated, a sig should be under,
say, 10 lines, but could include more lines of "standard" boiler plate
disclaimer junk. Recognizing those disclaimers could probably be done with some
kind of Bayseian thing (specifically counting typical disclaimer words).
(Reporter)

Comment 1

16 years ago
Bug 126149 may be related.
(Reporter)

Comment 2

16 years ago
Also, bug 121424 seems to be related to this.

Comment 3

16 years ago
The problem is that mozilla does not know where a signature ends. Making
dependent of bug 54570.
Status: UNCONFIRMED → NEW
Depends on: 54570
Ever confirmed: true

Updated

16 years ago
QA Contact: olgam → laurel

Comment 4

15 years ago
*** Bug 208668 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
This bug is the same problem as 54570 and one solution to it. This solution and
others are already proposed there.

See also: 
Bug 58406 - [RFE] let user choose signature separator
Bug 216728 - Let delimiter behaviour with position of signature be overridden

*** This bug has been marked as a duplicate of 54570 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.