[DOGFOOD] Crash while accessing bug report on bugzilla

VERIFIED DUPLICATE of bug 17315

Status

()

Core
Layout: Form Controls
P3
critical
VERIFIED DUPLICATE of bug 17315
19 years ago
19 years ago

People

(Reporter: Nisheeth Ranjan, Assigned: rods (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+], URL)

(Reporter)

Description

19 years ago
Go to above url and crash with the following call stack:

nsListControlFrame::GetSelect(nsIContent * 0xdddddddd) line 1062 + 13 bytes
nsListControlFrame::GetOptions(nsIContent * 0xdddddddd, nsIDOMHTMLSelectElement
* 0x00000000) line 1114 + 9 bytes
nsListControlFrame::GetOptionContent(int 10) line 1097 + 14 bytes
nsListControlFrame::SetContentSelected(int 10, int 1) line 1232 + 12 bytes
nsListControlFrame::Reset(nsIPresContext * 0x02b1a7b0) line 1349
nsListControlFrame::AddOption(nsListControlFrame * const 0x0322825c,
nsIPresContext * 0x02b1a7b0, int 10) line 1629
nsComboboxControlFrame::AddOption(nsComboboxControlFrame * const 0x03228198,
nsIPresContext * 0x02b1a7b0, int 10) line 1073 + 20 bytes
nsHTMLSelectElement::AddOption(nsHTMLSelectElement * const 0x0321cf9c,
nsIContent * 0x0323e89c) line 662 + 32 bytes
nsHTMLOptionElement::SetParent(nsHTMLOptionElement * const 0x0323e89c,
nsIContent * 0x0321cf90) line 208
nsGenericHTMLContainerElement::AppendChildTo(nsIContent * 0x0323e89c, int 0)
line 2968
nsHTMLSelectElement::AppendChildTo(nsHTMLSelectElement * const 0x0321cf90,
nsIContent * 0x0323e89c, int 0) line 165 + 22 bytes
SinkContext::CloseContainer(const nsIParserNode & {...}) line 1218 + 30 bytes
HTMLContentSink::CloseContainer(HTMLContentSink * const 0x02b18bb0, const
nsIParserNode & {...}) line 2563 + 15 bytes
CNavDTD::CloseContainer(const nsIParserNode & {...}, nsHTMLTag eHTMLTag_option,
int 1) line 2733 + 31 bytes
CNavDTD::CloseContainersTo(int 7, nsHTMLTag eHTMLTag_option, int 1) line 2770 +
26 bytes
CNavDTD::HandleDefaultStartToken(CToken * 0x02b93580, nsHTMLTag eHTMLTag_option,
nsIParserNode & {...}) line 975
CNavDTD::HandleStartToken(CToken * 0x02b93580) line 1285 + 22 bytes
CNavDTD::HandleToken(CNavDTD * const 0x02beb4a0, CToken * 0x02b93580, nsIParser
* 0x018cbdc0) line 654 + 12 bytes
CNavDTD::BuildModel(CNavDTD * const 0x02beb4a0, nsIParser * 0x018cbdc0,
nsITokenizer * 0x02beba40, nsITokenObserver * 0x00000000, nsIContentSink *
0x02b18bb0) line 458 + 20 bytes
nsParser::BuildModel() line 1062 + 34 bytes
nsParser::ResumeParse(nsIDTD * 0x00000000, int 0) line 973 + 11 bytes
nsParser::OnDataAvailable(nsParser * const 0x018cbdc4, nsIChannel * 0x03203db0,
nsISupports * 0x00000000, nsIInputStream * 0x03207628, unsigned int 0, unsigned
int 8192) line 1400 + 19 bytes
nsDocumentBindInfo::OnDataAvailable(nsDocumentBindInfo * const 0x031feba0,
nsIChannel * 0x03203db0, nsISupports * 0x00000000, nsIInputStream * 0x03207628,
unsigned int 0, unsigned int 8192) line 1216 + 32 bytes
nsChannelListener::OnDataAvailable(nsChannelListener * const 0x03204910,
nsIChannel * 0x03203db0, nsISupports * 0x00000000, nsIInputStream * 0x03207628,
unsigned int 0, unsigned int 8192) line 1402
nsHTTPResponseListener::OnDataAvailable(nsHTTPResponseListener * const
0x032071c0, nsIChannel * 0x0320bf00, nsISupports * 0x03203db0, nsIInputStream *
0x03207628, unsigned int 8192, unsigned int 8192) line 171 + 47 bytes
nsOnDataAvailableEvent::HandleEvent(nsOnDataAvailableEvent * const 0x0321fb90)
line 413
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x0321fbe0) line 169 + 12 bytes
PL_HandleEvent(PLEvent * 0x0321fbe0) line 537 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x0138eef0) line 498 + 9 bytes
_md_EventReceiverProc(void * 0x01ac064e, unsigned int 49269, unsigned int 0,
long 20508400) line 972 + 9 bytes
USER32! 77e71250()

Assigning this to Rod because I see select form element code on the stack and,
based on today's raptor all hands meeting, I remember that Rod is working on
selects.  Please re-assign this, if appropriate.  Thanks.
(Reporter)

Updated

19 years ago
Blocks: 17584

Updated

19 years ago
Whiteboard: [PDT+]

Comment 1

19 years ago
Putting on [PDT+] radar.

Updated

19 years ago
Severity: normal → critical
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 2

19 years ago
*** This bug has been marked as a duplicate of 17315 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 3

19 years ago
This is actually not a duplicate of 17315, but it is probably a duplicate of
17852.
You need to log in before you can comment on or make changes to this bug.