Closed Bug 1782250 Opened 4 months ago Closed 3 months ago

Cannot connect to pop.aol.com via OAuth2 using verizon account - "server does not support the selected authentication method"

Categories

(MailNews Core :: Networking: POP, defect, P1)

Thunderbird 102
Unspecified
All

Tracking

(thunderbird_esr102+ verified, thunderbird105 fixed)

VERIFIED FIXED
106 Branch
Tracking Status
thunderbird_esr102 + verified
thunderbird105 --- fixed

People

(Reporter: leojoncas, Assigned: rnons)

References

(Regression, )

Details

(Keywords: regression)

Attachments

(2 files)

Steps to reproduce:

I have an email address in the verizon.net domain, which for several years now has been supported by aol.com. Since last December I have been using OAuth2 as the authentication method. After upgrading to TB 102.0, "Get Messages" fails to connect to pop.aol.com used by one of my accounts. It tells me OAuth2 is not supported for that server.

Actual results:

TB fails to get messages and displays a pop saying that OAuth2 is not supported by pop.aol.com.

This is incorrect, so TB seems to be enforcing invalid constraints on pop.aol.com.

Expected results:

Before the upgrade to TB 102.0, OAuth2 connection to pop.aol.com worked fine. And it still works from my iPhone. So why does TB not allow it?

Note that prior to TB 102.0, TB would not let me directly create a server config using OAuth2 for pop.aol.com. However, I was able to create one for another server and then change it to pop.aol.com. As of TB 102.0, there seems to be a hard check that prevents trying this connection. So I get the impression that TB previously had an invalid "config" for pop.aol.com and now that invalid config is being enforced. Wht does TB not allow OAuth2 via pop.aol.com?

I guess this is bug 1778576. Please wait a few days for the next 102 release, or download a beta version to confirm it's fixed. Thanks.

Perhaps. BTW My Gmail account also uses OAuth2 for POP and that still works.

I noticed your tip about "mailnews.pop3.loglevel" in that other bug. So I tried that on my system. Here is what I saw in the Error Console:

mailnews.pop3.28: Connecting to pop://pop.aol.com:995 Pop3Client.jsm:129:18
mailnews.pop3.28: Connected Pop3Client.jsm:263:18
mailnews.pop3.28: S: +OK Hello from jpop-0.1

Pop3Client.jsm:304:18
mailnews.pop3.28: C: CAPA Pop3Client.jsm:436:20
mailnews.pop3.28: S: +OK CAPA list follows

IMPLEMENTATION jpop-0.1

TOP

USER

SASL LOGIN PLAIN

.

Pop3Client.jsm:304:18
mailnews.pop3.28: Possible auth methods: Pop3Client.jsm:513:18
mailnews.pop3.28: Got an error name=pop3AuthMechNotSupported Pop3Client.jsm:1243:18
mailnews.pop3.28: Done with status=2147500037 Pop3Client.jsm:1274:18
mailnews.pop3.28: Folder lock released. Pop3Client.jsm:1287:20
mailnews.pop3.28: C: QUIT Pop3Client.jsm:436:20
mailnews.pop3.28: Connection closed. Pop3Client.jsm:337:18
mailnews.pop3.28: S: +OK Server signing off.

Pop3Client.jsm:304:18
mailnews.pop3.29: Connecting to pop://pop.aol.com:995 Pop3Client.jsm:129:18
mailnews.pop3.30: Connecting to pop://pop.googlemail.com:995 Pop3Client.jsm:129:18
mailnews.pop3.29: Connected 2 Pop3Client.jsm:263:18
mailnews.pop3.29: S: +OK Hello from jpop-0.1

Pop3Client.jsm:304:18
mailnews.pop3.29: C: CAPA Pop3Client.jsm:436:20
mailnews.pop3.29: S: +OK CAPA list follows

IMPLEMENTATION jpop-0.1

TOP

USER

SASL LOGIN PLAIN

.

Pop3Client.jsm:304:18
mailnews.pop3.29: Possible auth methods: Pop3Client.jsm:513:18
mailnews.pop3.29: Got an error name=pop3AuthMechNotSupported Pop3Client.jsm:1243:18
mailnews.pop3.29: Done with status=2147500037 Pop3Client.jsm:1274:18
mailnews.pop3.29: Folder lock released. Pop3Client.jsm:1287:20
mailnews.pop3.29: C: QUIT Pop3Client.jsm:436:20
mailnews.pop3.29: S: +OK Server signing off.

Pop3Client.jsm:304:18
mailnews.pop3.29: Connection closed. Pop3Client.jsm:337:18
mailnews.pop3.30: S: +OK Gpop ready for requests from 98.118.127.241 r4mb199732687qkp

Pop3Client.jsm:304:18
mailnews.pop3.30: C: CAPA Pop3Client.jsm:436:20
mailnews.pop3.30: S: +OK Capability list follows

USER

RESP-CODES

EXPIRE 0

LOGIN-DELAY 300

TOP

UIDL

X-GOOGLE-RICO

SASL PLAIN XOAUTH2 OAUTHBEARER

.

Pop3Client.jsm:304:18
mailnews.pop3.30: Possible auth methods: XOAUTH2 Pop3Client.jsm:513:18
mailnews.pop3.30: Current auth method: XOAUTH2 Pop3Client.jsm:589:18
XHRPOSThttps://www.googleapis.com/oauth2/v3/token
[HTTP/2 200 OK 103ms]

mailnews.pop3.30: C: Logging suppressed (it probably contained auth information) Pop3Client.jsm:430:20
mailnews.pop3.30: S: +OK Welcome.

Pop3Client.jsm:304:18
mailnews.pop3.30: C: STAT Pop3Client.jsm:436:20
mailnews.pop3.30: S: +OK 0 0

Pop3Client.jsm:304:18
mailnews.pop3.30: Done with status=0 Pop3Client.jsm:1274:18
mailnews.pop3.30: C: QUIT Pop3Client.jsm:436:20
mailnews.pop3.30: S: +OK Farewell.

Pop3Client.jsm:304:18
mailnews.pop3.30: Connection closed. Pop3Client.jsm:337:18

I just tried setting up my yahoo account with pop3 on trunk. It worked. After setup getting mails seems to have got stuck though. After re-start on Thunderbird mails started coming in. Removed account and set it up again, no problem. Re-tried, and that time also went through without trouble.

lj_mozilla, could you retry on Thunderbird Beta (Thunderbird 103.0b6 or higher has fix from bug 1778576)? Just install into another folder and you'll get a separate new profile for testing.

Severity: -- → S3
Component: Untriaged → Networking: POP
Flags: needinfo?(leojoncas)
Product: Thunderbird → MailNews Core

Thanks for the Beta link. Downloaded and installed that (TB 104.0b1). Manually configured my POP server settings and restarted TB. Still getting the exact same popup window with error stating that the chosen authentication method (i.e. OAuth2) is not supported by pop.aol.com.

BTW
Initially tried using the account wizard to set the POP server settings for my "verizon.net" domain email address, which is supported by AOL nowadays. The wizard insisted on using "pop.verizon.net" or something like that. Verizon got out of the email business in 2018, but handed off support of their domain to AOL. The TB wizard is woefully out of date in what it considers valid email configs for "verizon.net" domain addresses. But perhaps I should submit a separate issue for that?

Flags: needinfo?(leojoncas)

mailnews.pop3.28: Connecting to pop://pop.aol.com:995 Pop3Client.jsm:129:18
mailnews.pop3.28: Connected Pop3Client.jsm:263:18
mailnews.pop3.28: S: +OK Hello from jpop-0.1
mailnews.pop3.28: C: CAPA Pop3Client.jsm:436:20
mailnews.pop3.28: S: +OK CAPA list follows
IMPLEMENTATION jpop-0.1
TOP
USER
SASL LOGIN PLAIN
.
mailnews.pop3.28: Possible auth methods: Pop3Client.jsm:513:18
mailnews.pop3.28: Got an error name=pop3AuthMechNotSupported Pop3Client.jsm:1243:18

According to the server response of CAPA, your server only supports LOGIN AND PLAIN. Does OAUTH work If you set mailnews.pop3.jsmodule to false and restart tb? If it works, can you get the logs by using MOZ_LOG=POP3:5, see https://wiki.mozilla.org/MailNews:Logging#Generating_a_Protocol_Log

I changed mailnews.pop3.jsmodule to false and restarted (TB 102.1.0) and still get the same error. Also tried those steps with two betas (TB 104.0b1 and then upgraded to TB 104.0b2) and get the same error.

Note that AOL POP3 OAuth2 was working fine for the past 8 months until I updated to TB 102.0. Also, it is still working just fine using iOS Mail on my iPhone. So I find it curious that the latest TB is getting a response back from pop.aol.com:995 that doesn't mention OAuth2 as an option. Is TB filtering that response at all? Or could this be a problem with the AOL response, which perhaps is suddenly causing a problem because TB has started paying closer attention to supported authentication methods listed in the response?

Note that AOL POP3 OAuth2 was working fine for the past 8 months until I updated to TB 102.0

Yes, that's strange. I don't think there is change to the pop3 C++ module between 91 and 102. You can try 91 to confirm it.

Is TB filtering that response at all?

No.

Just making sure, do you have "Connection security" set to SSL/TLS?
Can you double check the server hostname/port are exactly the same as in your ios client?

Oh, you're trying with the verizon email. That's won't work for OAuth2. Although the same server as aol, verizon would need a separate OAuth2 registration for Thunderbird.

Summary: Cannot connect to pop.aol.com via OAuth2 → Cannot connect to pop.aol.com via OAuth2 using verizon account

My TB email config:
Account Name: username@verizon.net
Email Address: username@verizon.net
Server Type: POP Mail Server
Server Name: pop.aol.com
Port: 995
User Name: username@verizon.net
Connection Security: SSL/TLS
Authentication method: OAuth2

These are the settings that worked fine with TB 91.9.0 and earlier versions and which failed immediately upon upgrading to TB 102.0. I have not reverted to 91.9.0 and tested again, because I considered that when the problem first arose and a quick search indicated some effort and potential pitfalls with reverting.

Note that the full email address must be used here because AOL is handling an address for another domain.

On iOS Mail, confirmed that fetch works with port=995 and auth=OAuth2. In its infinite wisdom, iOS chooses not to display the DNS name of the email server.

See Also: → 1698316

I am using 5 Aol mail addresses and after upgrade vom 91.13.0 today - which worked fine before - I am also getting the error that the authentification method is not supported. So this is not confined to verizon mail addresses only.

mailnews.pop3.10: Got an error name=pop3AuthMechNotSupported 6 Pop3Client.jsm:1279:18
_actionError resource:///modules/Pop3Client.jsm:1279
_actionChooseFirstAuthMethod resource:///modules/Pop3Client.jsm:558
_actionCapaResponse resource:///modules/Pop3Client.jsm:489
read resource:///modules/LineReader.jsm:55
_actionCapaResponse resource:///modules/Pop3Client.jsm:477
_onData resource:///modules/Pop3Client.jsm:317

Hi drde, have you tried setting mailnews.pop3.jsmodule to false (search for Config Editor on Settings page) and restart tb

Tried, same behaviour, The server doesn't support the authentication method.

So it's the same as comment 7. As I said in comment 8, setting mailnews.pop3.jsmodule to false should be the same as using tb91. So I don't know how it happened. Can you try 91 as a test? Maybe download a portable version or something.

I used now Thunderbird legacy 91 portable, which is 91.13.0 and that works with my saved profile like a charm. I could get the e-mails from Aol and authentication worked. So something is borked with the OAuth process maybe in 102.

Interesting, can you get some logs of 91 by following https://wiki.mozilla.org/MailNews:Logging#Generating_a_Protocol_Log
Maybe 102 as well. When mailnews.pop3.jsmodule is false, logs are in MOZ_LOG_FILE. When mailnews.pop3.jsmodule is true, logs are in the Console

Well most interesting is, that 102 only produces the error message like i posted before in the console, the log files are empty! The old version 91 does a correct oauth request:

--
POST
https://api.login.aol.com/oauth2/get_token
Status200
OK
VersionHTTP/2
Transferred1,49 KB (1,11 KB size)
Referrer Policystrict-origin-when-cross-origin

(In reply to Magnus Melin [:mkmelin] from comment #17)

Perhaps yahoo didn't like https://hg.mozilla.org/comm-central/rev/90ecd49f236c (bug 1752397)

I see, must be that. Instead of bringing back the empty AUTH command, what do you think if I ignore CAPA response and init oauth as long as user configured to use oauth?

Maybe? Not 100% clear what the issue is. Is the server not supporting CAPA?
It's also confusing that yahoo/aol in general work just fine with OAuth2. But for hosted services they do something different?

Assignee: nobody → remotenonsense
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

ok here a bit more from the failing 102:

mailnews.pop3.14: Connecting to pop://pop.aol.com:995 Pop3Client.jsm:132:18
mailnews.pop3.14: Connected Pop3Client.jsm:268:18
mailnews.pop3.14: S: +OK Hello from jpop-0.1

Pop3Client.jsm:309:18
mailnews.pop3.14: C: CAPA Pop3Client.jsm:451:20
mailnews.pop3.14: S: +OK CAPA list follows

IMPLEMENTATION jpop-0.1

TOP

USER

SASL LOGIN PLAIN

.

Pop3Client.jsm:309:18
mailnews.pop3.14: Possible auth methods: Pop3Client.jsm:521:18
mailnews.pop3.14: Got an error name=pop3AuthMechNotSupported Pop3Client.jsm:1279:18
mailnews.pop3.14: Done with status=2147500037 Pop3Client.jsm:1310:18
mailnews.pop3.14: C: QUIT Pop3Client.jsm:451:20
mailnews.pop3.14: Connection closed. Pop3Client.jsm:343:18
mailnews.pop3.14: S: +OK Server signing off.

(In reply to Magnus Melin [:mkmelin] from comment #20)

Maybe? Not 100% clear what the issue is. Is the server not supporting CAPA?
It's also confusing that yahoo/aol in general work just fine with OAuth2. But for hosted services they do something different?

The problem is OAUTH not returned in CAPA, but since it works in 91, OAUTH must have been returned in the initial empty AUTH command.

drde, would be great if you can get the logs on 91 to confirm this, should use MOZ_LOG=POP3:5

Regressed by: 1752397
Target Milestone: --- → 106 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/743a60f67e40
Try OAuth2 if configured but not advertised in CAPA in Pop3Client. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Attached file tb91-pop3.log

Here is the log for the pop3 on TB91

[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] Connecting to server pop.aol.com:995
[Parent 6952: Main Thread]: D/POP3 [this=2cc651b800] Setting server busy in nsPop3Protocol::LoadUrl()
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] Entering NET_ProcessPop3 25
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] Entering state: 1
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] Entering state: 2
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] Entering state: 4
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] RECV: +OK Hello from jpop-0.1
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] Entering state: 28
[Parent 6952: Main Thread]: D/POP3 [this=2cc651b800] SendCapa()
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] SEND: CAPA

[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] Entering NET_ProcessPop3 80
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] Entering state: 3
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] RECV: +OK CAPA list follows
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] Entering state: 29
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] RECV: IMPLEMENTATION jpop-0.1
[Parent 6952: Main Thread]: D/POP3 [this=2cc651b800] Capability entry processed
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] Entering state: 29
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] RECV: TOP
[Parent 6952: Main Thread]: D/POP3 [this=2cc651b800] Capability entry processed
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] Entering state: 29
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] RECV: USER
[Parent 6952: Main Thread]: D/POP3 [this=2cc651b800] Capability entry processed
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] Entering state: 29
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] RECV: SASL LOGIN PLAIN
[Parent 6952: Main Thread]: D/POP3 [this=2cc651b800] Capability entry processed
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] Entering state: 29
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] RECV: .
[Parent 6952: Main Thread]: D/POP3 [this=2cc651b800] Capability entry processed
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] Entering state: 30
[Parent 6952: Main Thread]: D/POP3 [this=2cc651b800] ProcessAuth()
[Parent 6952: Main Thread]: D/POP3 [this=2cc651b800] POP auth: server caps 0x201CB2, pref 0x200000, failed 0x0, avail caps 0x200000
[Parent 6952: Main Thread]: D/POP3 [this=2cc651b800] (GSSAPI = 0x100000, CRAM = 0x2000, APOP = 0x4000, NTLM = 0x8000, MSN = 0x10000, PLAIN = 0x1000, LOGIN = 0x800, USER/PASS = 0x400, XOAUTH2 = 0x200000)
[Parent 6952: Main Thread]: D/POP3 [this=2cc651b800] (Enabled - GSSAPI=0, CRAM=0, APOP=0, NTLM=0, MSN=0, PLAIN=0, LOGIN=0, USER/PASS=0, XOAUTH2=1)
[Parent 6952: Main Thread]: D/POP3 [this=2cc651b800] Trying auth method 0x200000
[Parent 6952: Main Thread]: D/POP3 [this=2cc651b800] POP XOAUTH2
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] Entering state: 51
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] SEND: AUTH XOAUTH2

[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] Entering NET_ProcessPop3 0
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] Entering state: 3
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] Entering NET_ProcessPop3 4
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] Entering state: 3
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] RECV: +
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] Entering state: 52
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] Logging suppressed for this command (it probably contained authentication information)
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] Entering NET_ProcessPop3 42
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] Entering state: 3
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] RECV: +OK Maildrop ready, (JPOP server ready).
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] Entering state: 31
[Parent 6952: Main Thread]: D/POP3 [this=2cc651b800] NextAuthStep()
[Parent 6952: Main Thread]: D/POP3 [this=2cc651b800] Login succeeded
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] Entering state: 7
[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] SEND: STAT

[Parent 6952: Main Thread]: I/POP3 [this=2cc651b800] Entering NET_ProcessPop3 15

Sorry for double posting last entry, got a bugzilla error. Here is the pop3 log for 102, seems 102 can't handle the auth string.

2022-09-02 13:25:22.664000 UTC - [Parent 4760: Main Thread]: I/POP3 [this=3f4a95d100] Connecting to server pop.aol.com:995
2022-09-02 13:25:22.664000 UTC - [Parent 4760: Main Thread]: D/POP3 [this=3f4a95d100] Setting server busy in nsPop3Protocol::LoadUrl()
2022-09-02 13:25:22.796000 UTC - [Parent 4760: Main Thread]: I/POP3 [this=3f4a95d100] Entering NET_ProcessPop3 25
2022-09-02 13:25:22.796000 UTC - [Parent 4760: Main Thread]: I/POP3 [this=3f4a95d100] Entering state: 1
2022-09-02 13:25:22.796000 UTC - [Parent 4760: Main Thread]: I/POP3 [this=3f4a95d100] Entering state: 2
2022-09-02 13:25:22.796000 UTC - [Parent 4760: Main Thread]: I/POP3 [this=3f4a95d100] Entering state: 4
2022-09-02 13:25:22.796000 UTC - [Parent 4760: Main Thread]: I/POP3 [this=3f4a95d100] RECV: +OK Hello from jpop-0.1
2022-09-02 13:25:22.796000 UTC - [Parent 4760: Main Thread]: I/POP3 [this=3f4a95d100] Entering state: 28
2022-09-02 13:25:22.796000 UTC - [Parent 4760: Main Thread]: D/POP3 [this=3f4a95d100] SendCapa()
2022-09-02 13:25:22.796000 UTC - [Parent 4760: Main Thread]: I/POP3 [this=3f4a95d100] SEND: CAPA

2022-09-02 13:25:22.840000 UTC - [Parent 4760: Main Thread]: I/POP3 [this=3f4a95d100] Entering NET_ProcessPop3 80
2022-09-02 13:25:22.840000 UTC - [Parent 4760: Main Thread]: I/POP3 [this=3f4a95d100] Entering state: 3
2022-09-02 13:25:22.840000 UTC - [Parent 4760: Main Thread]: I/POP3 [this=3f4a95d100] RECV: +OK CAPA list follows
2022-09-02 13:25:22.840000 UTC - [Parent 4760: Main Thread]: I/POP3 [this=3f4a95d100] Entering state: 29
2022-09-02 13:25:22.840000 UTC - [Parent 4760: Main Thread]: I/POP3 [this=3f4a95d100] RECV: IMPLEMENTATION jpop-0.1
2022-09-02 13:25:22.840000 UTC - [Parent 4760: Main Thread]: D/POP3 [this=3f4a95d100] Capability entry processed
2022-09-02 13:25:22.840000 UTC - [Parent 4760: Main Thread]: I/POP3 [this=3f4a95d100] Entering state: 29
2022-09-02 13:25:22.840000 UTC - [Parent 4760: Main Thread]: I/POP3 [this=3f4a95d100] RECV: TOP
2022-09-02 13:25:22.840000 UTC - [Parent 4760: Main Thread]: D/POP3 [this=3f4a95d100] Capability entry processed
2022-09-02 13:25:22.840000 UTC - [Parent 4760: Main Thread]: I/POP3 [this=3f4a95d100] Entering state: 29
2022-09-02 13:25:22.840000 UTC - [Parent 4760: Main Thread]: I/POP3 [this=3f4a95d100] RECV: USER
2022-09-02 13:25:22.840000 UTC - [Parent 4760: Main Thread]: D/POP3 [this=3f4a95d100] Capability entry processed
2022-09-02 13:25:22.840000 UTC - [Parent 4760: Main Thread]: I/POP3 [this=3f4a95d100] Entering state: 29
2022-09-02 13:25:22.840000 UTC - [Parent 4760: Main Thread]: I/POP3 [this=3f4a95d100] RECV: SASL LOGIN PLAIN
2022-09-02 13:25:22.840000 UTC - [Parent 4760: Main Thread]: D/POP3 [this=3f4a95d100] Capability entry processed
2022-09-02 13:25:22.840000 UTC - [Parent 4760: Main Thread]: I/POP3 [this=3f4a95d100] Entering state: 29
2022-09-02 13:25:22.840000 UTC - [Parent 4760: Main Thread]: I/POP3 [this=3f4a95d100] RECV: .
2022-09-02 13:25:22.840000 UTC - [Parent 4760: Main Thread]: D/POP3 [this=3f4a95d100] Capability entry processed
2022-09-02 13:25:22.840000 UTC - [Parent 4760: Main Thread]: I/POP3 [this=3f4a95d100] Entering state: 30
2022-09-02 13:25:22.840000 UTC - [Parent 4760: Main Thread]: D/POP3 [this=3f4a95d100] ProcessAuth()
2022-09-02 13:25:22.840000 UTC - [Parent 4760: Main Thread]: D/POP3 [this=3f4a95d100] POP auth: server caps 0x1EAA, pref 0x200000, failed 0x0, avail caps 0x0
2022-09-02 13:25:22.840000 UTC - [Parent 4760: Main Thread]: D/POP3 [this=3f4a95d100] (GSSAPI = 0x100000, CRAM = 0x2000, APOP = 0x4000, NTLM = 0x8000, MSN = 0x10000, PLAIN = 0x1000, LOGIN = 0x800, USER/PASS = 0x400, XOAUTH2 = 0x200000)
2022-09-02 13:25:22.840000 UTC - [Parent 4760: Main Thread]: D/POP3 [this=3f4a95d100] (Enabled - GSSAPI=0, CRAM=0, APOP=0, NTLM=0, MSN=0, PLAIN=0, LOGIN=0, USER/PASS=0, XOAUTH2=0)
2022-09-02 13:25:22.840000 UTC - [Parent 4760: Main Thread]: D/POP3 [this=3f4a95d100] No auth method remaining
2022-09-02 13:25:22.840000 UTC - [Parent 4760: Main Thread]: D/POP3 [this=3f4a95d100] ProcessAuth() early exit because no auth methods
2022-09-02 13:25:22.840000 UTC - [Parent 4760: Main Thread]: I/POP3 [this=3f4a95d100] ERROR: pop3AuthMechNotSupported

Thanks, the 91 logs are a bit different from what I imagined. I checked the code, it's because the server capabilities are cached. Never mind, please wait a few days for the patch to land on esr102. Or download a nightly build to see if my patch really fixed the problem http://ftp.mozilla.org/pub/thunderbird/nightly/2022/09/

Comment on attachment 9292760 [details]
Bug 1782250 - Try OAUTH if configured but not advertised in CAPA in Pop3Client. r=mkmelin

[Approval Request Comment]
Regression caused by (bug #): bug 1752397
User impact if declined: Can't use OAuth for some pop3 servers.
Testing completed (on c-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): no risk

Attachment #9292760 - Flags: approval-comm-beta?

I tried now thunderbird-106.0a1 daily and seems the problem is fixed, I could connect to AOL and receive mails. This fix should go asap in normal branch please^^

(In reply to Wayne Mery (:wsmwk) from comment #31)

Is this also likely to fix issues which apparently have only just appeared in the last week?

Yes, should fix those.

(In reply to drde from comment #32)

I tried now thunderbird-106.0a1 daily and seems the problem is fixed, I could connect to AOL and receive mails. This fix should go asap in normal branch please^^

Thanks for confirming.

(In reply to Wayne Mery (:wsmwk) from comment #31)

Is this also likely to fix issues which apparently have only just appeared in the last week?

FYI, reporter's info suggests this started in 102.2.0, so caused by one of these https://mzl.la/3epwbch and not a direct regression of Bug 1752397 - GMX say Thunderbird is using the POP protocol incorrectly

Whatever the fix might be, we'll want to quickly move this to 102

Comment on attachment 9292760 [details]
Bug 1782250 - Try OAUTH if configured but not advertised in CAPA in Pop3Client. r=mkmelin

[Triage Comment]
Approved for beta

Also approved for esr102 (agree with assessment "no risk")

Attachment #9292760 - Flags: approval-comm-esr102+
Attachment #9292760 - Flags: approval-comm-beta?
Attachment #9292760 - Flags: approval-comm-beta+
OS: Unspecified → All
Priority: -- → P1
Summary: Cannot connect to pop.aol.com via OAuth2 using verizon account → Cannot connect to pop.aol.com via OAuth2 using verizon account - "server does not support the selected authentication method"

This won't uplift to comm-esr102 without (a slightly modified) bug 1787766.

I also can confirm that the release 102.2.2 fixed this problem for my aol accounts. But seems I found another issue with the oauth process. I changed one password on the AOL webpage and therefore Thunderbird opened a web tab where I entered the new password to get the oauth token. After this the fetch mail hang up and lasted forever. I had to restart Thunderbird but then it worked.

OAuth2 on AOL POP authentication now works again for me (with a verizon.net email domain), as of TB 102.2.2.

Thanks to drde for reviving interest in this issue.

Thanks to Ping Chen (:rnons) and Magnus Melin [:mkmelin] for tracking this issue and identifying the fix.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.