Closed Bug 1782325 Opened 2 years ago Closed 1 year ago

[hazards] Improve error message when MOZCONFIG is set while running the hazard analysis

Categories

(Core :: JavaScript: GC, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
112 Branch
Tracking Status
firefox112 --- fixed

People

(Reporter: sfink, Assigned: sfink, NeedInfo)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Right now, if you run mach hazards gather with MOZCONFIG set to something that doesn't closely match js/src/devtools/rootAnalysis/mozconfig.{js,browser}, you'll get a wall of text that you have to sift through to find the real error message.

Type: defect → enhancement
Assignee: nobody → sphink
Status: NEW → ASSIGNED

Note that the purpose of allowing MOZCONFIG to be set at all is because you might want to analyze the code with a nonstandard configuration.

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:sfink, could you have a look please?
If you still have some work to do, you can add an action "Plan Changes" in Phabricator.
For more information, please visit auto_nag documentation.

Flags: needinfo?(sphink)
Flags: needinfo?(ahochheiden)

It's reviewed and ready to land. I'll leave it to :sfink to land.

Flags: needinfo?(ahochheiden)
Pushed by sfink@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d861fa7c9a4e
mach hazards gather: validate the mozconfig eagerly r=firefox-build-system-reviewers,ahochheiden
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 112 Branch
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: