Closed Bug 1782921 Opened 2 months ago Closed 2 months ago

position:fixed elements are not working correctly in an iframe

Categories

(Core :: Panning and Zooming, defect, P3)

Firefox 103
defect

Tracking

()

VERIFIED FIXED
105 Branch
Tracking Status
firefox-esr91 --- unaffected
firefox-esr102 --- unaffected
firefox103 --- wontfix
firefox104 --- wontfix
firefox105 --- verified
firefox106 --- verified

People

(Reporter: jonas, Assigned: dlrobertson)

References

(Regression)

Details

(Keywords: regression)

Attachments

(3 files)

Attached file iframe.html

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:103.0) Gecko/20100101 Firefox/103.0

Steps to reproduce:

Please take a look at my attached file iframe.html.
To reproduce the problem, please create an additional file and paste the comment content to open the iframe.html file in an iframe.
I think it is most reproducible on Windows 10. Also test the behavior with Firefox 102 to see the difference.

  1. Open your created file in Firefox.
  2. Click on the button. Your mouse icon changes when you hover over it, and the button is triggered.
  3. Scroll a little bit.
  4. Move your mouse over the button again.

Actual results:

The mouse icon does not change. The button is not triggered on (first) click.

Expected results:

The mouse icon should change and the button should be triggered.

If you do the same procedure on Firefox 102, you should see the problem.
I think the underlying problem is bigger, but this is the easiest way to show it.

The Bugbug bot thinks this bug should belong to the 'Core::Web Painting' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Web Painting
Product: Firefox → Core
Component: Web Painting → Panning and Zooming
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attached file bug1782921.html

Also test the behavior with Firefox 102 to see the difference.

Sorry, I'm not sure I follow this. Does this happen on 102? I was unable to reproduce the issue on Linux and macOS with the example I attached.

Flags: needinfo?(jonas)

Hello Dan,
thanks for the fast response.
I can reproduce the issue also with your file at

  • Windows 10
  • Linux Debian 11.4

The issue only happen on 103. The issue is hard to see so I suggested to directly compare it with a previous version.

I created two videos to show the issue:

The issue looks small, but it feels like some parts of the browser thinks the element is on another position.

Also many of our customers reported the issue at our company website.

Flags: needinfo?(jonas)

(In reply to Alice0775 White from comment #4)

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=598649d8d10a0508e363d6cadccd26ad4dd9bfa1&tochange=c6e364c416d75e4ad554a33c2fb2dcee388be54b

Suspect: Bug 1760368

Thanks! I also found the same result with mozregression.

(In reply to jonas from comment #3)

The issue only happen on 103. The issue is hard to see so I suggested to directly compare it with a previous version.

I created two videos to show the issue:

Thanks! This helped me reproduce the issue.

The issue looks small, but it feels like some parts of the browser thinks the element is on another position.

We recently landed some changes to the way we hit-test fixed elements in bug 1760368. I think this is actually a duplicate of bug 1772273 (See https://phabricator.services.mozilla.com/D148099).

Do not propogate the async transform components when calling
GetTransformToLastDispatchedPaint() on the parent.

Assignee: nobody → drobertson
Status: NEW → ASSIGNED
Severity: -- → S3
Priority: -- → P3
Pushed by drobertson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/aaa6074574fd
Do not propogate transform components to GetTransformToLastDispatchedPaint(). r=botond
Regressions: 1785026
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 105 Branch

Reproduced the issue in Nightly 103.0a1 (build id: 20220606093709).
Verified - Fixed in Beta 105.0b5 and latest Nightly 106.0a1 (2022-08-31) using Windows 10 and Ubuntu 20.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.