Full screen mode does not get the screen size everytime you enter that mode.

RESOLVED DUPLICATE of bug 62395

Status

()

RESOLVED DUPLICATE of bug 62395
17 years ago
14 years ago

People

(Reporter: andrew, Assigned: hewitt)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1) Gecko/20020826

It seems that the screen size it set to the screen size of when mozilla was
initially launched.  If the screen size changes and you enter full screen mode,
the window will not fill the whole screen.  

Reproducible: Always

Steps to Reproduce:
1. Set your screen resolution to 800X600
2. Open Mozilla
3. Enter full screen mode to make sure it fills the screen
4. Exit full screen mode
5. DO NOT CLOSE MOZILLA!  Change your screen resolution to anything larger, say
1024X768
5. Then enter Full screen mode again

Actual Results:  
The window will not fill the whole screen, it will only fill the amount of
screen that the previous screen size was.

Expected Results:  
Full screen mode should redetermine the screen size when you enter full screen
mode so it always fills the screen

I actually discovered this using a monitor that can pivot from landscape to
portrait, so it would fill the screen wrong if I changed orentiation of the
screen.    The work around is to close and repoen mozilla.

Comment 1

17 years ago
-> hewitt
Assignee: jaggernaut → hewitt

Comment 2

16 years ago
Similar to bug 167263?
(Reporter)

Comment 3

16 years ago
Yes simular, except bug 167263 is a much more dynamic case.  Mozilla would have
to update it's screen size everytime it gets a resolution size changed event (if
it even gets them).  In my bug here, mozilla could just repoll the screen size
everytime you hit F11

Comment 4

16 years ago
I attached a patch to bug 167263 that also fixes this problem.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

15 years ago
Duplicate of 167263. It's not about a more dynamic case. It's exactly the same:

mozilla does not take into account new resolution -->when going full screen<--



*** This bug has been marked as a duplicate of 167263 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 62395 ***
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.