bogus SMTP server entries in prefs.js cause hang

RESOLVED WORKSFORME

Status

MailNews Core
Networking: SMTP
--
critical
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Andrew E. Mileski, Assigned: Scott MacGregor)

Tracking

({hang})

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021016

Seen this several times.  Found an apparent solution this time though.

Clicking "Send" would cause Mozilla to lockup.  Opening the Advanced options
unde r SMTP would also, as a few other things.

Solution:  this shouldn't work in my non-mozilla programmer humble opinion, but
it does ... edited prefs.js

Changed
  user_pref("mail.smtpservers", "smtp1,smtp3");
To
  user_pref("mail.smtpservers", "smtp1,smtp2");
Changed:
  user_pref("mail.smtpserver.smtp3.*
To:
  user_pref("mail.smtpserver.smtp2.*






Reproducible: Didn't try

Steps to Reproduce:

Updated

15 years ago
Blocks: 193931
Severity: normal → critical
Keywords: hang

Comment 1

15 years ago
First, please upgrade to Mozilla 1.3 beta or later.

Second, if you delete all your SMTP servers, close Mozilla, then recreate the
SMTP servers, do you get the same problem?

Comment 2

15 years ago
Confirming on basis of duplicate... (next)
Blocks: 123929
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Lockup on clicking Send button → bogus SMTP server entries in prefs.js cause hang

Comment 3

15 years ago
*** Bug 180130 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 4

15 years ago
I've not had this recently.  It seems to have been related to the XUL file bugs.

I'm marking it as RESOLVED and WORKSFORME, though multiple SMTP servers still
appear when they shouldn't  ... but that should be another bug entry.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Updated

15 years ago
No longer blocks: 123929

Updated

15 years ago
No longer blocks: 193931
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.