Last Comment Bug 178668 - css parser generates wrong hint when resetting property to be !important
: css parser generates wrong hint when resetting property to be !important
Status: RESOLVED FIXED
: testcase
Product: Core
Classification: Components
Component: CSS Parsing and Computation (show other bugs)
: Trunk
: All All
: P4 normal (vote)
: Future
Assigned To: Boris Zbarsky [:bz] (still a bit busy)
: Hixie (not reading bugmail)
: Jet Villegas (:jet)
Mentors:
http://bugzilla.mozilla.org/attachmen...
Depends on: 125246 188803
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-06 08:45 PST by Boris Zbarsky [:bz] (still a bit busy)
Modified: 2003-06-28 20:28 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Boris Zbarsky [:bz] (still a bit busy) 2002-11-06 08:45:44 PST
This is a spinoff from bug 173767.  The hint when going from "color: red" to
"color: red !important" is NONE, so no update (eg repaint) is done...
Comment 1 Madhur Bhatia 2002-12-02 15:28:04 PST
testcase provided in the url field .....
http://bugzilla.mozilla.org/attachment.cgi?id=104372&action=view
Comment 2 Boris Zbarsky [:bz] (still a bit busy) 2003-04-02 21:13:11 PST
The current nsCSSDeclaration data storage makes this kinda hard to fix... :(
Comment 3 Boris Zbarsky [:bz] (still a bit busy) 2003-06-14 12:27:35 PDT
OK.  We now generate the right hint.... but we don't reresolve style on anything
because the assumption is that changes to a style rule's declaration don't
change what order rules apply in.

Bad assumption, when declarations get set to !important.... I suspect that the
easiest way to fix this bug is via bug 188803.
Comment 4 Boris Zbarsky [:bz] (still a bit busy) 2003-06-28 20:28:30 PDT
Fixed by changes for bug 188803

Note You need to log in before you can comment on or make changes to this bug.