Closed Bug 178756 Opened 17 years ago Closed 17 years ago

Use favicons as icon for OS/2 URL objects

Categories

(Firefox :: General, enhancement)

x86
Other
enhancement
Not set

Tracking

()

VERIFIED DUPLICATE of bug 110894

People

(Reporter: t4qohfl402, Assigned: mkaply)

References

()

Details

User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.2b) Gecko/20021030 Phoenix/0.4
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.2b) Gecko/20021030 Phoenix/0.4

By dragging to the desktop (or a folder) the "Q" icon besides the "Current URL"
combo box, I can create an OS/2 URL object (WPUrl?). I'd like it to use the
favicon of the page if available.
Enabling this for the current page would be enough. Doing it for links in the
current page dragged to the desktop would requit to fetch the linked page's
favicon, actually downloading the linked page.

Reproducible: Always

Steps to Reproduce:
1. Drag the Q-shaped icon in the URL combo box to a WPS folder, for example in
this very page
http://bugzilla.mozilla.org/enter_bug.cgi?product=Phoenix&format=guided


Actual Results:  
An URL object is formed in the folder with the standard WPUrl icon (an Earth
globe with a sheet of paper).

Expected Results:  
Create the WPUrl with the same icon as the favicon.

This is OS/2 Warp 4 Fixpack 15.
Mozilla's Bug 110894 favicons on webpage "shortcuts", seems to be similar, but I
don't know if shortcuts in Windows are to be treated as URL objects in OS/2.
-> mkaply
Assignee: blaker → mkaply
I am going to dupe this off.

If the infrastructure were in place from 110894, this would be easy.

*** This bug has been marked as a duplicate of 110894 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Mass verifiying old duplicates.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.