Closed Bug 1788033 Opened 3 months ago Closed 19 days ago

Modify the Media Queries sidebar so it includes layers and container queries too

Categories

(DevTools :: Style Editor, enhancement)

enhancement

Tracking

(firefox108 fixed)

RESOLVED FIXED
108 Branch
Tracking Status
firefox108 --- fixed

People

(Reporter: nchevobbe, Assigned: nchevobbe)

References

Details

Attachments

(3 files)

The sidebar provides an easy way to navigate to a specific media query rule, that we could define as "sections".
It would probably be as useful to other kind of "sections" you can have nowadays in CSS: @layer and @container

This would require to rename a few things in the styleeditor, and add more information on each item of the sidebar so we can see the different type of @ rules
We may even introduce a color-scheme with colors for different type of rules that we could also use in the inspector rule view

Since we plan to add other rules than @media into the sidebar, it makes sense
to rename it.

Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Duplicate of this bug: 1787175

We take this as an opportunity to update the existing
screenshots of the page as the previous one were quite
outdated.

Depends on D157084

Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a57c69dc1054
[devtools] Rename StyleEditor media sidebar to at-rules sidebar. r=jdescottes,fluent-reviewers,devtools-backward-compat-reviewers.
https://hg.mozilla.org/integration/autoland/rev/4604df70ebde
[devtools] Display container, layer and supports in StyleEditor at-rules sidebar. r=jdescottes.
https://hg.mozilla.org/integration/autoland/rev/8c903c2f3ea4
[devtools] Update StyleEditor documentation for at-rules sidebar. r=jdescottes.
Regressions: 1799984
Status: ASSIGNED → RESOLVED
Closed: 19 days ago
Resolution: --- → FIXED
Target Milestone: --- → 108 Branch
You need to log in before you can comment on or make changes to this bug.