Ahead/Nero web site does not properly record session history. Back and Forward buttons don't work.

VERIFIED FIXED

Status

()

VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: jasonb, Assigned: radha)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021106
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20021106

This Web site does not work properly with the Back button.  Previous locations
will be "lost" - not remembered properly.  Worse, it doesn't simply not get
entered but when clicking on them you get "taken back" to a pseudo version of
the page you're already on.

Reproducible: Always

Steps to Reproduce:
1. Go to the reference URL.
2. Click on the "Nero - version history page" link.
3. Observe that the Back button is no longer greyed out and there are two
entires in the Back history list.
4. Click the back button (or select one of the Back history items).

Actual Results:  
Either nothing happens, or some top parts of the screen "disappear".  (I don't
know how to better describe the effect.)  Clicking on Forward at this point will
also not restore the page from which you intially clicked Back.  You're pretty
much lost and have to reload the initial Web site again.

Expected Results:  
Back and Forward should do what they're supposed to do.
(Reporter)

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

16 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021102

This seems to happen also under linux

Comment 2

16 years ago
I am able to reproduce this on commercial trunk build crossplatform

changed hardware and os to reflect that.
OS: Windows XP → All
Hardware: PC → All

Comment 3

16 years ago
This is still occuring in the latest nightly builds 1/1/2003

Comment 4

16 years ago
I visited the web site today (1/12/03) using nightly build 2003010908

I was not able to open the page at all. http://www.nero.com turned up a blank page.

Seems to work ok in IE 5.5.

Thanks

Ajay Gautam

Comment 5

16 years ago
Well, the problem with the blank page should be already fixed in the latest
build! See bug #187790 for further details...

Comment 6

16 years ago
I have just tried again with the most recent nightly 2/23/03 and the session
history is STILL not working properly. Is this a bug that only effects the NERO
site or is it something that effects other similiar sites? If so, I hope this
gets cleaned up soon.

Comment 7

16 years ago
Tried to double the problem with both Mozilla/5.0 (Windows; U; WinNT4.0; en-US;
rv:1.3b) Gecko/20030223 Phoenix/0.5 and Mozilla/5.0 (Windows; U; WinNT4.0;
en-US; rv:1.3b) Gecko/20030223 and Mozilla / Phoenix crashed.

Next I used a fresh profile for both browsers and I was still able to reproduce
the crash.

Will do some further testing and if the crash persist I will change the severity
and add keyword "crash".

Comment 8

16 years ago
*** Bug 168708 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 9

16 years ago
Confirming that the Web site now causes a crash with the testcase I provided. 
I'm now using 2003022304 / XP.

Adding keyword and increasing severity of this bug.  (But note that if the crash
is fixed, the original problem will likely still remain.)
Severity: normal → critical
Keywords: crash

Comment 10

16 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/20030224
don´t see a crash, but Back & Forward buttons don´t work.

I got three identical entries there, all saying Ahead Nero or something like that,
but neither worked, I stayed on this page.

Comment 11

16 years ago
Ok - in the meanwhile Talkback managed it to send the data - here are the IDs in
case someone can have a look on it:

TB17444830Y
TB17444828H

Comment 12

16 years ago
Well - the crash seems to be gone now using Mozilla/5.0 (Windows; U; WinNT4.0;
en-US; rv:1.3b) Gecko/20030224.

Obviously this was a duplicate of bug #194584 - hence I will change the severity
back to normal and remove keyword "crash"... The problem with the not working
back / forward buttons still remains.
Severity: critical → normal
Keywords: crash
(Reporter)

Comment 13

16 years ago
Confirming.

Comment 14

16 years ago
shouldn´t "BACK FORWARD" added to the summary?
Looking for "back forward" in summary gave me 32 bugs, could it be this one is a
dupe ? ( I didn´t look at source code )
Bug 193887 Back/Forward buttons break when a variable is used in a javascript:
URI that changes the value of location.href
(Reporter)

Comment 15

16 years ago
Modifying summary.

If anything, bug 193887 would be a duplicate of this bug (since this one is over
4 months older) - but I doubt that they're the same.  I don't think it would
have taken so long for this issue to have been reported elsewhere.
Summary: Ahead/Nero web site does not properly record session history. → Ahead/Nero web site does not properly record session history. Back and Forward buttons don't work.
(Reporter)

Comment 16

16 years ago
Also, JS Console does not display any errors, let alone any of those reported in
bug 193887.
(Reporter)

Comment 17

16 years ago
Their site has been redesigned and the problem originally reported here (browser
history) is no longer a problem, so I'm resolving this bug as FIXED.

Note, however, that their site now has evangelism issues with their javascript
menus.  (JavaScript Console catches an ongoing flood of errors.)  Using Mozilla
to view their site is terrible.  (It works find under IE.)  But I don't feel
like morphing this bug into something different at this point.  somebody else
can file a bug on this new (mis)behaviour if they wish.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 18

15 years ago
.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.