Closed Bug 1788557 Opened 28 days ago Closed 12 days ago

YouTube videos sometimes fail to start playing in Europe

Categories

(Core :: Audio/Video: Playback, defect, P2)

defect

Tracking

()

RESOLVED FIXED
106 Branch
Tracking Status
firefox106 --- fixed

People

(Reporter: diannaS, Assigned: pehrsons)

Details

Attachments

(6 files)

I have seen reports on reddit about connection issue while playing Youtube videos as well as other unwanted behaviors with Outlook and Gmail after updating their firefox.

https://www.reddit.com/r/firefox/comments/x1um0o/browser_problems_after_1040_and_10401/?utm_source=share&utm_medium=ios_app&utm_name=iossmf

If you are experiencing this issues, please post any https logs that could help debug this issue

Hello!
I could reproduce the connectivity issue on youtube using this url on Windows 11 Version 21H2 (OS Build 22000.856), on Firefox 104.0.1. The video looks like it’s loading but it doesn’t start. I was logged on Youtube with a Google Account. I would also like to mention that this issue is intermittent. The same issue was encountered in 105.0b5 and 2022-09-01 Nightly but only with the adblockers enabled.
The following extensions were enabled while testing:

I have two screenshots of the browser console whilst reproducing;

I’m also attaching the about:support., and I will try to add the https logs ASAP.
Thank you.

Attached file about support.txt

A regression range would be very helpful. Also, can you reproduce without adblockers installed?

Ardelean, can you reproduce the issue on any other OSs?

Flags: needinfo?(oana.ardelean)

I somehow reproduced this locally on my macbook with Firefox 104.1.

The http log is attached.
Looks like there is no obvious network errors, but I noticed couple of http requests are cancelled:

2022-09-01 16:08:06.606 ⁃ nsHttpChannel ⁃ 142c24000 ⁃ cancelled ⁃ status=0 ⁃ http-status=200 ⁃ url=https://www.youtube.com/sw.js
2022-09-01 16:08:06.702430 UTC - [Parent 69180: Main Thread]: D/nsHttp nsHttpChannel::Cancel [this=142c24000 status=804b0002]

2022-09-01 16:08:06.606 ⁃ nsHttpChannel ⁃ 14722c000 ⁃ cancelled ⁃ status=804b0002,0 ⁃ http-status=n/a ⁃ url=https://www.youtube.com/s/desktop/8a493f20/jsbin/serviceworker-notifications.vflset/serviceworker-notifications.js
2022-09-01 16:08:06.702465 UTC - [Parent 69180: Main Thread]: D/nsHttp nsHttpChannel::Cancel [this=14722c000 status=804b0002]

2022-09-01 16:08:06.606 ⁃ nsHttpChannel ⁃ 147261000 ⁃ cancelled ⁃ status=804b0002,0 ⁃ http-status=n/a ⁃ url=https://www.youtube.com/s/desktop/d5cebff0/jsbin/serviceworker-notifications.vflset/serviceworker-notifications.js
2022-09-01 16:08:06.702481 UTC - [Parent 69180: Main Thread]: D/nsHttp nsHttpChannel::Cancel [this=147261000 status=804b0002]

There is another log that shows a bit more information about why a http request was cancelled.
Take the request https://www.youtube.com/sw.js as an example:

2022-09-01 16:22:08.070544 UTC - [Parent 69984: Main Thread]: E/nsHttp HttpBaseChannel::Init [this=149be3c00]
2022-09-01 16:22:08.070548 UTC - [Parent 69984: Main Thread]: E/nsHttp host=www.youtube.com port=-1
2022-09-01 16:22:08.070552 UTC - [Parent 69984: Main Thread]: E/nsHttp uri=https://www.youtube.com/sw.js

2022-09-01 16:22:08.314660 UTC - [Parent 69984: Main Thread]: D/nsHttp nsHttpChannel::Cancel [this=149be3c00 status=804b0002, reason=CompareNetwork::Abort]
2022-09-01 16:22:08.314680 UTC - [Parent 69984: Main Thread]: D/nsHttp nsHttpChannel::CancelInternal [this=149be3c00]

The log shows this channel was cancelled by this line.
I am not sure if this cancellation has anything to do with the problem in this bug, but maybe Andrew can confirm.
Thanks.

Flags: needinfo?(bugmail)

Kershaw, are you able to reproduce with a fresh profile? If not do you also get the cancellations there?

Flags: needinfo?(kershaw)

The log shows this channel was cancelled by this line.
I am not sure if this cancellation has anything to do with the problem in this bug, but maybe Andrew can confirm.
Thanks.

Never mind. The http log from the working Youtube page also shows same requests are cancelled.
Sorry for the noise.

Flags: needinfo?(bugmail)

(In reply to Jeff Muizelaar [:jrmuizel] from comment #7)

Kershaw, are you able to reproduce with a fresh profile? If not do you also get the cancellations there?

Yes, I was reproduced with a fresh profile with my own google account.
I'll try to reproduce again without an account.

Flags: needinfo?(kershaw)

Hello!
I re-tested all 3 builds( Dot Release 104.0.1, Beta 105.0b5 and Nightly 106.0a1);

  • I could reproduce yesterday on macOS 12 on Nightly; still can today but not so frequently as before.
  • I couldn't reproduce on Ubuntu at all so far;
  • I could also reproduce without ad-blockers yesterday, on both Nightly and Dot Release.

On Windows 11 and macOS, I can still reproduce on 104.0.1 more often than not. Will try again on Ubuntu.
Please note that the issue is observable only with the provided URL in Comment 1. All other videos seem to work.
I'm currently trying to narrow down a regression range.

Flags: needinfo?(oana.ardelean)

Reproducing consistently using these STR(without any ad-blocker).

  1. Launch Firefox.
  2. "Paste and Go" the URL into the Address Bar.
  3. Wait for the ads to finish. (If there are any.)
  4. Refresh after the video starts playing.

Tested on macOS 12, macOS 11, Ubuntu 22.04, Windows 11 and Windows 10.
We were able to reproduce this on today's Nightly and Beta 105.0b6 as well. Again, please note that this happens only with this URL. On Google Chrome and Safari, the video plays without any issue.
We tried to find a regression range, but mozregression goes as back as 2019 and it still reproduces using these STR, so either the steps aren't accurate enough for this particular issue or this isn't a regression as far as we know. We will continue investigating on Youtube as well as other websites(reddit post also mentioned Gmail and Outlook issues) and hopefully get more relevant info as soon as possible.

Ardelean -- Are you able to join slack or matrix so that Jeff and I can talk with you "in real time" as we debug this? It would help us greatly.

This is a profile of this happening on macOS, Firefox Nightly, with MOZ_LOG=MediaSource:5,nsHTMLMediaElement:5 as profiler markers, on a fresh profile: https://share.firefox.dev/3RsRpEf.

In contrast here's the same log of a video that "works": https://share.firefox.dev/3q3BO2n (same scenario, same profile, with preroll ads just before the profile, that has been trimmed).

(In reply to Jeff Muizelaar [:jrmuizel] from comment #12)

Ardelean, do any of these videos also fail?
https://www.youtube.com/watch?v=wbf7qYk2AJY

Works

https://www.youtube.com/watch?v=qOcktbXSfxU

Doesn't work

https://www.youtube.com/watch?v=Dpk8js66onA

Doesn't work

https://www.youtube.com/watch?v=_DagU91lKuQ

Works

https://www.youtube.com/watch?v=n1M5MyYB04U

Works

When it works, it always works, and when it doesn't work, it never works, when I refresh.

Component: Networking → Audio/Video: Playback

(In reply to Ardelean Oana from comment #11)

Reproducing consistently using these STR(without any ad-blocker).

  1. Launch Firefox.
  2. "Paste and Go" the URL into the Address Bar.
  3. Wait for the ads to finish. (If there are any.)
  4. Refresh after the video starts playing.

Tested on macOS 12, macOS 11, Ubuntu 22.04, Windows 11 and Windows 10.
We were able to reproduce this on today's Nightly and Beta 105.0b6 as well. Again, please note that this happens only with this URL. On Google Chrome and Safari, the video plays without any issue.
We tried to find a regression range, but mozregression goes as back as 2019 and it still reproduces using these STR, so either the steps aren't accurate enough for this particular issue or this isn't a regression as far as we know. We will continue investigating on Youtube as well as other websites(reddit post also mentioned Gmail and Outlook issues) and hopefully get more relevant info as soon as possible.

I just want to add some of my part, on Windows 7 SP1 2021 ESU x64, it won't play ONLY if the NEW CODEC is turned on, the AV1, if I use H264, it never fail to play, so it's find on my side if I force yt to use H264 avc. It's reproducable as Ardelean wrote before on Windows 7

Summary: Possible Connection problems after updating 104.0 and 104.0.1 → YouTube videos sometimes fail to start playing in Europe

This appears to have been fixed by YouTube. If anyone can still reproduce the issue using something like the steps in comment 11 please and some details in a comment.

Flags: needinfo?(oana.ardelean)

Hello
My parents have the same issue. It happens only with their Windows 10, I am not concerned (Ubuntu 20.04).
They have updated to the last Firefox version (104.0.1), but the youtube videos aren't still played.
Issue totally random: at some point the video is played, the next minute the same video (with the same equipment) is not played.
What they've tried :

  • private window (instead of normal)
  • Youtube cookies deleted
  • uBlock Origin activated or not

Here the about:networking logs, during the test of watching the videos on Youtube:
https://pastebin.com/u85T9RBs

We have identified a case where we try to parse a webm file that by spec should have been considered invalid. For invalid files we can fire an error event that a site can act on, which would be an improvement. Taking this bug to improve this.

Assignee: nobody → apehrson
Severity: -- → S4
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P2

(In reply to mozillien from comment #18)

Hello
My parents have the same issue. It happens only with their Windows 10, I am not concerned (Ubuntu 20.04).

mozillien, can you open new bug for that issue and we can investigate it there?

Hello Jeff,
Ok I will try to open a new bug. I'm here because french support forum told me to post, but I am not comfortable with this tool. Moreover, I speak for my parents, who use Windows (I don't), and are several hundred kilometers away, so it's difficult for me to put the information from their system on my computer.

(i don't know how to edit my previous message)
Here's the bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1789642
Hope it's well filled.

Pushed by pehrsons@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/5a2d07ad3a18
Remove SeekHead element from test.webm to make it a valid ebml document. r=alwu
https://hg.mozilla.org/integration/autoland/rev/f96bfbe8664a
Validity check element IDs and Sizes with EBMLMax{Id,Size}Length in WebMBufferedParser. r=alwu
https://hg.mozilla.org/integration/autoland/rev/5b0c144fe507
Return MediaResult from WebMBufferedParser::Append to expose more details on error. r=alwu
Status: ASSIGNED → RESOLVED
Closed: 12 days ago
Resolution: --- → FIXED
Target Milestone: --- → 106 Branch
You need to log in before you can comment on or make changes to this bug.