Closed Bug 1789412 Opened 3 months ago Closed 3 months ago

(Another) dynamic import() blocks

Categories

(Core :: JavaScript Engine, defect)

Firefox 105
defect

Tracking

()

VERIFIED FIXED
106 Branch
Tracking Status
firefox-esr91 --- unaffected
firefox-esr102 --- unaffected
firefox104 --- unaffected
firefox105 --- fixed
firefox106 --- fixed

People

(Reporter: mozbz, Assigned: jonco)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached file demo_site_2.zip

This is very similar to bug1787926, which has been fixed and uplifted to Beta, but I've found another pattern of imports that also fails even after that fix landed.

I've included a new demo site, mimicing the test for bug1787926.

Once again the demo site works in Firefox 104 and Chrome but fails in Beta 105 and Nightly 106. The mozregression range again points to bug1779421.

Steps to Reproduce:
Serve the included website and open /index.html.

Expected Results:
The site displays a status message, which should progress to a "Success!" message.

Actual Results:
The site gets stuck "Waiting...".

Flags: needinfo?(jcoppeard)

Setting Regressed by field after analyzing regression range found by mozregression in comment #0.

Keywords: regression
Regressed by: 1779421
Assignee: nobody → jcoppeard
Flags: needinfo?(jcoppeard)

Thanks for another great bug report!

This is indeed very similar to bug 1787926.

As per the current spec we don't resolve the top level capability of async
modules in ModuleEvaluate, even if evaluation has finished successfully. This
is due to the following spec change:

https://github.com/tc39/proposal-top-level-await/commit/c2375dbd6ecb0d5e9a415f6a812fc0974a2935b7#diff-181371b08d71216599b0acccbaabd03c306da6de142ea6275c2135810999805aL546-R547

I think this should revert to the original behaviour which resolves the
capability when the module has finished evaluating, even for async modules.

Pushed by jcoppeard@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7756e3ed482f
Resolve top-level capability of all Evaluated modules in ModuleEvaluate r=yulia
Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 106 Branch

Reporter confirming the Expected Results are now seen in Nightly 20220909212835 (rev/b84775bfccf2243f664b1c15ca987a05c54a95e2). Thank you!

  • Status message progresses to "Success!"
Status: RESOLVED → VERIFIED

The patch landed in nightly and beta is affected.
:jonco, is this bug important enough to require an uplift?

  • If yes, please nominate the patch for beta approval.
  • If no, please set status-firefox105 to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(jcoppeard)

Comment on attachment 9293516 [details]
Bug 1789412 - Resolve top-level capability of all Evaluated modules in ModuleEvaluate r?yulia

Beta/Release Uplift Approval Request

  • User impact if declined: Web compat issue involving modules not loading in some circumstances.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is a very simple change that is covered by tests and has been verified on nightly.
  • String changes made/needed: None
  • Is Android affected?: Yes
Flags: needinfo?(jcoppeard)
Attachment #9293516 - Flags: approval-mozilla-beta?

Comment on attachment 9293516 [details]
Bug 1789412 - Resolve top-level capability of all Evaluated modules in ModuleEvaluate r?yulia

Approved for 105.0rc1.

Attachment #9293516 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.