Closed Bug 1790110 Opened 20 days ago Closed 9 days ago

[foxfooding] Colorways promo takes up a lot of space on smaller screen widths

Categories

(Firefox :: Firefox View, defect, P3)

Firefox 106
Desktop
Unspecified
defect

Tracking

()

VERIFIED FIXED
107 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox106 --- verified
firefox107 --- verified

People

(Reporter: pdehaan, Assigned: kcochrane)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fidefe-2022-mr1-firefox-view] [foxfooding])

Attachments

(3 files)

Firefox Version: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/105.0.0.0 Safari/537.36
Window Size (inner width and height): 1920x919
GitHub Username: @lime124

Steps to Reproduce

i do split screen a lot on my mac, so windows appear side by side. and this is the layout when the width of the view tab is reduced. i'm not sure if this is the intended layout - with the colorways promo in between the two bits of content. i would think it would appear at the top on narrower viewports.

secondly - if the colorway promo is meant to be between pickup and closed sections, the spacing between the promo and the closed section feels really wide.

Expected Behavior

Less of a gap between sections on smaller page widths.

Actual Behavior

Large vertical gap between Independent Voices and Recently closed sections on smaller page widths

Attachment


Link to the original attachment

Blocks: firefox-view
Whiteboard: [foxfooding] → [fidefe-2022-mr1-firefox-view] [foxfooding]
Severity: -- → S4
Priority: -- → P3
Assignee: nobody → kcochrane
Status: NEW → ASSIGNED
Attached image FigmaSpec

According to the Figma spec, it looks like the Colorways section should be displayed between Tab pickup and Recently closed on smaller screens.

Pushed by kcochrane@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1844b1b74815
Removing margin bottom for Colorways figure on smaller screens r=dao
Status: ASSIGNED → RESOLVED
Closed: 9 days ago
Resolution: --- → FIXED
Target Milestone: --- → 107 Branch

Comment on attachment 9295272 [details]
Bug 1790110 - Removing margin bottom for Colorways figure on smaller screens r?dao

Beta/Release Uplift Approval Request

  • User impact if declined: There will be excess vertical spacing between 'Colorways' and 'Recently close tabs' sections on smaller screens
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Not risky as it's just a small css change
  • String changes made/needed:
  • Is Android affected?: No
Attachment #9295272 - Flags: approval-mozilla-beta?

Comment on attachment 9295272 [details]
Bug 1790110 - Removing margin bottom for Colorways figure on smaller screens r?dao

Approved for 106 beta 2, thanks.

Attachment #9295272 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]
Flags: qe-verify+

Verified as fixed with Nightly 107.0a1 and Firefox 106.0b2 on smaller screens Ubuntu 18.4, macOS 10.12 and Windows 10x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.