background-color is ignored for COL elements

VERIFIED DUPLICATE of bug 4510

Status

()

Core
CSS Parsing and Computation
VERIFIED DUPLICATE of bug 4510
16 years ago
16 years ago

People

(Reporter: Alexander Demenchuk, Assigned: dbaron)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Example:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
"http://www.w3.org/TR/html4/strict.dtd">
<HTML>
<HEAD>
	<TITLE>COL background-color example</TITLE>
	<STYLE type="text/css">
		TABLE.tst { border: 2px solid #006699; }
		COL.bgc   { background-color: #DDDDDD; padding-right: 0.5em; }
		COL.clr   { padding-left: 0.5em; }
	</STYLE>
</HEAD>

<BODY>
<TABLE class="tst" cellspacing="0">
<COL class="bgc"/>
<COL class="clr"/>
<TR>
	<TD>abcdefg</TD>
	<TD>klmnop</TD>
</TR>
<TR>
	<TD>qrstuv</TD>
	<TD>wxyz</TD>
</TR>
</TABLE>
</BODY>
</HTML>

In IE the left column is gray, in Mozilla it is transparent.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 4510 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.