Last Comment Bug 179308 - Cannot trigger form controls or links using page accesskey
: Cannot trigger form controls or links using page accesskey
Status: RESOLVED FIXED
: access, html4
Product: Camino Graveyard
Classification: Graveyard
Component: Accessibility (show other bugs)
: unspecified
: PowerPC Mac OS X
: P2 normal with 5 votes (vote)
: Camino0.9
Assigned To: Simon Fraser
: sairuh (rarely reading bugmail)
Mentors:
http://bugzilla.mozilla.org/query.cgi
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-09 17:32 PST by Avi Drissman
Modified: 2005-07-11 06:41 PDT (History)
6 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Fix cocoa event dispatching to correctly handle control-modified key events (335 bytes, text/html)
2005-06-24 23:05 PDT, Simon Fraser
no flags Details
The patch this time. (19.42 KB, patch)
2005-06-25 10:16 PDT, Simon Fraser
jaas: review-
Details | Diff | Splinter Review
updated to trunk, warnings not fixed yet (14.02 KB, patch)
2005-06-27 13:43 PDT, Josh Aas
no flags Details | Diff | Splinter Review
Updated patch to trunk (14.22 KB, patch)
2005-06-27 14:55 PDT, Simon Fraser
jaas: review+
Details | Diff | Splinter Review

Description Avi Drissman 2002-11-09 17:32:44 PST
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021029 Chimera/0.5+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021029 Chimera/0.5+

Form controls marked with accesskey parameters don't respond to the access keys.

Reproducible: Always

Steps to Reproduce:
1. Go to the Bugzilla query page.
2. Try to use an accesskey.


Actual Results:  
Try command. Control. Option. Shift-all of the above. None trigger it.
Comment 1 Greg K. 2002-11-10 11:12:25 PST
Yeah, I don't think accesskeys were ever fixed on Mac. There's probably a bug
about it somewhere...
Comment 2 Avi Drissman 2002-11-10 11:22:16 PST
You mean bug 122479. Hmm. Dup? Should this be covered by that bug?
Comment 3 sairuh (rarely reading bugmail) 2003-01-02 12:43:37 PST
confirming. not sure if this is a dup of bug 122479...
Comment 4 sairuh (rarely reading bugmail) 2003-01-02 14:03:27 PST
this appears to be a problem within chimera, as it's not a problem in mozilla
--trunk or 1.0.2 branch.

here's another test case, where Ctrl-1 (and ctrl-2, Ctrl-3, etc) will focus the
textfields in the form (in mozilla, but not chimera):

http://www.cs.hmc.edu/~jruderma/s/

i think bug 122479 is a similar but different bug, which prolly affects both
chimera and mozilla on mac.
Comment 5 Marcello Testi 2003-05-02 07:09:19 PDT
The problem affects also links: try
http://www.francocarcillo.it/dive/accessibility_statement.html
The acceskeys don't work.
I'm using Build ID: 2003042705

The same keys work fine on Mozilla 1.3 (Gecko/20030312)

ACCESSIBILITY IS A MUST!
Comment 6 Ludovic Hirlimann [:Usul] 2003-08-27 12:03:39 PDT
Confirming with 2003082402
Comment 7 Sean Kelly 2004-07-30 11:34:14 PDT
Camino is a fine, /fine/, browser ... but this accesskey problem is the only
reason I'll venture back to Safari now and then.  (There's one website I
frequent for which the accesskeys are muscle memory now.)
Comment 8 Josh Aas 2004-10-05 00:10:26 PDT
Could either Jasper, Mike, or Stuart please explain what is going on with this
bug? Why is there a nib that removes a delete icon that was never added? Do we
just need to land a little cleanup patch?

It seems to me we should have a delete button and the edit menu should work.
Either way this bug should be easy to knock off the 0.9 list.
Comment 9 Josh Aas 2004-10-05 11:13:49 PDT
That last comment of mine is posted in the wrong bug... ignore it.
Comment 10 mozilla 2005-04-02 01:24:28 PST
Neat idea for Accesskey application. Forgive me if the wrong place.
http://www.mozdev.org/pipermail/camino/2004-March/001696.html
Comment 11 Samuel Sidler (old account; do not CC) 2005-05-28 00:19:04 PDT
Ping.

This hasn't yet been marked as a 09 blocker, but I think it *needs* to be ready
by then. Has anyone taken a look at it recently?
Comment 12 Samuel Sidler (old account; do not CC) 2005-06-24 20:41:45 PDT
I'm pinging this again. No one's touched it and it's an 09 blocker. Can someone
look more into this? How hard is this to implement? If it's not something that
should be in 09 (or can be in 09 due to time constraint), let's move it to 1.0.
Comment 13 Simon Fraser 2005-06-24 23:05:08 PDT
Created attachment 187266 [details]
Fix cocoa event dispatching to correctly handle control-modified key events

This patch fixes access keys by making sure that we dispatch the correct
KEY_PRESS events when the control key is down.

The patch also contains some renaming of the various -convert: methods to
reduce reader confusion, and guts nsChildView::ModalEventFilter(), since that
is all bogus code.
Comment 14 Jasper 2005-06-25 06:56:25 PDT
Oy Simon, it appears you only attached a testcase and no actual patch.
Comment 15 Simon Fraser 2005-06-25 10:16:51 PDT
Created attachment 187291 [details] [diff] [review]
The patch this time.
Comment 16 Josh Aas 2005-06-27 13:41:48 PDT
Aside from the fact that the patch doesn't apply, the following concerns me:

/Users/josh/src/camino_opt/mozilla/widget/src/cocoa/nsChildView.mm: In function 
   `void -[ChildView mouseUp:](ChildView*, objc_selector*, NSEvent*)':
/Users/josh/src/camino_opt/mozilla/widget/src/cocoa/nsChildView.mm:2569: warning: `
   ChildView' may not respond to `-convert:message:toGeckoEvent:'
/Users/josh/src/camino_opt/mozilla/widget/src/cocoa/nsChildView.mm:2569:
warning: cannot
   find method `-convert:message:toGeckoEvent:'; return type `id' assumed
Comment 17 Josh Aas 2005-06-27 13:43:21 PDT
Created attachment 187429 [details] [diff] [review]
updated to trunk, warnings not fixed yet
Comment 18 Simon Fraser 2005-06-27 14:55:33 PDT
Created attachment 187440 [details] [diff] [review]
Updated patch to trunk
Comment 19 Simon Fraser 2005-06-27 16:39:03 PDT
Checked in. Thanks!
Comment 20 Smokey Ardisson (offline for a while; not following bugs - do not email) 2005-07-11 06:41:36 PDT
Er, this was landed, so removing the obsolete ? flag.  Sorry for the noise.

Note You need to log in before you can comment on or make changes to this bug.