Closed Bug 179482 Opened 22 years ago Closed 22 years ago

Try sample URL. Note in URL bar, Apple logo, but in bookmark form, generic logo...

Categories

(Camino Graveyard :: Bookmarks, enhancement)

PowerPC
macOS
enhancement
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 165774

People

(Reporter: Xapplimatic, Assigned: sfraser_bugs)

References

()

Details

(Keywords: platform-parity, polish)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021104 Chimera/0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021104 Chimera/0.6

Chimera can already display these icon files.. so why only in the current URL /
location window?  It should also cache them and display them saved with their
bookmarks.. it's much easier to find what you're looking for with distinctive
logos instead of all generic icons and text.  Fixing this would put Chimera on
par with even current Windows versions of IE (besting the Mac versions which
ignore custom site icons completely!)

Reproducible: Always

Steps to Reproduce:
1.  Open site with custom site logo. (not all sites have one!)
2.  Bookmark site.. drag by logo into toolbar bookmarks.

Actual Results:  
Logo disappears, is replaced by generic icon.

Expected Results:  
The browser should have retained the logo.
Looks like all the hardest coding is out of the way for this.. image translation
was already handled by bug #46177.
Depends on: 46177
Keywords: polish, pp, ui
Reporter, I think what you're requesting is already there. Check out the 0.5
release notes at http://www.mozilla.org/projects/chimera/releasenotes.html :

*  Added site icons (favicons) for the url bar, and tabs. You can also make them
visible for bookmarks by setting the pref browser.chrome.favicons to true in
prefs.js, but this can cause some page-loading delays at startup.

So quit Chimera, open your prefs.js, and add the line
"user_pref("browser.chrome.favicons", true);". Save and restart Chimera.

This doesn't, however, cache them. Are you explicitly looking for caching?
Covered by bug 165774.

*** This bug has been marked as a duplicate of 165774 ***
Status: UNCONFIRMED → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
v dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.