[DOGFOOD] reply to message in Local Mail, and you get no body

VERIFIED FIXED in M11

Status

MailNews Core
Backend
P3
normal
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

Attachments

(1 attachment)

reply to message under a pop server and it works.

reply to a message under local mail, and it fails.

I'll look into it tomorrow.
Target Milestone: M11
could be a problem caused by the fact the uri would be

mailbox://nobody@Local Mail/Trash#4
Status: NEW → ASSIGNED
yes, it looks like it's caused by the space.

when I change (in my prefs and on disk) "Local Mail" to "LocalMail" reply works.

debugging to find out where the space kills us now...

accepting.

Updated

19 years ago
Hardware: PC → All

Comment 3

19 years ago
alec has a bug or two about the space problem in Local Mail.  I don't think
those bugs mention this reply/quote case though.
Target Milestone: M11 → M12
since imap, nntp, and pop3 work, but the none (aka Local Mail) case fails, and
this is less common, moving this to m12, and not m11.

not a stopper for m11.

Comment 5

19 years ago
I agree for the target milestone of M12.  If someone was using 4.x POP and
migrated, would their POP folders be migrated into local mail?
no, if they used pop in 4.x, they would not have this problem.

local folders (when using pop) go into something like

<profile>/Mail/<servername>/Trash
ok, here's the problem.

in nsMsgComposeService.cpp, line 240, we are passing null for object to

msgCompose->Initialize(aWindow, originalMsgURI, type, format, compFields,
object, identity);

the reason it's null is because at in nsMsgComposeService.cpp, line 228
we compare  hack_uri[i] to originalMsgURI.

hack_uri[i] is mailbox_message://nobody@Local%20Mail/Trash#4
and originalMsgURI is mailbox_message://nobody@Local Mail/Trash#4

so the compare fails.  one possible solution is to URL escape before comparing.

comments?

    	/*--- temporary hack ---*/
    	    int i;
    		nsISupports * object = nsnull;
    	    if (originalMsgURI)
    		    for (i = 0; i < 16; i ++)
    		    	if (hack_uri[i] == originalMsgURI)
    		    	{
    		    		hack_uri[i] = "";
    					object = hack_object[i];
    					hack_object[i] = nsnull;
    					break;
    				}
    	/*--- temporary hack ---*/

Comment 8

19 years ago
Hi JF,
Does this one ring a bell?

- rhp
(Assignee)

Comment 9

19 years ago
All this hack stuff should go away. We normally don't need it anymore as we can
retreive message data from the URI now. I will take a look at remove it and
converting necessary code. Reassign it to me please
(Assignee)

Updated

19 years ago
Assignee: sspitzer → ducarroz
Status: ASSIGNED → NEW
(Assignee)

Comment 10

19 years ago
OK, I have removed the hack in my build and reply still working fine. I haven't
tested yet for local mail but I am pretty sure it will works.
send me your patch so I can test it.
(Assignee)

Comment 12

19 years ago
Created attachment 2629 [details] [diff] [review]
Fix Patch
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 13

19 years ago
Seth, the patch is here (id=2629). Could you review it? thanks
jfd, I'm having troubles getting and applying your patch.

can you send it to me via email?

Comment 15

19 years ago
seth -
setenv POSIXLY_CORRECT 1

before applying the patch, I often have that problem.
(Assignee)

Comment 16

19 years ago
patch sent by email
jfd, your changes look good, and they fix this bug.

check it in!
(Assignee)

Updated

19 years ago
Blocks: 8510
(Assignee)

Comment 18

19 years ago
That solve also bug 8510. I like solving bugs by removing codes...
(Assignee)

Updated

19 years ago
Whiteboard: Will check in a fix when the tree open for M12

Updated

19 years ago
Whiteboard: Will check in a fix when the tree open for M12 → [PDT+]Will check in a fix when the tree open for M12

Comment 19

19 years ago
Putting on PDT+ radar.
seeking approval to check this in now...
Target Milestone: M12 → M11
marking m11...awaiting for approval now...
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
Whiteboard: [PDT+]Will check in a fix when the tree open for M12 → [PDT+]
I just checked in ducarroz's fix.  marking fixed.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 23

19 years ago
Using build 1999111017 on win and linux and 1999111011 on mac when I click Reply
to a message in a Local Mail folder, the compose window comes up but the reply
to address is not filled in nor is the title of the message visible on the
subject line after  Re:   Since this bug was for the body missing this is fixed
- I will verify it and a new bug will be logged (18620).  Note: If I fill in an
address (one that is not what should have been automatically entered) and send
it goes to the address I entered only (meaning the address is missing not just
invisible).
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.