Closed Bug 1796278 Opened 4 months ago Closed 3 months ago

AAAA records are confused for a domain within a container

Categories

(Core :: Networking: DNS, defect)

Firefox 102
x86_64
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1420777

People

(Reporter: g00g1, Unassigned, NeedInfo)

Details

Attachments

(1 file)

Attached video bug_demonstration.mp4

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:102.0) Gecko/20100101 Firefox/102.0

Steps to reproduce:

  1. create new container
  2. open encryp.ch (it's AAAA is 2a0c:b641:6f1:55:656e:6372:726f:6f74)
  3. open new tab within the same container
  4. open git.encryp.ch (it's AAAA is 2a0c:b641:6f1:55:6769:7465:6e63:7200)
  5. firefox thinks that git.encryp.ch has IPv6 address 2a0c:b641:6f1:55:656e:6372:726f:6f74

Actual results:

IPv6 address of git.encryp.ch was consufed with encryp.ch one

Expected results:

Each (sub) domain have it's own IPv6

Component: Untriaged → Networking: DNS
OS: Unspecified → Linux
Product: Firefox → Core
Hardware: Unspecified → x86_64

This seems a lot like bug 1420777.
We want to fix it soon. The gist of it is if one domain returns a cert valid for the other, and there's an overlap in the DNS records of the domains, then they will be coalesced.
If that's not the case for you please let me know.

Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Duplicate of bug: http2-connection-coalescing
Flags: needinfo?(me)
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.