Java applet crashes when attempting to modify edit field on Mac OS 10.2.[1/2]

RESOLVED DUPLICATE of bug 163940

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED DUPLICATE of bug 163940
16 years ago
8 years ago

People

(Reporter: ziph, Assigned: Joe Chou)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2b) Gecko/20021016

As part of an online game, I run a Java applet (using I believe version 1.3
Java).    Under OS X 10.2.1, it would reliably crash the program if I typed in
certain edit fields as the first editing operation after opening the
application.  On OS X 10.2.2, it crashes the application on (seemingly) any edit
field.

Reproducible: Always

Steps to Reproduce:
The short answer is open Java app, bring up edit field, attempt to type in edit
field, click 'OK' to 'App has unexpectedly quit' message.

I can't show you the application, since it is proprietary and controlled by NDA
and login.
Actual Results:  
Browser crashes (all sessions)

Expected Results:  
At least, not crashed (even if app is buggy).  Ideally, allowed me to edit the
field.

Have crash logs from Mozilla.  Will attach.

There are several crashes in the log.  I believe they are all from the same
problem.  Certainly, the last few are.
(Reporter)

Comment 1

16 years ago
Created attachment 105968 [details]
Text file: OS X crash reporter log for Mozilla

Log from OS X crash reporter showing state at crash.  Believe all crashes are
from same problem over last couple of months.  Matching Java console log from
most recent session is:

|MRJ Plugin for Mac OS X v1.0.1
|[starting up Java Applet Security @ Wed Nov 13 01:32:52 EST 2002]
|no proxy
|
|Attempting to connect to [host suppressed]:[port suppressed]
|New Socket created
|establishConnection exiting happily
|writeLine() writing: SEND 
and then a bunch of readline() commands

Updated

16 years ago
Keywords: crash

Comment 2

16 years ago
do you have any URL ?

Comment 3

16 years ago
Reporter, for future reference, you should not attach your entire Mozilla crash
log; just the single crash report relevant to the crash in question need be
attached.

Stack looks like bug 163940.

Comment 4

16 years ago
ziph@marrach.skotos.net, can you still reproduce this problem using a current
nightly build? If so, please be sure TalkBack is activated, and let us know the
incident ID.

Comment 5

14 years ago

*** This bug has been marked as a duplicate of 163940 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.