Closed Bug 1797469 Opened 1 month ago Closed 1 month ago

[wayland] Maximizing/restoring window has become delayed with large numbers of tabs

Categories

(Firefox :: Tabbed Browser, defect)

Firefox 108
defect

Tracking

()

VERIFIED FIXED
108 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox106 --- unaffected
firefox107 --- unaffected
firefox108 --- verified
firefox109 --- verified

People

(Reporter: ke5trel, Assigned: emilio)

References

(Blocks 2 open bugs, Regression)

Details

(Keywords: perf, regression)

Attachments

(3 files)

STR:

  1. Start with MOZ_ENABLE_WAYLAND=1 on Ubuntu 22.04.
  2. Restore a window session with 2000 tabs.
  3. Maximize the window.

Expected:

The window maximizes immediately.

Actual:

The window maximizes after a delay, the length of the delay increases with the number of tabs. It does not happen with the native system titlebar enabled (browser.tabs.inTitlebar = 0) or with XWayland.

Performance profile:
https://share.firefox.dev/3zgABcV

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=894ad5982bff38a17909b61323273417a4662650&tochange=47e9c3d582b3a791cdf7914588ff15965cc8506e

Regressed by Bug 1795804.

:emilio, since you are the author of the regressor, bug 1795804, could you take a look? Also, could you set the severity field?

For more information, please visit auto_nag documentation.

Flags: needinfo?(emilio)

Only dialog elements can have backdrops. The current selector right now
acts like a global selector which causes a massive restyle when
maximizing / restoring the window.

Assignee: nobody → emilio
Status: NEW → ASSIGNED

Some appearance changes like from -moz-window-titlebar to
-moz-window-titlebar-maximized shouldn't really cause layout of the
whole browser area.

Depends on D160354

Well, that's kind of expected I suspect. We now draw with the updated styles, all that work was happening after maximizing... But most of that work seems it could be faster.

Flags: needinfo?(emilio)
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/edb9bc20edad
Use a more specific selector for rounded corners of backdrops. r=stransky
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 108 Branch
QA Whiteboard: [qa-108b-p2]

Reproduced the issue on Firefox 108.0a1 (2022-10-26) on Ubuntu 22.04 Wayland by following the STR from Comment 0.

The issue is fixed on Firefox 108.0a1 (2022-11-01) and 109.0a1 (2022-11-23) on the same system and the Maximize action is much faster.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-108b-p2]
You need to log in before you can comment on or make changes to this bug.