Status

()

Core
Plug-ins
P5
minor
RESOLVED DUPLICATE of bug 132759
15 years ago
15 years ago

People

(Reporter: Nick Konstadoglou, Assigned: Peter Lubczynski)

Tracking

Trunk
Future
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PL2:NA], URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2b) Gecko/20021016

Poor flash performance. It is much faster with IE. It may be of my slow CPU (P2
350mhz) but that doesn't explain why it works much faster with IE. Well
sometimes it seems to work fine for a while but it goes back slow again. Compare
it with IE to see what I mean. This may be Macromedia's fault tho. I made the
.swf so if it's the .swf's fault you can blame me :-)

Reproducible: Sometimes

Steps to Reproduce:
1.visit url http://www.yahob.gr/NEWsite/index4.shtml and compare Mozilla with IE
Actual Results:  
Flash performed poorly compared to IE

Expected Results:  
Performance equal to IE.

Comment 1

15 years ago
IE uses ActiveX controls, Netscape and Opera use NPAPIs, that means that IE uses
a completely different set of code to rprocess plug-ins.

Performance is also affected by how the author created the plug-in, they may
have used memory intensive functions within the plug-in instance, and in the
ActiveX version used a different set of functions.

It aslo depends on how the site sniffs the users browser, there may be incorrect
js used to reallocate pages

At this particular location, if you access the swf file directly, it loads
promptly and correctly, which is a good indication that the site has somehow
used incorrect sniffing code.

Try going to:
http://www.yahob.gr/NEWsite/flash/123.swf

Here is the js they use at the top of the page:
<script language="JavaScript">
<!--
function MM_reloadPage(init) {  //reloads the window if Nav4 resized
  if (init==true) with (navigator) {if
((appName=="Netscape")&&(parseInt(appVersion)==4)) {
    document.MM_pgW=innerWidth; document.MM_pgH=innerHeight;
onresize=MM_reloadPage; }}
  else if (innerWidth!=document.MM_pgW || innerHeight!=document.MM_pgH)
location.reload();
}
MM_reloadPage(true);
// -->
</script>

Testing that page in IE 6 and the flash does not load, however the rest of the
page partially loads.

Comment 2

15 years ago
My results:
With IE5.5 some Navigation (?) is loaded (mail, forum, games), but it does not
work. Info on right mouseclick: Flash 3 (?!)

With Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2b) Gecko/20021103 I get a
white area with blue growing cicles when museover
Info on right mouseclick: Flash 6

With NN4.78 I get a white area (only)

With OPERA: Page did not load (might have eben a system resources problem)

Comment 3

15 years ago
assigning to AV to help look at the js and rendering.
Priority: -- → P5
Whiteboard: [PL2:NA]
Target Milestone: --- → Future

Comment 4

15 years ago
reassign
Assignee: beppe → peterl

Comment 5

15 years ago
Please check with a recent build and latest Flash 6, you can get it here:
ftp://ftp.netscape.com/pub/netscape7/english/7.02/windows/win32/eehxkt/flash.xpi

The Flash performance issue was likely fixed with bug 132759.

*** This bug has been marked as a duplicate of 132759 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.