If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Cursor focus should be the URL bar when a page loads.

VERIFIED INVALID

Status

Camino Graveyard
Location Bar & Autocomplete
VERIFIED INVALID
15 years ago
15 years ago

People

(Reporter: Carlo, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021112 Chimera/0.6+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021112 Chimera/0.6+

Cursor focus should be the URL bar when a page loads (even when empty) so that
one can immediatly type an URL. Or, when pressing the "tab" key, the URL line
should be selected. Seems easy to fix ;-) and a real time saver.... 

Reproducible: Always

Steps to Reproduce:
1. Open new page
2. Type URL
3.

Actual Results:  
Nothing

Expected Results:  
URL being typed should appear in URL bar
(Assignee)

Comment 1

15 years ago
this is a dupe.
Whiteboard: DUPEME

Comment 2

15 years ago
Invalid. When a page loads, focus is given to the content area intentionally.
Focus is only given to the URL field in a new *blank* window or tab.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

15 years ago
I still consider it a nuisance/bug, because the objective is to be able to type
a new URL fast without using the mouse to click on the location bar. At least
pressing the TAB key should cycle through all the clickable areas of a page
INCLUDING the location bar. Maybe "Shift Tab" should always put the focus on the
location bar ?
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 4

15 years ago
Carlo, use Cmd-L it will put the focus in the Location bar and show the location
bar in a sheet if the toolbar is not visible. So Cmd-L always put the focus in it.

Comment 5

15 years ago
Carlo, that's another bug. Search Bugzilla for it. This is Invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → INVALID
agreed, v.
Status: RESOLVED → VERIFIED
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.