Autocomplete crash: one single option, hit tab (maybe), down arrow, enter, crashed

VERIFIED DUPLICATE of bug 184202

Status

()

Firefox
Address Bar
--
critical
VERIFIED DUPLICATE of bug 184202
15 years ago
15 years ago

People

(Reporter: Peter Beckman, Assigned: Joe Hewitt (gone))

Tracking

({crash, stackwanted})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021029 Phoenix/0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021029 Phoenix/0.4

I was on paypal filling out a form.  Asked for my address.  I started to enter
it when a little box (autocomplete) popped up below the input box with my
current address.  Thinking "COOL!" I hit the down arrow and enter, hoping it
would highlight the first and only option.  It never highlighted it, and then
phoenix crashed.  I'm using the 0.4 release, not a nightly tarball, running
Win2K SP3.  At the time I was running Winamp, TeraTerm + SSH (3 windows), a
Windows File Explorer, Trillian, and had three windows open with AOL IM users
via Trillian.  At the time of writing I had 37 processes running, ~6-10% CPU
usage, and Mem Usage: 165012k / 1275348k.  I have 512MB memory in the box, and a
1.2Ghz celeron.

Peter

Reproducible: Didn't try

Steps to Reproduce:
1. Fill out a form.  when it asks (annoyingly) if it should save values, say Yes.
2. Go back to that form later.  Try filling it out.  Hopefully you have one entry.
3. Try to select that entry when it pops up.  This caused a crash.
4. Have 5 or 6 tabs open to different sites at the time too, and use like the
second to last one for the test.

Actual Results:  
Phoenix crashed complete.  I'd send a log, but I'm not sure where it gets written.

Expected Results:  
Not crashed, highlighted the selection, and filled in the input box for me.

No Talkback in this release.

Updated

15 years ago
Keywords: crash, stackwanted

Comment 1

15 years ago
I have experienced this same problem about a dozen times on a nearly identical
system (Win2K running Phoenix 0.4). I will have the autocomplete window pop open
beneath a form field, press TAB to select the entry, then ENTER to select it,
and Phoenix crashes with an error stating that Windows is creating a log (I
don't know where that log is either).

The problem is that I am not able to consistently reproduce it.

At first I thought it happened when the entry in the autocomplete window was
longer than the window itself. But that explanation has not been observed
consistently.

It seems that the crash is more likely to happen the very first time I use
autocomplete after I have opened Phoenix. After Phoenix crashes once and I
reopen it, autocomplete works, mostly, without a snag.

Other times, however, I will have five or more tabs open, have been running
Phoenix all day, and then autocomplete will crash the browser. Perhaps this
happens the first time I use autocomplete in a new tab -- but I'm not sure.

I'd be happy to submit the error log that is created on the crash if someone
could point me in the right direction. Thanks for all your work! Phoenix is the
only browser I use anymore. Huzzah!

Comment 2

15 years ago
I can confirm on latest Phoenix/0.5 20021212 Win32 nightly build.
It crashes even when i don't try to select anything by pressing down-arrow.
Starting typing the same text as the saved one in autocomplete history is enough to cause the Phoenix crash.

The weird thing is that it don't happen closely after I start Phoenix, only a bit later after some activity was made.

Comment 3

15 years ago
This bug is a duplicate one of bug #184202... 

*** This bug has been marked as a duplicate of 184202 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
Mass verifiying old duplicates.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.