Closed Bug 1798707 Opened 3 months ago Closed 2 months ago

DLL block request: ExplorerPatcher.amd64.dll

Categories

(Toolkit :: Blocklist Policy Requests, defect)

Firefox 106
Desktop
Windows 11
defect

Tracking

()

RESOLVED FIXED
109 Branch
Tracking Status
firefox109 --- fixed

People

(Reporter: kbbbles, Assigned: gstoll, NeedInfo)

Details

Crash Data

Attachments

(1 file)

Windows DLLBlocklist request form

  1. How were we aware of the problem?
    Crash reports. Firefox crashes anywhere from 1-4 times when starting up with ExplorerPatcher installed on the computer. This affects even a clean install of Firefox - tested it on a computer I completely reformatted & reinstalled Windows on. Firefox worked normally until ExplorerPatcher was installed.
    https://crash-stats.mozilla.org/report/index/69e70001-6fa5-43a0-80c3-dbfbb0221029

  2. What is a suspicious product causing the problem?
    ExplorerPatcher, specifically ExplorerPatcher.amd64.dll - on my Intel laptop, deleting this DLL completely resolves the issue. Simply blocking the DLL in Firefox will fix the issue. I'm unable to do this on my AMD desktop without breaking ExplorerPatcher.

  3. Is the product downloadable? If so, do we have a local repro?
    Yes, from here:
    https://github.com/valinet/ExplorerPatcher

  4. Which OS versions does the problem occur on?
    Windows 11, seems to have affected 22H2 onward but may also be affecting 21H2 (I don't have it available to test with). Here's the Windows build info I'm using for both my Intel laptop & AMD desktop:
    Edition Windows 11 Pro (*this is Windows 11 Home on the Intel laptop)
    Version 22H2
    Installed on ‎2022-‎10-‎04
    OS build 22621.755
    Experience Windows Feature Experience Pack 1000.22636.1000.0

  5. Which process types does the problem occur on?
    I'm not sure how to answer this question, I can check it out if needed but please let me know how to figure it out.

  6. What is the maximum version of the module in the crash reports?
    I'm also not familiar with how to answer this one.

  7. Is the issue fixed by a newer version of the product?
    Issue persists even on the latest versions of Firefox (stable) and ExplorerPatcher.

  8. Do we have data about the module in the third-party-module ping?
    If this information isn't in the crash report and I need to provide it, please let me know how to find it.

  9. Do we know how the module is loaded?
    Seems to be being loaded through explorerframe.dll?

  10. Describe your conclusion.
    I believe blocking ExplorerPatcher.amd64.dll from Firefox will resolve the issue. If compatibility can be added, that would be great - but ExplorerPatcher just adds some convenience into Windows 11 File Explorer so it shouldn't have any effect on Firefox whether it's loaded or blocked.

Jared, it looks like you handled the last dll block. Are you the right person to work on this?

Assignee: nobody → gstoll
Crash Signature: explorerpatcher.amd64.dll
Crash Signature: explorerpatcher.amd64.dll → [@ explorerpatcher.amd64.dll]
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Thanks for the report! I've installed ExplorerPatcher and after I turned the File Explorer->Register as shell extension setting on, I verified that it gets loaded into Firefox. But I'm not seeing a crash.

kbbbles: are there other settings I can try to toggle to make the crash happen?

Flags: needinfo?(kbbbles)

I contacted the developer and he was also unable to reproduce, but based on the crash reports published a new version (22621.608.51.6) that he thinks will fix the crash. We're going to wait and see if we get crash reports with the new version; if not, we can just block versions older than that.

Still seeing crashes with 22621.608.51.6 (examples 1 and 2). Contacted developer again.

Since it's been a while and we haven't gotten a response, I'm going to block all versions of this DLL.

kbbles did a great job with the questionnaire above, I'm just going to add a few details:

  1. How were we aware of the problem?
    Report from kbbels as well as other crash reports.

  2. What is a suspicious product causing the problem?
    ExplorerPatcher, specifically ExplorerPatcher.amd64.dll. Turning on the "Register as shell extension" makes the DLL inject itself into Firefox.

  3. Is the product downloadable? If so, do we have a local repro?
    Yes, it's downloadable from https://github.com/valinet/ExplorerPatcher. I'm not able to reproduce the crash, but kbbels is.

  4. Which OS versions does the problem occur on?
    Based on the crash reports, this seems to only happen on Windows 11.

  5. Which process types does the problem occur on?
    This is a crash at startup and happens in the parent process.

  6. What is the maximum version of the module in the crash reports?
    22622.450.50.3 is the maximum version seen in the crash reports. Note that 22621.608.51.6 is the latest release from GitHub, and this version shows up as well.

  7. Is the issue fixed by a newer version of the product?
    No.

  8. Do we have data about the module in the third-party-module ping?
    Yes.

  9. Do we know how the module is loaded?
    It's being loaded as a shell extension.

  10. Describe your conclusion.
    We should blocklist all versions of ExplorerPatcher.amd64.dll.

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 109 Branch
You need to log in before you can comment on or make changes to this bug.