Closed Bug 179935 Opened 22 years ago Closed 21 years ago

{ib}Problem to hide a div layer

Categories

(Core :: Layout: Block and Inline, defect, P2)

x86
Windows NT
defect

Tracking

()

VERIFIED FIXED
Future

People

(Reporter: kdu, Unassigned)

References

()

Details

(Keywords: testcase)

User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2b) Gecko/20021016
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.2b) Gecko/20021016

Depending on the definition of the css 
<style type="text/css">
<!--
//	.boxdisplay {position:relative;display:inline;}
// the line above causes the error
// if i remove the "display:inline" item it is ok
// after inserting this line after this comment every thing is also fine
	.boxdisplay {position:relative;display:inline;}
-->
</style>

After hiding and showing the div layer:

<script type="text/javascript">
<!--
function ShowTable() {	document.getElementById("menu103").style.display = "";}
function HideTable() { 	document.getElementById("menu103").style.display = "none";}
//-->
</script>

the next time mozilla does not hide the div again.

bill browser does :-(
and this all depends only on the position of the definition 
of the style.

"if i do this it hurts"
Doc: "dont do this"
but this is not my code so i am not able to change em

regards
kladde

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
>  // the line above causes the error

That's not a comment, you _do_ realize that, right?

Yet another block-inside-inline-dynamic-thing issue...
Assignee: jst → other
Status: UNCONFIRMED → NEW
Component: DOM Level 0 → Layout
Ever confirmed: true
QA Contact: desale → ian
Summary: Problem to hide a div layer → {ib}Problem to hide a div layer
Priority: -- → P2
Target Milestone: --- → Future
->Block & Inline
Assignee: other → block-and-inline
Component: Layout → Layout: Block & Inline
Keywords: testcase
Fixed by bug 171830, looks like.
Depends on: 171830
*** Bug 190720 has been marked as a duplicate of this bug. ***
er, fixed.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
testcase works. Verifying 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.