Dragging a link from mozilla should provide the text/uri-list target.

VERIFIED DUPLICATE of bug 109798

Status

SeaMonkey
General
VERIFIED DUPLICATE of bug 109798
16 years ago
13 years ago

People

(Reporter: Thomas Leonard, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020913 Debian/1.2.6-2
Build Identifier: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020913 Debian/1.2.6-2

Related to bug 86371 (dragging into mozilla didn't work, now fixed), there is a
problem dragging links from the page out of a browser window. Mozilla currently
provides the following targets:

text/x-moz-url
_NETSCAPE_URL
text/html
text/unicode
text/plain

For compatibility with other software, the correct target for the URI of the
resource is text/uri-list. This may be somewhat related to bug 109798 (dragging
from XP widgets).


Reproducible: Always

Steps to Reproduce:
1. Open any page containing an <a> link
2. Drag the link into a ROX-Filer window, or other XDND compatible program.


Actual Results:  
An error box appeared:

"Sorry - I require a target type of text/uri-list or XdndDirectSave0."

Expected Results:  
Offered text/uri-list instead of (or in addition to) _NETSCAPE_URL.
This is the same as bug 109798, exactly.  The same code handles both.

*** This bug has been marked as a duplicate of 109798 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.