Quantum.com products & services page always crashes on load.

RESOLVED DUPLICATE of bug 173668

Status

Camino Graveyard
General
--
critical
RESOLVED DUPLICATE of bug 173668
16 years ago
16 years ago

People

(Reporter: Matt Carrell, Assigned: saari (gone))

Tracking

({crash, topcrash})

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021104 Chimera/0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021104 Chimera/0.6

Will always crash my iBook and iMac G3 loading this page on Chimera v0.6

Reproducible: Always

Steps to Reproduce:
1. Load http://www.quantum.com/AM/products/default.htm
2.
3.

Actual Results:  
Crash..  Goes to Talkback.

Expected Results:  
loaded the page.

Tested the page also with Mozilla 1.2b  <-- Mozilla didn't crash, but Chimera does.
(Reporter)

Updated

16 years ago
Keywords: crash, topcrash
Summary: Quantum.com products & services page always crashes on load. → Quantum.com products & services page always crashes on load.

Comment 1

16 years ago
Crashes for me, and stack trace is the same as bug 173668. Suspect it's a dupe.
(Reporter)

Comment 2

16 years ago
OK, I think the last comment was onto something.  I looked into the code on the
Quantum site, and it is the following line of code which brings on the crash
condition:

<P><IMG class=bracket height=12 alt=""
src="file:///C:/DOCUME~1/cfolayan/LOCALS~1/Temp/1//images/linkBracket_L.gif"
width=8 border=0><A href="/AM/products/dlt/sdlt320/">Learn More</A>
<IMG class=bracket height=12 alt=""
src="file:///C:/DOCUME~1/cfolayan/LOCALS~1/Temp/1//images/linkBracket_R.gif"
width=8 border=0></P>


It is a mistake in their code which tells the browser to look for an image on a
local drive C:... well, naturally the filename, path, and drive name C: are not
likely to exist on anyone's computer running Chimera, so the crash is brought on
because Chimera is not handling the bad URL exception properly.  Further proof.. 

Enter this line from their code alone into your URL bar:

file:///C:/DOCUME~1/cfolayan/LOCALS~1/Temp/1//images/linkBracket_L.gif


Instead of invalid path complaint (naturally we won't find a drive C: on a
Mac).. we get a crash.


* See stack traces filed with TalkBack:
TB30852Y, TB30394G, TB30387Q

*** This bug has been marked as a duplicate of 173668 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.