Closed Bug 1799691 Opened 1 year ago Closed 6 months ago

apple-touch-icon used instead of icon

Categories

(Fenix :: General, defect)

All
Android
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1772264

People

(Reporter: freko, Unassigned)

Details

(Whiteboard: [qa-triaged])

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:106.0) Gecko/20100101 Firefox/106.0

Steps to reproduce:

<link rel="icon" type="image/x-icon" href="path/to/icon/icon.ico">

<link rel="apple-touch-icon" type="image/png" href="path/to/icon/apple-touch-icon.png">

icon.ico have 8 icons, range from 16x16-256x256 px.
apple-touch-icon.png is 512x512 px.
We have different designs for the icon and apple-touch-icon, one is design for the app to home screen and the other for the tabs in a browser.

Actual results:

Firefox on android uses the apple touch icon instead of regular icon

Expected results:

Other browsers don't do this, and it should use regular icon before apple-touch-icon.
Other browsers and Firefox on other devices chooses not to use the apple-touch-icon, but only on android is got chosen. This icon is only used for the add to home screen and should only be there. This issue is more visible on dark mode.

The severity field is not set for this bug.
:cpeterson, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(cpeterson)

To add to the initial description, Apple forces certain design restrictions upon us that prevent these icons from being generally useful. The primary being that it cannot have any transparency.

Flags: needinfo?(cpeterson)

Ahh, I missed this report otherwise I would not open a new one: https://bugzilla.mozilla.org/show_bug.cgi?id=1837655

However, it appears the issue won't be fixed any time soon according to my ticket.

Just want to add my 2 cents that apple-touch-icon is definitely not supposed to be used in browsers because apple icons have unique shape and colour requirements that are not suitable for browser use.

Closing this ticket as duplicate of 1772264.

Status: UNCONFIRMED → RESOLVED
Closed: 6 months ago
Duplicate of bug: 1772264
Resolution: --- → DUPLICATE
Whiteboard: [qa-triaged]
Severity: -- → S3
You need to log in before you can comment on or make changes to this bug.