Closed Bug 1800567 Opened 13 days ago Closed 7 days ago

[Bug]: privacy.resistFingerprinting breaks touch gestures

Categories

(Core :: DOM: Events, defect)

Unspecified
Android
defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox-esr102 --- affected
firefox107 --- wontfix
firefox108 --- wontfix
firefox109 --- affected

People

(Reporter: kbrosnan, Unassigned)

References

(Blocks 1 open bug, Regression, )

Details

(Keywords: regression)

From github: https://github.com/mozilla-mobile/fenix/issues/21225.

Steps to reproduce

  1. Ensure privacy.resistFingerprinting is true in about:config
  2. Navigate to openstreetmap.org
  3. Try to manipulate the map via panning or pinch-to-zoom

Expected behaviour

Touch gestures should function properly

Actual behaviour

Touch gestures do not work

Device name

No response

Android version

Android 11

Firefox release type

Firefox

Firefox version

92.1.1

Device logs

No response

Additional information

Can reproduce on:

  • Firefox Beta 93.0.0-beta.1, with the exception that panning does work
  • Firefox Nightly 94.0a1, with the exception that panning does work
  • Mull 92.1.1, with the exception that panning does work
  • Mull 91.2.0
  • Fennec F-Droid 91.2.0
  • Tor Browser for Android 10.5.5 (91.2.0)

Cannot reproduce on official 92.1.1 due to lack of about:config.

Other things:

Other user reports:

┆Issue is synchronized with this Jira Task

Change performed by the Move to Bugzilla add-on.

Looks like an intentional regression from bug 1382499.

Has STR: --- → yes
Regressed by: 1382499

Set release status flags based on info from the regressing bug 1382499

(In reply to Kevin Brosnan [:kbrosnan] from comment #1)

Looks like an intentional regression from bug 1382499.

Hello Tim, would you be the right person to confirm if yhe above comment is true?

Flags: needinfo?(tihuang)
Severity: -- → S3

When fingerprinting resistance is enabled, Firefox will spoof the touch API to neutralize fingerprinting vector(Bug 1382499). Therefore, this is the intended behavior when RFP is enabled.

Flags: needinfo?(tihuang)

Thanks for the confirmation, Tim!

Status: NEW → RESOLVED
Closed: 7 days ago
Resolution: --- → INVALID

While this is expected for desktop and the mouse events will still be sent. This breaks Firefox Android beta/nightly users that have enabled RFP and some downstream forks like Mull that ship RFP as a default. The user is extremely unlikely to have a mouse attached.

Blocks: rfp-android
You need to log in before you can comment on or make changes to this bug.