Closed Bug 1801840 Opened 2 months ago Closed 2 months ago

alert dialog cover docked DevTools panel

Categories

(DevTools :: General, defect, P1)

Firefox 107
defect

Tracking

(firefox-esr102 unaffected, firefox107 verified, firefox108 verified, firefox109 verified)

VERIFIED FIXED
109 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox107 --- verified
firefox108 --- verified
firefox109 --- verified

People

(Reporter: david.balazic, Assigned: emilio)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:107.0) Gecko/20100101 Firefox/107.0

Steps to reproduce:

  • open a web page
  • open Web Developer Tools with F12
  • click on the web page on an element that opens an alert dialog (like alert('foo);)

(actually the alert is triggered by JavaScript code that executes on load of the page, not user click)

Actual results:

the devtools GUI at the bottom of the page is covered in gray overlay and can not be used

Expected results:

devtools usable

The Bugbug bot thinks this bug should belong to the 'DevTools::General' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → General
Product: Firefox → DevTools

workaround: use devtools in a separate window

in that case it is not blocked by JavaScript alert dialogs

Simpler STR:

  1. On this page, opens devtools, select the console
  2. Execute alert("hi")

It looks like it was regressed in 107, I'll run mozregression to find what caused it

Status: UNCONFIRMED → NEW
Ever confirmed: true

Okay, mozregression gave me this push https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=12300304d39453250dfdaa8e249056659a20adbc&tochange=50f72898d7b8b88985dc5d7595007b426a46c93e

I suspected Bug 1791972 so I backed out https://hg.mozilla.org/mozilla-central/rev/fcfa74481179 , and I can confirm this fixes the issue

It's important to fix this issue as users might use alert to pause the application and do some work in DevTools

Regressed by: 1791972
Summary: javascript alert dialog cover Web Developer Tools → alert dialog cover docked DevTools panel

Set release status flags based on info from the regressing bug 1791972

:emilio, since you are the author of the regressor, bug 1791972, could you take a look? Also, could you set the severity field?

For more information, please visit auto_nag documentation.

Flags: needinfo?(emilio)

This makes alert take the same area as the status panel, partially
backing out the regressing bug.

.browserStack is also relatively-positioned, so this works too. I think
I didn't realize this while writing bug 1791972 because the rule was in
a UA sheet (all <stack>s are relatively positioned, apparently).

This restores the behavior when devtools is toggled vertically. On
responsive mode this still covers the top toolbar, but that was the
pre-existing behavior. Could be fixed in a follow-up with some z-index
tweaking...

Assignee: nobody → emilio
Status: NEW → ASSIGNED
Severity: -- → S2
Priority: -- → P1
Blocks: 1802338
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c5387d626df7
Go back to using .browserStack rather than .browserContainer for tab dialog box. r=Gijs,nchevobbe

Please nominate this for beta and release uplift when ready

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 109 Branch

The patch landed in nightly and beta is affected.
:emilio, is this bug important enough to require an uplift?

  • If yes, please nominate the patch for beta approval.
  • If no, please set status-firefox108 to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(emilio)

Comment on attachment 9304739 [details]
Bug 1801840 - Go back to using .browserStack rather than .browserContainer for tab dialog box. r=dao,Gijs,nchevobbe

Beta/Release Uplift Approval Request

  • User impact if declined: comment 0
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: comment 0
  • List of other uplifts needed: none
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): One-liner, effectively.
  • String changes made/needed: none
  • Is Android affected?: No
Flags: needinfo?(emilio)
Attachment #9304739 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9304739 [details]
Bug 1801840 - Go back to using .browserStack rather than .browserContainer for tab dialog box. r=dao,Gijs,nchevobbe

(see above)

I think it's safe for a ride-along.

Attachment #9304739 - Flags: approval-mozilla-release?

Comment on attachment 9304739 [details]
Bug 1801840 - Go back to using .browserStack rather than .browserContainer for tab dialog box. r=dao,Gijs,nchevobbe

Approved for 108.0b7.

Attachment #9304739 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Reproduced the issue with Firefox 109.0a1 (20221122214324) on Windows 10x64. After following STR from comment 3 the devtools cannot be used.
The issue is verified fixed with Firefox 109.0a1 (2022-11-27) and 108.0b7 on Windows 10x64, macOS 10.15, and Ubuntu 20.04. The Web Developer Toolbox can be used as expected after executing an alert("hi") command inside the console.

Comment on attachment 9304739 [details]
Bug 1801840 - Go back to using .browserStack rather than .browserContainer for tab dialog box. r=dao,Gijs,nchevobbe

Approved for 107.0.1

Attachment #9304739 - Flags: approval-mozilla-release? → approval-mozilla-release+

Verified fixed with Firefox 107.0.1 (20221128144904) on Windows 10x64, macOS 11, and Ubuntu 20.04. After the alert is triggered the dev tools can be used.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.