import from ms outlook failed due to slash (/) in outlook folder name

RESOLVED DUPLICATE of bug 131013

Status

MailNews Core
Import
RESOLVED DUPLICATE of bug 131013
16 years ago
10 years ago

People

(Reporter: steve davis, Assigned: Cavin Song)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020823 Netscape/7.0
Build Identifier: it's in netscape 7.0 and the mozilla 1.1 download currently on the mozilla web site.

imported folder name from outlook contained slash.  caused all sorts of ugly
behaviors in mail program - lost data/messages, undeleteable and unrenameable
folders.  Suggested solution, scan the name coming from microsoft outlook for a
slash (and other magic characters if any) and replace them with something like a
space or dash.

Reproducible: Always

Steps to Reproduce:
1.make a folder in outlook with a slash in the name
2.import the email in the folder into the mail program
3.

Actual Results:  
folders in mozilla mail program either contain a slash and no messages, or,
after restarting the program, the folder names are replaced with random numbers
with no emails.

Expected Results:  
replaced the slash or any other character that mozilla doesn't like with a space
and give a warning

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 131013 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.