Closed Bug 1803763 Opened 2 years ago Closed 2 years ago

Closed tab dismiss button tooltip says "Open ... in a new tab"

Categories

(Firefox :: Firefox View, defect)

defect

Tracking

()

VERIFIED FIXED
109 Branch
Tracking Status
firefox-esr102 --- unaffected
firefox107 --- unaffected
firefox108 --- unaffected
firefox109 + verified

People

(Reporter: dao, Assigned: kcochrane)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression, Whiteboard: [fidefe-2022-mr1-firefox-view])

Attachments

(2 files)

The dismiss button should have a dedicated tooltip instead of inheriting the list item's one. It looks like the button does have an aria-label; let's make that title instead which is automatically accessible?

Also the way the aria-label is built (${dismissLabel} ${tab.title}) seems like it's going to be wrong for various languages; not sure why flod removed fluent-reviewers from the patch?

Flags: needinfo?(kcochrane)
Flags: needinfo?(francesco.lodolo)
Assignee: nobody → kcochrane
Status: NEW → ASSIGNED
Flags: needinfo?(kcochrane)

(In reply to Dão Gottwald [::dao] from comment #0)

Also the way the aria-label is built (${dismissLabel} ${tab.title}) seems like it's going to be wrong for various languages; not sure why flod removed fluent-reviewers from the patch?

The only explanation is that I opened the wrong phabricator link. I clearly remember opening the diff and there were no strings in the patch (in hindsight, probably looked at the partial diff), and assumed it was a missed rebase that triggered herald.

And you're correct, the whole string should be exposed (e.g. Dismiss ${tabTitle}), not just the partial.

Flags: needinfo?(francesco.lodolo)

Sorry for the mixup here! I definitely see the value in switching from aria-label to title, so I'm working on fix for that and the other issue you've brought up. Thanks for catching that, Dao!

Pushed by kcochrane@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6c9b61f0bdaf
Add title attribute to recently closed tab dismiss button r=dao,fluent-reviewers,flod

Backed out for causing bc failures on browser_recently_closed_tabs.js.

Flags: needinfo?(kcochrane)
Attached image fluent-error

Seeing this error when running a debug build. Looking into a fix now.

Flags: needinfo?(kcochrane)
Pushed by kcochrane@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a2f9ac51b94b
Add title attribute to recently closed tab dismiss button r=dao,fluent-reviewers,flod
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 109 Branch
Flags: qe-verify+

Reproduced the issue with Firefox 109.0a1 (2022-12-02) on Windows 10x64.
The issue is verified fixed with Firefox 109.0b3 on Windows 10x64, macOS 10.15 and Ubuntu 20.0.4. The Dismiss tab title tooltip is displayed when hovering over the dismiss button.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: