Last Comment Bug 180378 - macromedia.com - Flash ought to support <param name="movie..."> in addition to data attribute
: macromedia.com - Flash ought to support <param name="movie..."> in addition t...
Status: RESOLVED INCOMPLETE
[plugin]
:
Product: Tech Evangelism Graveyard
Classification: Graveyard
Component: English US (show other bugs)
: unspecified
: All All
: -- normal
: ---
Assigned To: english-us
:
:
Mentors:
: 272343 (view as bug list)
Depends on: 230890
Blocks: 161891
  Show dependency treegraph
 
Reported: 2002-11-15 13:56 PST by Arun Ranganathan
Modified: 2015-04-19 23:39 PDT (History)
11 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Arun Ranganathan 2002-11-15 13:56:20 PST
This bug follows on the heels of bug 161891 in which we decided against
implementing special invocation params for plugins.  Here is the issue:

Currently, Flash player can be invoked in Netscape/Mozilla browsers with markup
of the following kind:

<object id="myFlash" data="someFlash.swf" type="application/x-shockwave-flash"
width="366" height="142">    	
    	<param name="quality" value=high>
    	<param name="swliveconnect" value="true">
</object> 

This is great, because we use the W3C approved "data" attribute in the object
tag.  But it does not work if we use <param name="movie" src="someFlash.swf">. 
For some reason, Flash in Gecko does not recognize the <param name="movie"..."
invocation, but does recognize the data attribute invocation.
It would be nice if Flash could support *all* their params, including param
name="movie" which is a very well known way of invoking Flash.
Comment 1 Arun Ranganathan 2002-11-15 14:00:10 PST
The attachment that goes with bug 161891 shows what goes wrong:
http://bugzilla.mozilla.org/attachment.cgi?id=94992&action=view

Comment 2 Arun Ranganathan 2002-11-15 14:04:56 PST
Incidentally, IE does NOT recognize data attribute, but only recognizes param
name="movie" param.  Thus, IE has the reverse problem that we have.  One single
object tag that works in IE and Mozilla might be:

<object id="myFlash" data="javascript_to_flash.swf"
type="application/x-shockwave-flash" width="366" height="142">
	
    	<param name="movie" value="javascript_to_flash.swf">
    	<param name="quality" value=high>
    	<param name="swliveconnect" value="true">
</object>

But here, data is ignored by IE, but respected by Mozilla.  The param
name="movie "... is respected by IE, but ignored by Mozilla. 
Comment 3 mmc 2003-01-17 05:04:26 PST
I have the same problem in this page:
   http://spazioinwind.libero.it/magicdice/about/
and putting the "data" attribute in the object tag hasn't solved the problem.
Comment 4 Nick Bebout 2003-06-12 19:59:48 PDT
SPAM: New Components
Comment 5 PikeUK 2005-03-07 08:45:20 PST
*** Bug 272343 has been marked as a duplicate of this bug. ***
Comment 6 Benjamin Smedberg [:bsmedberg] 2012-02-21 06:14:41 PST
We do forward the value to Flash, and this is a product decision on the Flash side, I don't see any reason to continue tracking it from the Mozilla side.

Note You need to log in before you can comment on or make changes to this bug.