Closed Bug 1803981 Opened 1 year ago Closed 1 year ago

only one table caption will render

Categories

(Core :: Layout: Tables, defect)

Firefox 107
defect

Tracking

()

RESOLVED DUPLICATE of bug 144517

People

(Reporter: vtwintiger, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:107.0) Gecko/20100101 Firefox/107.0

Steps to reproduce:

created a table with two captions, like:
<html lang="en">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<title>table caption bug</title>
<style>
table, th, td {
border: 1px solid black;
}
</style>
</head>
<body>
<table>
<caption>top caption</caption>
<caption style="caption-side: bottom;">bottom caption</caption>
<tbody>
<tr>
<td>a</td>
</tr>
<tr>
<td>b</td>
</tr>
</tbody>
</table>
</body>
</html>

Actual results:

Only the first caption renders (the second does not appear), but it is selectable on the page - here I copy/pasted from the page:
top caption bottom caption a
b

Expected results:

Both captions should render and display on the page.

Per https://developer.mozilla.org/en-US/docs/Web/HTML/Element/caption

If used, the <caption> element must be the first child of its parent <table> element.

The Bugbug bot thinks this bug should belong to the 'Core::Layout: Tables' component, and is moving the bug to that component. Please correct in case you think the bot is wrong.

Component: Untriaged → Layout: Tables
Product: Firefox → Core

The severity field is not set for this bug.
:jwatt, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(jwatt)
Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Duplicate of bug: 144517
Flags: needinfo?(jwatt)
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.