Closed Bug 180404 Opened 17 years ago Closed 17 years ago

mozilla does not seem to correctly style <col> tags in a table

Categories

(Core :: CSS Parsing and Computation, defect)

x86
Windows 98
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 4510

People

(Reporter: joh6nn, Assigned: dbaron)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1) Gecko/20020826

while working on a site, i tried to assign the same background image to an
entire column in a table.  it didn't work, so i checked IE's interpretation of
the code ( IE acted as i expected. that doesn't mean much, i know ), and then
checked the w3c to see if i was mistaken in my expectations.  according to this
page http://www.w3.org/TR/REC-html40/struct/tables.html#h-11.2.4 , i wasn't;
<col> tags are supposed to be stylable, but mozilla doesn't do this.

Reproducible: Always

Steps to Reproduce:
1. create a table of at least 2 rows and 2 columns.
2. create at least one <colgroup> with-in that table, and at least one <col>
inside that <colgroup>.
3. apply a style to that <col>

Actual Results:  
nothing; the style is not applied to the cells in the column

Expected Results:  
all cells in the appropriate column should receive the given style.

some sample code to demonstrate the bug follows:

<html>
<body>

<table border="1" width="50">

 <colgroup>
  <col style="color: #FF0000;">
 </colgroup>

 <tr height="25">
  <td> 1 </td><td> 2 </td>
 </tr>

 <tr height="25">
  <td> 1 </td><td> 2 </td>
 </tr>

</table>

</body>
</html>
Summary: mozilla does not seem to correctly <col> tags in a table → mozilla does not seem to correctly style <col> tags in a table
->Style System
Assignee: asa → dbaron
Component: Browser-General → Style System
QA Contact: asa → ian
(See also bug 915.)

*** This bug has been marked as a duplicate of 4510 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Note that in no case should "color" work as you think it should work.  See
http://www.w3.org/TR/CSS21/tables.html#q4 for the four properties that apply to
<col>.
Status: RESOLVED → VERIFIED
ok, duely noted.  but originally, i was attempting to manipulate the
background-image.  my use of color, was simply to demonstrate quickly that col's
don't seem to be doing ANYTHING with style, rather than simply ignoring
backgrounds ( which now makes sense, in light of bug 4510 ( by the way, i did
search; apologies for the duplication )).

out of curiosity, does anyone know why there are such restrictions on col's?  i
understand that cells are supposed to be children of rows, but in the special
case of columns, i would think the very point would be to have them inherit from
the column, and not the row.
You need to log in before you can comment on or make changes to this bug.